This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
JPCSP crashing (Linux 64bit, r2456)
JPCSP crashes in GUI thread upon selecting ISO if Xuggler native libs are installed/used.

Doesn't seem to matter how I've built Xuggler. I've tried using their built-in ffmpeg/etc libs, as well as using the system libs. I've also tried compiling against Sun Java 6 and OpenJDK 6. Doesn't appear to make a difference. Building Xuggler with the system libs builds fine. Tests pass. Building the Java side works, but with a failure in the com.xuggler.mediatool.MediaToolTest if that makes a difference.

I know it's Xuggler causing it as not setting LD_LIBRARY_PATH to point to Xuggler's native libraries allows JPCSP to run fine, albeit without the ability to use the media engine.

Is there something I'm missing, or is it just broken on Linux 64bit at the moment? If you need the crash log you'll have to tell me how to attach it as it would be too big to paste in here and the forum is rejecting it as an attachment.

OS: Debian Wheezy amd64
CPU: Intel Core 2 Duo T7700 2.4ghz
RAM: 3gb
GFX: nVidia Quadro 130M (like GeForce 8400)

Forum Jump:

Users browsing this thread: 1 Guest(s)