EmuNewz Network

Full Version: JPCSP crashing (Linux 64bit, r2456)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
JPCSP crashes in GUI thread upon selecting ISO if Xuggler native libs are installed/used.

Doesn't seem to matter how I've built Xuggler. I've tried using their built-in ffmpeg/etc libs, as well as using the system libs. I've also tried compiling against Sun Java 6 and OpenJDK 6. Doesn't appear to make a difference. Building Xuggler with the system libs builds fine. Tests pass. Building the Java side works, but with a failure in the com.xuggler.mediatool.MediaToolTest if that makes a difference.

I know it's Xuggler causing it as not setting LD_LIBRARY_PATH to point to Xuggler's native libraries allows JPCSP to run fine, albeit without the ability to use the media engine.

Is there something I'm missing, or is it just broken on Linux 64bit at the moment? If you need the crash log you'll have to tell me how to attach it as it would be too big to paste in here and the forum is rejecting it as an attachment.

OS: Debian Wheezy amd64
CPU: Intel Core 2 Duo T7700 2.4ghz
RAM: 3gb
GFX: nVidia Quadro 130M (like GeForce 8400)