This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Marvel Ultimate Alliance - ULUS10167
#1
Other game playable

great team jpcspAngel

[Image: 26389536.th.jpg]
[Image: 84984296.th.jpg]
[Image: 52433650.th.jpg]
3rd mission
[Image: 94026052.th.jpg]

In a laptop a 1,6Ghz,win xp[/align]
Reply

#2
using r 2956
still goes ingame
few errors and warnings in the log


Attached Files
.zip   log.zip (Size: 7.1 KB / Downloads: 19)
.zip   profiler.zip (Size: 390.43 KB / Downloads: 21)
Reply

#3
bf86e36 version
black screen on video

log and profiler : https://drive.google.com/file/d/1GtAb3XI...sp=sharing
Reply

#4
(02-04-2021, 01:27 PM)sum2012 Wrote: bf86e36 version
black screen on video

log and profiler : https://drive.google.com/file/d/1GtAb3XI...sp=sharing
Could you please try it using the external software renderer? To verify if this is an issue within sceMpeg (in which case the video will also be black) or if this is an issue with the renderering (in which case the video will be displayed).
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#5
Yes, external software renderer work
(02-04-2021, 03:33 PM)gid15 Wrote:
(02-04-2021, 01:27 PM)sum2012 Wrote: bf86e36 version
black screen on video

log and profiler : https://drive.google.com/file/d/1GtAb3XI...sp=sharing
Could you please try it using the external software renderer? To verify if this is an issue within sceMpeg (in which case the video will also be black) or if this is an issue with the renderering (in which case the video will be displayed).


Attached Files
.7z   log_external_and_profiler.7z (Size: 126.66 KB / Downloads: 1)
.txt   log2.txt (Size: 50.34 KB / Downloads: 1)
Reply

#6
Last work d87b5f8
First bad b40c65d
That mean https://github.com/jpcsp/jpcsp/commit/b4...42398afd05 have problem.
d87b5f8 log: https://drive.google.com/file/d/1Qp1w0D3...sp=sharing
b40c65d log: https://drive.google.com/file/d/1LyiXGzz...sp=sharing
25192de log: https://drive.google.com/file/d/137jxiw5...sp=sharing
Reply

#7
The video fix between
https://github.com/jpcsp/jpcsp/compare/c......7b96dbc
Reply

#8
(08-25-2022, 01:41 PM)sum2012 Wrote: The video fix between
https://github.com/jpcsp/jpcsp/compare/c......7b96dbc
Does it mean that the video issue is now fixed?
Should the game be moved to the Playable state?

Thank you!
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#9
ddf9061 version

In x2 mode:

case 1 disable Disable saving GE screen to textures instead of memory:
Only 1/4 screen video

Case 2:Enable saving GE screen to textures instead of memory
Black screen of video


Attached Files Thumbnail(s)
       

.7z   log and profiler.7z (Size: 141.56 KB / Downloads: 3)
Reply

#10
Code:
    08C0DF6C:[D8A00000]: lv.q      C000.q, 0($a1)
    08C0DF70:[D8A10010]: lv.q      C010.q, 16($a1)
    08C0DF74:[D8A20020]: lv.q      C020.q, 32($a1)
    08C0DF78:[D8A30030]: lv.q      C030.q, 48($a1)
    08C0DF7C:[24A50040]: addiu      $a1, $a1, 64
    08C0DF80:[F8600002]: vwb.q      C000.q, 0($v1)
    08C0DF84:[F8610012]: vwb.q      C010.q, 16($v1)
    08C0DF88:[F8620022]: vwb.q      C020.q, 32($v1)
    08C0DF8C:[F8630032]: vwb.q      C030.q, 48($v1)
    08C0DF90:[FFFF0000]: vnop
    08C0DF94:[14A2FFF5]: bne        $a1, $v0, 0x08C0DF6C
    08C0DF98:[24630040]: addiu      $v1, $v1, 64
From the profile information, this game might try to copy video images to the VRAM using the above code sequence. I've tried to catch it in 03ee764. Does it help for the black screen issue?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply



Forum Jump:


Users browsing this thread:
2 Guest(s)

Powered By MyBB, © 2002-2022 iAndrew & Melroy van den Berg.