This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Infrastructure support
03-05-2021, 09:12 PM (This post was last modified: 03-05-2021 09:16 PM by gid15.)
Post: #11
RE: Infrastructure support
(03-05-2021 04:42 PM)Nir777 Wrote:  Yeah but then if I want to play adhoc over xlink i need the flash0 folder again....
Could there be a way to tell it not to load the flash0 folder? or i have to make seperate folders for each one?
Also some infrastructure games do connect to the PSN for authentication and I think you would need the flash0 folder for that no?
You could for example use the command line option "--flash0 flash0.xlink/" to tell to use another directory for flash0. You can then have multiple flash0 directories, each with a different content.

(03-05-2021 04:42 PM)Nir777 Wrote:  I mean its not that bad and I dont want to complain that much...
Your comments are welcome!
I guess not many users are working with Linux and the Java controller API might react slightly different than on Windows...

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-06-2021, 10:57 AM (This post was last modified: 03-06-2021 12:02 PM by Nir777.)
Post: #12
RE: Infrastructure support
Ok next game I tried is NBA 07 PSP as it had been added as well.
This time it won't work even on HLE.. and again cant get a log without a flash0 dump.
The log for LLE with flash0 folder that got prx files for xlink kai:
https://pastebin.com/NwyXEkeG
When I try to get a log with HLE this is what I get:
https://pastebin.com/6eHn9hJG
And JPCSP freezes.
On LLE the game seems to connect to a JPCSP access point but the wep password is incorrect? thats what it seems like.
Like always got some minor controller issues that I hope will be fixed in the future if possible thanks.
Find all posts by this user
Quote this message in a reply
03-06-2021, 12:01 PM (This post was last modified: 03-06-2021 12:37 PM by Nir777.)
Post: #13
RE: Infrastructure support
Ok it seems to work with HLE but then it freezes at random points?
This is the log I got with HLE:
https://pastebin.com/mUCUPTxV
It freezes here:
https://pasteboard.co/JRm0AqO.png
EDIT:
This is the most I got out by going first into ad-hoc and then infrastructure with HLE:
Code:
'libssl'
14:35:19  INFO hle.sceUtility - user_main - sceUtilityLoadNetModule(module=0x0007) PSP_NET_MODULE_SSL loaded
14:35:19  INFO hle.sceNet - user_main - sceNetInit poolSize=0x28000, calloutThreadPri=0x24, calloutThreadStack=0x0, netinitThreadPri=0x24, netinitThreadStack=0x0
14:35:19  INFO hle.sceNet - user_main - sceNetInit returning 0x0
14:35:19  INFO hle.sceSsl - user_main - sceSslInit heapSize=0x28000
14:35:19  INFO hle.sceSsl - user_main - sceSslInit returning 0x0
14:35:19  INFO hle.sceHttp - user_main - sceHttpInit heapSize=0x25800
14:35:19  INFO hle.sceHttp - user_main - sceHttpInit returning 0x0
14:35:19  WARN hle.sceHttps - user_main - Unimplemented sceHttpsInit rootCertNum=0x0, rootCertListAddr=0x00000000, clientCertAddr=0x00000000, keyAddr=0x00000000
14:35:19  WARN hle.sceHttps - user_main - Unimplemented sceHttpsInit returning 0x0
14:35:19  WARN hle.sceHttps - user_main - Unimplemented sceHttpsLoadDefaultCert certIssuer=0x0, certType=0x0
14:35:19  WARN hle.sceHttps - user_main - Unimplemented sceHttpsLoadDefaultCert returning 0x0
14:35:19  INFO hle.sceUtility - user_main - sceUtilityNetconfInitStart 0x08D97818-0x08D97858: SceUtilityNetconf[address=0x08D97818, netAction=0, groupName=, timeout=0]
14:35:19 ERROR  runtime - user_main - Pausing emulator - branch to self (death loop) at 0x08ABB6EC
Find all posts by this user
Quote this message in a reply
03-07-2021, 09:29 AM
Post: #14
RE: Infrastructure support
From the log, I see that the font files are missing (flash0/font/*.pgf). It should contain the files provided with Jpcsp or the ones from your own PSP.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-07-2021, 02:39 PM (This post was last modified: 03-07-2021 02:44 PM by Nir777.)
Post: #15
RE: Infrastructure support
(03-07-2021 09:29 AM)gid15 Wrote:  From the log, I see that the font files are missing (flash0/font/*.pgf). It should contain the files provided with Jpcsp or the ones from your own PSP.

Ah sry lol it's because I had to switch from all the flash0 folders and got confused.
I am just a guy that likes to make emulators work better over multiplayer Big Grin.
Enough for me for now so good luck!.
Find all posts by this user
Quote this message in a reply
03-07-2021, 05:55 PM
Post: #16
RE: Infrastructure support
(03-07-2021 02:39 PM)Nir777 Wrote:  
(03-07-2021 09:29 AM)gid15 Wrote:  From the log, I see that the font files are missing (flash0/font/*.pgf). It should contain the files provided with Jpcsp or the ones from your own PSP.

Ah sry lol it's because I had to switch from all the flash0 folders and got confused.
I am just a guy that likes to make emulators work better over multiplayer Big Grin.
Enough for me for now so good luck!.
Is the Infrastructure connection now working with NBA 07?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-07-2021, 07:20 PM (This post was last modified: 03-07-2021 07:25 PM by Nir777.)
Post: #17
RE: Infrastructure support
This time I made sure I didnt fuck up with anything lol.
And no it still won't work because it will timeout when you try JPCSP against a PSP.
Again can't get a log with HLE.
Also for some reason it will freeze when you try to connect to infrastructure sometimes...
https://i.ibb.co/R24MKGJ/image.png
NHL 2005 also got added and it's stuck on this screen for me:
https://i.snipboard.io/tYKSZc.jpg
Find all posts by this user
Quote this message in a reply
03-07-2021, 07:46 PM (This post was last modified: 03-07-2021 07:47 PM by gid15.)
Post: #18
RE: Infrastructure support
(03-07-2021 07:20 PM)Nir777 Wrote:  Again can't get a log with HLE.
I'm confused, you already reported logs with HLE earlier???

In one of the previous errors you reported:
Code:
WARNING: Couldn't close Closeable
java.io.IOException: Bad file descriptor
    at java.io.FileOutputStream.writeBytes(Native Method)
    at java.io.FileOutputStream.write(FileOutputStream.java:326)
    at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
    at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
    at java.io.FilterOutputStream.close(FilterOutputStream.java:158)
    at jpcsp.util.Utilities.close(Utilities.java:768)
    at jpcsp.settings.Settings.writeSettings(Settings.java:190)
it seems it was related to some writing error as Jpcsp can't write its own Setting.properties file. Maybe a file access permission under Linux? Verify that the Jpcsp files have correct access rights and are owned by your Linux user. Or are you running it with sudo?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-07-2021, 08:09 PM
Post: #19
RE: Infrastructure support
It's weird it sometimes works and sometimes does not...
It's not sudo related because I am running it from the home folder.. believe me I prefer to try it from WIndows lol.
Here is a log I got with NBA 07:
https://pastebin.com/mumX7ycH
No matter what I try I cant get NHL to work though.
The most I got from a log is this:
https://pastebin.com/crgAtym3
Find all posts by this user
Quote this message in a reply
03-07-2021, 09:32 PM (This post was last modified: 03-07-2021 09:38 PM by gid15.)
Post: #20
RE: Infrastructure support
(03-07-2021 08:09 PM)Nir777 Wrote:  Here is a log I got with NBA 07:
https://pastebin.com/mumX7ycH
OK, NBA 07 is using a special type of socket (i.e. "raw socket") which is only supported by an external library (rocksaw.dll / librocksaw.so). It seems this library is only available in the 32-bit versions of Jpcsp Sad.

I admit that the below error should be better catched, but this is the reason for the issue.
Code:
22:03:08 ERROR  runtime - user_main - Catched Throwable in RuntimeThread:
java.lang.NoClassDefFoundError: Could not initialize class jpcsp.network.SelectableRawSocket
    at jpcsp.network.RawChannel.<init>(RawChannel.java:33)
    at jpcsp.HLE.modules.sceNetInet$pspInetRawSocket.openChannel(sceNetInet.java:1891)
    at jpcsp.HLE.modules.sceNetInet$pspInetRawSocket.sendto(sceNetInet.java:2067)
    at jpcsp.HLE.modules.sceNetInet$pspInetSocket.sendto(sceNetInet.java:892)
    at jpcsp.HLE.modules.sceNetInet.sceNetInetSendto(sceNetInet.java:3176)

(03-07-2021 08:09 PM)Nir777 Wrote:  No matter what I try I cant get NHL to work though.
The most I got from a log is this:
https://pastebin.com/crgAtym3

This game seems to be an extremely old one (running on PSP v1.00?)
Code:
PSP_SYSTEM_VER = 1.00
REGION = 32768
TITLE = Gretzky NHL
Is it still running on a real PSP using a recent firmware?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: