This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Infrastructure support
03-01-2021, 08:47 PM (This post was last modified: 03-01-2021 08:50 PM by Nir777.)
Post: #1
Infrastructure support
PSP infrastructure is getting revived.
Some gameplay on JPCSP for the Star Wars games:
On JPCSP:
https://streamable.com/zcvqgn
https://www.youtube.com/watch?v=Voaym_A4pDU
PSP footage:
https://www.youtube.com/watch?v=ALwiibd8gJo
https://www.youtube.com/watch?v=s63OYjFFDkM

Progress is coming along nicely.
Hopefully JPCSP will improve its support as well.
Note: I didnt make these videos I am just sharing them for others to see.
Find all posts by this user
Quote this message in a reply
03-02-2021, 03:25 PM
Post: #2
RE: Infrastructure support
(03-01-2021 08:47 PM)Nir777 Wrote:  PSP infrastructure is getting revived.
Some gameplay on JPCSP for the Star Wars games:
On JPCSP:
https://streamable.com/zcvqgn
https://www.youtube.com/watch?v=Voaym_A4pDU
PSP footage:
https://www.youtube.com/watch?v=ALwiibd8gJo
https://www.youtube.com/watch?v=s63OYjFFDkM

Progress is coming along nicely.
Hopefully JPCSP will improve its support as well.
Note: I didnt make these videos I am just sharing them for others to see.
Thank you for sharing the information!
It would be interesting if someone could test it with Jpcsp and post a log file so that I can analyze the issue.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-03-2021, 05:42 AM
Post: #3
RE: Infrastructure support
Going into gameplay:
https://www.youtube.com/watch?v=kqLoRbDgn08
There is a link to the discord server if someone wanna join.
Find all posts by this user
Quote this message in a reply
03-04-2021, 05:32 AM
Post: #4
RE: Infrastructure support
More news:

With his new update to the server a new game is now supported.

ATV Off Road Fury Blazin' Trails (NTSC) for the psp.

To connect you will need a PSP as the java psp emulator just doesn't seem to try to properly connect online if you change your hosts file in windows.

Create / modify your WiFi connect on the psp and set the DNS to 104.237.9.163

Known issues
Buddy Lists currently do not work

Stats may not record. (Not really something I've tested)

If you are having connection issues between players, the host may need to open UDP port 10075 on their PSP's IP.

It does not work properly on JPCSP.
I dont have the game and not that interested in it but maybe it will be important for other games.
Find all posts by this user
Quote this message in a reply
03-04-2021, 11:54 AM
Post: #5
RE: Infrastructure support
(03-04-2021 05:32 AM)Nir777 Wrote:  Create / modify your WiFi connect on the psp and set the DNS to 104.237.9.163
OK, it seems to require to set a specific DNS server which will then probably return another IP address for the private game server.
For testing purpose, I've added in commit a198564 the possibility to define the "primaryDNS" from the Setting.properties file. Previously, it was somehow hardcoded to the DNS server from your router.
Could someone test this game by adding the following line into your Setting.properties file:
Code:
primaryDNS=104.237.9.163
If this is helping, I will add the possibility to set the DNS server from the configuration settings.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-04-2021, 09:01 PM (This post was last modified: 03-04-2021 09:04 PM by Nir777.)
Post: #6
RE: Infrastructure support
Kinda unrelated but I wanted to try the latest jpcsp version and got this error:
Code:
Exception in thread "main" java.lang.NoSuchMethodError: java.nio.ByteBuffer.position(I)Ljava/nio/ByteBuffer;
    at jpcsp.crypto.KIRK.libkirkUtilsBufferCopyWithRange(KIRK.java:936)
    at jpcsp.crypto.KIRK.hleUtilsBufferCopyWithRange(KIRK.java:894)
    at jpcsp.crypto.PreDecrypt.isUseless(PreDecrypt.java:328)
    at jpcsp.crypto.PreDecrypt.addInfo(PreDecrypt.java:350)
    at jpcsp.crypto.PreDecrypt.loadInfo(PreDecrypt.java:318)
    at jpcsp.crypto.PreDecrypt.load(PreDecrypt.java:215)
    at jpcsp.crypto.PreDecrypt.init(PreDecrypt.java:176)
    at jpcsp.MainGUI.main(MainGUI.java:3110)

Is there a way to fix this?
Could be that I compiled it wrong on Linux... If so can someone share the latest build again lol.
Find all posts by this user
Quote this message in a reply
03-04-2021, 09:53 PM
Post: #7
RE: Infrastructure support
(03-04-2021 09:01 PM)Nir777 Wrote:  
Code:
Exception in thread "main" java.lang.NoSuchMethodError: java.nio.ByteBuffer.position(I)Ljava/nio/ByteBuffer;
    at jpcsp.crypto.KIRK.libkirkUtilsBufferCopyWithRange(KIRK.java:936)
    at jpcsp.crypto.KIRK.hleUtilsBufferCopyWithRange(KIRK.java:894)
    at jpcsp.crypto.PreDecrypt.isUseless(PreDecrypt.java:328)
    at jpcsp.crypto.PreDecrypt.addInfo(PreDecrypt.java:350)
    at jpcsp.crypto.PreDecrypt.loadInfo(PreDecrypt.java:318)
    at jpcsp.crypto.PreDecrypt.load(PreDecrypt.java:215)
    at jpcsp.crypto.PreDecrypt.init(PreDecrypt.java:176)
    at jpcsp.MainGUI.main(MainGUI.java:3110)
It seems you have compiled with JDK 9 (or later) and are now trying to run with JDK 8.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-05-2021, 02:00 PM (This post was last modified: 03-05-2021 02:46 PM by Nir777.)
Post: #8
RE: Infrastructure support
Well decided to get it anyway and see how thing works out of interest.
When I tried the game with a flash0 dump intact the game froze.
When I tried without the flash0 folder the game did proceed and even worked but for some reason I couldn't get past the intro screen with a log?
Also wanted to report about a strange thing : JPCSP will only work if my controller is connected to my laptop and won't work otherwise (because i binded the button with it?)
its a bit strange but yeah.
The LLE/flash0 folder log is this (its too long so made a pastebin):
https://pastebin.com/n2x8VWTA
The HLE/non flash0 folder log:
https://pastebin.com/6UidTU1s

Pictures of it working:
https://i.ibb.co/tCJVxLB/image.png
https://user-images.githubusercontent.co...e97b9d.png


Attached File(s)
.txt  log.txt (Size: 16.92 KB / Downloads: 4)
Find all posts by this user
Quote this message in a reply
03-05-2021, 04:37 PM
Post: #9
RE: Infrastructure support
As this seems to be helpful, I've now added in 39b95bb a configuration option to set the primary DNS server address.
Select the menu "Options / Settings (F12)", then "Network / Primary DNS server address" and set the value to "104.237.9.163" for the above list game.

There is no need to extract PSP files into the flash0 directory, the High Level Emulation (HLE) should be good enough to support connections for the Infrastructure mode.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-05-2021, 04:42 PM (This post was last modified: 03-05-2021 04:51 PM by Nir777.)
Post: #10
RE: Infrastructure support
Yeah but then if I want to play adhoc over xlink i need the flash0 folder again....
Could there be a way to tell it not to load the flash0 folder? or i have to make seperate folders for each one?
Also some infrastructure games do connect to the PSN for authentication and I think you would need the flash0 folder for that no?
Also this happens when I dont have the controller plugged in:
Code:
Exception in thread "GUI" java.lang.ExceptionInInitializerError
    at jpcsp.MainGUI.<init>(MainGUI.java:184)
    at jpcsp.MainGUI$76.run(MainGUI.java:3152)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
    at java.awt.EventQueue.access$500(EventQueue.java:97)
    at java.awt.EventQueue$3.run(EventQueue.java:709)
    at java.awt.EventQueue$3.run(EventQueue.java:703)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Pr​otectionDomain.java:74)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
    at org.GNOME.Accessibility.AtkWrapper$6.dispatchEvent(AtkWrapper.java:705)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205​)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105​)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.NullPointerException
    at jpcsp.Controller.getControllerComponentByName(Controller.java:652)
    at jpcsp.Controller.onInputControllerChanged(Controller.java:222)
    at jpcsp.Controller.loadControllerConfig(Controller.java:214)
    at jpcsp.Controller.loadControllerConfig(Controller.java:207)
    at jpcsp.Controller.init(Controller.java:118)
    at jpcsp.Controller.getInstance(Controller.java:171)
    at jpcsp.State.<clinit>(State.java:65)
    ... 17 more
[/

I mean its not that bad and I dont want to complain that much...
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)