EmuNewz Network
Sonic The Hedgehog [BLES00028] - Printable Version

+- EmuNewz Network (http://www.emunewz.net/forum)
+-- Forum: Official RPCS3 Forum (/forumdisplay.php?fid=172)
+--- Forum: RPCS3 - Commercial Games (/forumdisplay.php?fid=193)
+---- Forum: RPCS3 - Commercial Games - Intro (/forumdisplay.php?fid=197)
+---- Thread: Sonic The Hedgehog [BLES00028] (/showthread.php?tid=178905)

Pages: 1 2 3


RE: Sonic The Hedgehog [BLES00028] - shoopdahoop22 - 05-09-2017 06:03 PM

(05-09-2017 05:57 PM)Annie Wrote:  Please retest in latest master build, some stuff to sys_fs was added that the game needed

I'll do it tonight.


RE: Sonic The Hedgehog [BLES00028] - irixion - 05-10-2017 10:52 PM

Game still hangs out in the infinite loading loop. Tested with 0.0.2-4606.

Uploaded to MEGA as the log file is around 2 MB.
MEGA

Tested again on 0.0.2-4608. OGL locks up, Vulkan load loops.

Registered for paste.ee because pastebin is garbage. Here's the log Smile
https://paste.ee/p/m1MW5

Edit: Merged my posts. x.x


RE: Sonic The Hedgehog [BLES00028] - Annie - 05-16-2017 07:19 PM

Don't load automatic and manual selection and select twice the same module. Delete all .prx files in the folder and keep just .sprx.


RE: Sonic The Hedgehog [BLES00028] - irixion - 05-18-2017 02:12 AM

(05-16-2017 07:19 PM)Annie Wrote:  Don't load automatic and manual selection and select twice the same module. Delete all .prx files in the folder and keep just .sprx.


I've done that, still nothing Sad

https://paste.ee/p/5MKx6


RE: Sonic The Hedgehog [BLES00028] - Sonikko - 05-19-2017 12:16 AM

Tried the game on rpcs3 0.0.2-4658 (bf03cf1 Alpha on the application title), it boots and it hangs during the loading screen now, it does not loop like it used to.
It boots with OpenGL too now, it doesn't crash anymore. It hangs at the same point with all three renderers. Log file:
https://paste.ee/p/Xg4gK


RE: Sonic The Hedgehog [BLES00028] - shoopdahoop22 - 05-19-2017 12:42 AM

(05-19-2017 12:16 AM)Sonikko Wrote:  Tried the game on rpcs3 0.0.2-4658 (bf03cf1 Alpha on the application title), it boots and it hangs during the loading screen now, it does not loop like it used to.
It boots with OpenGL too now, it doesn't crash anymore. It hangs at the same point with all three renderers. Log file:
https://paste.ee/p/Xg4gK

I tried it on the exact same build as you, but it still loops for me.


RE: Sonic The Hedgehog [BLES00028] - Sonikko - 05-19-2017 06:29 AM

(05-19-2017 12:42 AM)shoopdahoop22 Wrote:  
(05-19-2017 12:16 AM)Sonikko Wrote:  Tried the game on rpcs3 0.0.2-4658 (bf03cf1 Alpha on the application title), it boots and it hangs during the loading screen now, it does not loop like it used to.
It boots with OpenGL too now, it doesn't crash anymore. It hangs at the same point with all three renderers. Log file:
https://paste.ee/p/Xg4gK

I tried it on the exact same build as you, but it still loops for me.

What settings?
I tried Automatic and manual loading for modules and picked the modules in the OP.
Vulkan/OGL/DX 12 all had the same outcome
Xaudio2 and Null
DS4 Pad
EDIT: I had the GPU Texture Scaling option on, disabling it caused the loading loop again, but only once. I closed the emulator, reopened it and tried again and now it hangs.


RE: Sonic The Hedgehog [BLES00028] - irixion - 05-21-2017 02:49 AM

(05-19-2017 06:29 AM)Sonikko Wrote:  
(05-19-2017 12:42 AM)shoopdahoop22 Wrote:  
(05-19-2017 12:16 AM)Sonikko Wrote:  Tried the game on rpcs3 0.0.2-4658 (bf03cf1 Alpha on the application title), it boots and it hangs during the loading screen now, it does not loop like it used to.
It boots with OpenGL too now, it doesn't crash anymore. It hangs at the same point with all three renderers. Log file:
https://paste.ee/p/Xg4gK

I tried it on the exact same build as you, but it still loops for me.

What settings?
I tried Automatic and manual loading for modules and picked the modules in the OP.
Vulkan/OGL/DX 12 all had the same outcome
Xaudio2 and Null
DS4 Pad
EDIT: I had the GPU Texture Scaling option on, disabling it caused the loading loop again, but only once. I closed the emulator, reopened it and tried again and now it hangs.

Yeah, sometimes it seems to hang and sometimes it loops while loading.


RE: Sonic The Hedgehog [BLES00028] - knuckles500 - 06-28-2017 08:27 PM

This error is still occurring as of v0.0.2-13-431a1ef. This affects the US version (BLUS300008) as well.


RE: Sonic The Hedgehog [BLES00028] - irixion - 07-05-2017 04:33 PM

(06-28-2017 08:27 PM)knuckles500 Wrote:  This error is still occurring as of v0.0.2-13-431a1ef. This affects the US version (BLUS300008) as well.

https://paste.ee/p/1Id9t

Here's a log from the latest build. It appears it has issues decompressing the game's files.