EmuNewz Network
Booting VSH in Jpcsp - Printable Version

+- EmuNewz Network (http://www.emunewz.net/forum)
+-- Forum: PSP Emulation (/forumdisplay.php?fid=191)
+--- Forum: JPCSP Official Forum (/forumdisplay.php?fid=51)
+---- Forum: svn trunk discussion (/forumdisplay.php?fid=56)
+---- Thread: Booting VSH in Jpcsp (/showthread.php?tid=175293)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12


RE: Booting VSH in Jpcsp - onelight - 06-23-2017 10:09 AM

(06-21-2017 04:09 PM)gid15 Wrote:  This should be fixed in 3ca5aac (or later). I'm making investigations into the PSP file system functions and somehow, I broke the VSH. Sorry.

Think you, now VSH working again.


RE: Booting VSH in Jpcsp - gid15 - 07-05-2017 05:35 PM

(06-22-2017 09:20 AM)DragonNeos Wrote:  Commercial games that are distributed digitally through the PlayStation Network may have a DOCUMENT.DAT file next to the game (EBOOT.PBP). Demos and Trial games hosted on either PSN or the developer's website can also have a DOCUMENT.DAT file (Ex: God Eater 2 Trial, Yu-Gi-Oh! ARC-V Tag Force Special Trial). The DOCUMENT.DAT file is a software version of the manual that developers used to provide in game cases in previous console generations.
The DOCUMENT.DAT should now be properly recognized in 8fa8133.

(06-22-2017 09:20 AM)DragonNeos Wrote:  2) VSH is showing duplicate entries for any file and doesn't allow execution of encrypted EBOOT.PBP (except for certain demos/trial games that are classified in the "MG" category such as Bleach: Heat the Soul 5 Trial which will crash the emulator after gameboot.pmf loads)
I can't reproduce this issue. Are you sure you don't have multiple times the same directory defined in Settings.properties for "emu.umdpath*"?

(06-22-2017 09:20 AM)DragonNeos Wrote:  3) After selecting a game, there should be audio playing on the screen with PSP displayed as the emulator is attempting to load the game (gameboot.pmf is not consistent in always producing the booting sound). None of the audio prx modules is producing any sound when the game is loaded.
This should now be fixed in e90c14b.

(06-22-2017 09:20 AM)DragonNeos Wrote:  4) Custom Themes are not saved in the configuration after the emulator is closed. The emulator will bring up the default theme when the VSH is loaded up again (similar behavior to Date & Time Settings before the issue was fixed).
The theme settings are now also saved in 00cc543.

(06-22-2017 09:20 AM)DragonNeos Wrote:  5) On the VSH, the Free Space capacity of the Memory Stick displays a random number (972 MB).
Previously, it reported 95% of 1GB as free space on the Memory Stick (972 MB). Now, with de23c5b, Jpcsp is reporting 1GB of free space, which is displayed as 1023 MB by the VSH.

(06-22-2017 09:20 AM)DragonNeos Wrote:  7) Certain homebrew applications such as PRXdecrypter 2.7a will not be able to load when selected from the VSH (displays "Error 0x80010002 loading/starting PRXdecrypter02g module" and "Exiting in 10 seconds...").
This seems to be fixed by c1abb3a.


RE: Booting VSH in Jpcsp - DragonNeos - 07-07-2017 09:50 AM

(07-05-2017 05:35 PM)gid15 Wrote:  
(06-22-2017 09:20 AM)DragonNeos Wrote:  2) VSH is showing duplicate entries for any file and doesn't allow execution of encrypted EBOOT.PBP (except for certain demos/trial games that are classified in the "MG" category such as Bleach: Heat the Soul 5 Trial which will crash the emulator after gameboot.pmf loads)
I can't reproduce this issue. Are you sure you don't have multiple times the same directory defined in Settings.properties for "emu.umdpath*"?
I only have the default directories listed in the configuration when the emulator is first started up. After conducting some further tests, it seems that only files placed in the Memory Stick directory will display duplicate entries. Disk Images that are placed in umdimages will display correctly as individual entries in the VSH.
Code:
emu.umdpath=umdimages
emu.umdpath.1=ms0/PSP/GAME
It should also be noted that the homebrew game pong (provided in JPCSP in "ms0/PSP/GAME") does not work when selected from the VSH (displayed as "Corrupted Data" and when selected displays "This game cannot be started. The data is corrupted.") The game does work when selected from "Load UMD..."

Execution of any encrypted EBOOT.PBP is still prohibited when selected from the VSH (displays "The copyright protection information is invalid (8010850E)"). Is there a particular file that I could remove from the "kd" or "vsh" directory such as "np*.prx" or "np*.rco" to allow encrypted EBOOT.PBP to load from the VSH natively?

(07-05-2017 05:35 PM)gid15 Wrote:  
(06-22-2017 09:20 AM)DragonNeos Wrote:  3) After selecting a game, there should be audio playing on the screen with PSP displayed as the emulator is attempting to load the game (gameboot.pmf is not consistent in always producing the booting sound). None of the audio prx modules is producing any sound when the game is loaded.
This should now be fixed in e90c14b.
The actual issue was that I let the emulator attempt to load avcodec.prx and its dependencies (audiocodec_260.prx, mpegbase_260.prx, & videocodec_260.prx) as the game was starting up from VSH which resulted in the game having no in-game audio. The solution was to remove these files from the "kd" directory which restored the in-game audio when I tried to load the game again from the VSH.

Another issue that I forgot to mention is that users aren't able to enter System Settings. When users select this option in the VSH, they are immediately shown this error message (1st Screenshot). After pressing the Circle button, the VSH display appears to be messed up as the System Settings options appear in the background (2nd Screenshot).


RE: Booting VSH in Jpcsp - gid15 - 07-13-2017 05:25 PM

(07-07-2017 09:50 AM)DragonNeos Wrote:  Another issue that I forgot to mention is that users aren't able to enter System Settings. When users select this option in the VSH, they are immediately shown this error message (1st Screenshot). After pressing the Circle button, the VSH display appears to be messed up as the System Settings options appear in the background (2nd Screenshot).
Hmmm, I can't reproduce it. Could you post a log file for that issue?

Thank you!


RE: Booting VSH in Jpcsp - DragonNeos - 07-14-2017 11:05 AM

I have attached a log using revision cbc09e5.


RE: Booting VSH in Jpcsp - gid15 - 07-14-2017 01:27 PM

(07-13-2017 05:25 PM)gid15 Wrote:  
(07-07-2017 09:50 AM)DragonNeos Wrote:  Another issue that I forgot to mention is that users aren't able to enter System Settings. When users select this option in the VSH, they are immediately shown this error message (1st Screenshot). After pressing the Circle button, the VSH display appears to be messed up as the System Settings options appear in the background (2nd Screenshot).
Hmmm, I can't reproduce it. Could you post a log file for that issue?

Thank you!
OK, got it now with the help of your log file:
Code:
07:01:54  INFO hle.IoFileMgrForUser - ScePafJob - hleIoOpen filename = flash0:/vsh/etc/index_03g.dat flags = 1 permissions = 0777
In the configuration, you have setup the "PSP Model" to PSP 3000.

In that case, the VSH is trying to access new registry entries that aren't used for PSP 1000/2000:
Code:
07:02:03  WARN hle.sceReg - SCE_VSH_GRAPHICS - Unknown registry entry '/CONFIG/SYSTEM/umd_cache'
07:02:04  WARN hle.sceReg - SCE_VSH_GRAPHICS - Unknown registry entry '/CONFIG/DISPLAY/color_space_mode'

I never tested that case, I will further investigate...

Thank you Smile


RE: Booting VSH in Jpcsp - gid15 - 07-17-2017 07:20 PM

(07-14-2017 01:27 PM)gid15 Wrote:  
(07-13-2017 05:25 PM)gid15 Wrote:  
(07-07-2017 09:50 AM)DragonNeos Wrote:  Another issue that I forgot to mention is that users aren't able to enter System Settings. When users select this option in the VSH, they are immediately shown this error message (1st Screenshot). After pressing the Circle button, the VSH display appears to be messed up as the System Settings options appear in the background (2nd Screenshot).
Hmmm, I can't reproduce it. Could you post a log file for that issue?

Thank you!
OK, got it now with the help of your log file:
Code:
07:01:54  INFO hle.IoFileMgrForUser - ScePafJob - hleIoOpen filename = flash0:/vsh/etc/index_03g.dat flags = 1 permissions = 0777
In the configuration, you have setup the "PSP Model" to PSP 3000.

In that case, the VSH is trying to access new registry entries that aren't used for PSP 1000/2000:
Code:
07:02:03  WARN hle.sceReg - SCE_VSH_GRAPHICS - Unknown registry entry '/CONFIG/SYSTEM/umd_cache'
07:02:04  WARN hle.sceReg - SCE_VSH_GRAPHICS - Unknown registry entry '/CONFIG/DISPLAY/color_space_mode'

I never tested that case, I will further investigate...

Thank you Smile
Support for PSP 3000 has been added in 92f4da3.

PSP-GO is not yet working properly...


RE: Booting VSH in Jpcsp - DragonNeos - 07-18-2017 08:01 PM

Attempting to select the Video option on the VSH causes the emulator to Pause. Clicking on Run makes the emulator display errors and goes back to Pause. I used this video from YouTube as an example to test the Video option: KINGDOM HEARTS III – D23 2017 Toy Story Trailer

Also, files that are placed in the Memory Stick still have duplicate entries displayed on the VSH.

The Pong EBOOT.PBP (distributed with JPCSP) is still classified as Corrupted Data when displayed on the VSH.

The Data Install text is not displayed correctly as the final character in the first sentence is shown on a new line (ex: Renai 0 Kilometer Portable).


RE: Booting VSH in Jpcsp - gid15 - 07-20-2017 01:22 PM

(07-18-2017 08:01 PM)DragonNeos Wrote:  The Pong EBOOT.PBP (distributed with JPCSP) is still classified as Corrupted Data when displayed on the VSH.
My PSP is also displaying it as Corrupted Data. The PARAM.SFO contained in the EBOOT.PBP is incomplete... according to the developer, it runs only on firmware 1.0


RE: Booting VSH in Jpcsp - DragonNeos - 07-21-2017 09:15 PM

The homebrew application SavedataTool seems to cause an invalid memory address error when loaded from the VSH:
Code:
15:45:43 ERROR   memory - user_main - write8 - Invalid memory address: 0x8A01773B PC=0x088047F8
The application loads fine when selected from either the "UMD ISO/CSO Browser" or "Load file..." option. Also if the option "Enable saving GE screen to textures instead of memory" is enabled while SavedataTool is open on OpenGL, there will be a black screen. The option must be disabled in order to view the application when using OpenGL as the graphics renderer.

Any commercial game or demo that contains an ICON1.PMF will play, but the audio will produce occasional popping. Also, gameboot.pmf still has issues in always producing the booting audio (audio occasionally doesn't play when an application or game is selected).

I'm not sure if this is a bug or not, but name_plate.png (placed in "flash0\vsh\resource") doesn't always display correctly (displays a white screen) when other options such as Theme Settings or Date & Time Settings are modified then the user selects "About PSP (PlayStation Portable)" from System Settings.

The Video option doesn't cause the emulator to freeze anymore, but the video linked in my previous post is classified as Unsupported Data (although the specifications of the video can be seen when pressing Triangle and selecting Information (AVC Bit Rate is not displayed and AAC Bit Rate should be 96 kbps but displayed as 95 kbps)).

The "An internal error has occurred. (80110684)" message that occurs when a user tries to enter the PlayStation Store or Network Settings and selects Infrastructure Mode seems to be an undocumented SCE_UTILITY_NET_PARAM_ERROR. uOFW only documented six types so far on "include/utility/utility_netparam.h".

The Digital Comics application doesn't load when selected from the VSH (probably needs to be decrypted first).