EmuNewz Network

Full Version: IL-2 Sturmovik: Birds of Prey - ULES01316
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hangs when it should show the intro. Goes in-game if you disable media engine.

[attachment=8913]
Code:
java.lang.IllegalArgumentException: must pass in a non null handler
     at com.xuggle.xuggler.io.XugglerIO.mapIO(XugglerIO.java:588)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:539)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:218)
     at com.xuggle.xuggler.IContainer.open(IContainer.java:334)
     at jpcsp.media.MediaEngine.init(MediaEngine.java:333)
     at jpcsp.HLE.modules150.sceMpeg.sceMpegGetAvcAu(sceMpeg.java:1197)
Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
(07-17-2012 06:04 PM)gid15 Wrote: [ -> ]Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!

[attachment=8921]
(07-18-2012 01:22 PM)pave Wrote: [ -> ]
(07-17-2012 06:04 PM)gid15 Wrote: [ -> ]Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
Are you sure you added the line as requested? It seems the log is only at "debug" level, not at "trace" like requested.
(07-18-2012 02:30 PM)gid15 Wrote: [ -> ]
(07-18-2012 01:22 PM)pave Wrote: [ -> ]
(07-17-2012 06:04 PM)gid15 Wrote: [ -> ]Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
Are you sure you added the line as requested? It seems the log is only at "debug" level, not at "trace" like requested.
I think I did it right unless I should use logging level other than info.
(07-18-2012 03:22 PM)pave Wrote: [ -> ]I think I did it right unless I should use logging level other than info.
This is correct... I wonder why I don't see in the log what I was looking for... I have to look closer at the code.

Thanks
Code:
java.lang.IllegalArgumentException: must pass in a non null handler
     at com.xuggle.xuggler.io.XugglerIO.mapIO(XugglerIO.java:588)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:539)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:218)
     at com.xuggle.xuggler.IContainer.open(IContainer.java:334)
     at jpcsp.media.MediaEngine.init(MediaEngine.java:333)
     at jpcsp.HLE.modules150.sceMpeg.sceMpegGetAvcAu(sceMpeg.java:1197)
This should now be fixed in r2768. Could you retest?

Thanks!
using r 3138
still goes ingame
need to use software rendering otherwise graphic glitches but software rendering still has a few glitches as shown in the picture
no sound during the intro
might be because of
09:24:24 WARN hle.sceAudio - user_main - sceAudioChReserve failed - channel 2 already in use
09:24:24 WARN hle - av::vdecoding - Unknown StartCode 0x0000015F, offset 00000059
here is an info log
Can it be moved to playabe or needs more testing?
it can stay in half playable for the time being
Pages: 1 2
Reference URL's