This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IL-2 Sturmovik: Birds of Prey - ULES01316
#1
Hangs when it should show the intro. Goes in-game if you disable media engine.


.html   log.html (Size: 36.92 KB / Downloads: 16)
Reply
#2
Code:
java.lang.IllegalArgumentException: must pass in a non null handler
     at com.xuggle.xuggler.io.XugglerIO.mapIO(XugglerIO.java:588)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:539)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:218)
     at com.xuggle.xuggler.IContainer.open(IContainer.java:334)
     at jpcsp.media.MediaEngine.init(MediaEngine.java:333)
     at jpcsp.HLE.modules150.sceMpeg.sceMpegGetAvcAu(sceMpeg.java:1197)
Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#3
(07-17-2012, 06:04 PM)gid15 Wrote: Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!


.html   log.html (Size: 43.67 KB / Downloads: 13)
Reply
#4
(07-18-2012, 01:22 PM)pave Wrote:
(07-17-2012, 06:04 PM)gid15 Wrote: Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
Are you sure you added the line as requested? It seems the log is only at "debug" level, not at "trace" like requested.
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#5
(07-18-2012, 02:30 PM)gid15 Wrote:
(07-18-2012, 01:22 PM)pave Wrote:
(07-17-2012, 06:04 PM)gid15 Wrote: Could you add the following line in your LogSettings.xml, this will generate additional information for sceMpeg:
Code:
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thanks!
Are you sure you added the line as requested? It seems the log is only at "debug" level, not at "trace" like requested.
I think I did it right unless I should use logging level other than info.


Attached Files Thumbnail(s)
   
Reply
#6
(07-18-2012, 03:22 PM)pave Wrote: I think I did it right unless I should use logging level other than info.
This is correct... I wonder why I don't see in the log what I was looking for... I have to look closer at the code.

Thanks
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#7
Code:
java.lang.IllegalArgumentException: must pass in a non null handler
     at com.xuggle.xuggler.io.XugglerIO.mapIO(XugglerIO.java:588)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:539)
     at com.xuggle.xuggler.io.XugglerIO.map(XugglerIO.java:218)
     at com.xuggle.xuggler.IContainer.open(IContainer.java:334)
     at jpcsp.media.MediaEngine.init(MediaEngine.java:333)
     at jpcsp.HLE.modules150.sceMpeg.sceMpegGetAvcAu(sceMpeg.java:1197)
This should now be fixed in r2768. Could you retest?

Thanks!
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#8
using r 3138
still goes ingame
need to use software rendering otherwise graphic glitches but software rendering still has a few glitches as shown in the picture
no sound during the intro
might be because of
09:24:24 WARN hle.sceAudio - user_main - sceAudioChReserve failed - channel 2 already in use
09:24:24 WARN hle - av::vdecoding - Unknown StartCode 0x0000015F, offset 00000059
here is an info log


Attached Files Thumbnail(s)
   

.zip   log.zip (Size: 172.68 KB / Downloads: 9)
Reply
#9
Can it be moved to playabe or needs more testing?
Am I the only one with this cool sig?
[Image: ji6WX.png]
[Image: 2404362.png]
Reply
#10
it can stay in half playable for the time being
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)