This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Puyo Puyo!! 20th Anniversary - NPJH50492
#11
(12-22-2011, 06:24 PM)Shina Wrote: So, figure out anything? I found a way around the save issue, but not the sound issue. Seems to only happen in Puyo games.

Ah yes. I've noticed that the save problem comes from the generated file itself. Unfortunately, the only way to test this further would be to get a real PSP SAVEDATA file for this game, which I haven't found anywhere. Undecided
As for the sound issue, it is indeed a bad synchronization problem. I'm currently looking into it, but it seems to be also related to the lack of a secondary buffer in our ATRAC3+ handling implementation.
This issue affects a couple of games, but it can only be solved properly with the full implementation of a custom ATRAC3+ decoder, which we're currently working on. Wink
Reply

#12
So, a save with JCPSP won't work?
Reply

#13
(12-22-2011, 07:20 PM)Shina Wrote: So, a save with JCPSP won't work?

Not yet. Since this game is quite recent, there's a chance that it may be doing some extra checks upon the save file.
But only with a real PSP save file it will be possible to confirm this.
Reply

#14
using r 3220
after you choose what type of game and characters and all of your options it freezes up on the loading screen
here is an info log


Attached Files Thumbnail(s)
               

.zip   log.zip (Size: 110.64 KB / Downloads: 2)
Reply

#15
Last work r2624
r2625-r2629 break
Attach 2624,2629,3220 compiler debug log


Attached Files
.zip   3220log.zip (Size: 841.55 KB / Downloads: 4)
.zip   2629log.zip (Size: 866.91 KB / Downloads: 1)
.zip   2624log.zip (Size: 967.17 KB / Downloads: 1)
Reply

#16
Code:
18:29:41 DEBUG compiler - uncompress thread - Compiling _S1_2_8000020
18:29:41 DEBUG compiler - uncompress thread - CodeInstruction.compile  > 0x8000020 - syscall    0x04555 [hleKernelExitThread]
18:29:41 DEBUG compiler - uncompress thread - CodeInstruction.compile    0x8000024 - jr         $ra
18:29:41 DEBUG compiler - uncompress thread - CodeInstruction.compile    0x8000028 - nop
...
18:29:41 DEBUG compiler - user_main - Compiling _S1_2_8998128
18:29:41 DEBUG compiler - user_main - CodeInstruction.compile  > 0x8998128 - jr         $ra
18:29:41 DEBUG compiler - user_main - CodeInstruction.compile    0x899812C - syscall    0x0459C [sceKernelGetThreadExitStatus]
This problem could be fixed by r3232. Could you check?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#17
Yes.r3232 fixed thanks. Smile


Attached Files
.txt   3232log.txt (Size: 48.41 KB / Downloads: 1)
Reply

#18
ddf9061 version

Keep as ask "save data not find,create new save ? " after fiirst time save

Jpcsp 's save work in Real PSP.
The following log use jpcsp's save

Attach jpcsp and real psp log.


Attached Files
.7z   Realpsp-load-goodlog.7z (Size: 18.41 KB / Downloads: 1)
.7z   jpcsp load-bad-log.7z (Size: 370.1 KB / Downloads: 1)
.zip   jpcspsave-NPJH50492.zip (Size: 44.1 KB / Downloads: 1)
Reply

#19
The application is first calling sceUtilitySavedataInitStart mode=AUTOLOAD with dataBufSize=0x00000004, which should return an error as the buffer is too short. This case should now be fixed in cb37686.
Code:
19:36:57.717838 user_main - -> sceUtilitySavedataInitStart 0x089F1BC0:
0x00000600, 0x00000000, 0x00000000, 0x00000011  >................<
0x00000013, 0x00000012, 0x00000010, 0x00000000  >................<
0x00000000, 0x00000000, 0x00000000, 0x00000000  >................<
0x00000000, 0x00000000, 0x00000001, 0x484A504E  >............NPJH<
0x39343035, 0x00000032, 0x00000000, 0x00000000  >50492...........<
0x00000000, 0x00000000, 0x00000000, 0x00000000  >................<
0x00000000, 0x45564153, 0x41544144, 0x5441442E  >....SAVEDATA.DAT<
0x00000000, 0x09035180, 0x00000004, 0x00000000  >.....Q..........<
The application is then calling sceUtilitySavedataInitStart mode=AUTOLOAD with dataBufSize=0x00001000, which is fine
Code:
19:36:57.984773 user_main - -> sceUtilitySavedataInitStart 0x089F1BC0:
0x00000600, 0x00000000, 0x00000000, 0x00000011  >................<
0x00000013, 0x00000012, 0x00000010, 0x00000000  >................<
0x00000000, 0x00000000, 0x00000000, 0x00000000  >................<
0x00000000, 0x00000000, 0x00000001, 0x484A504E  >............NPJH<
0x39343035, 0x00000032, 0x00000000, 0x00000000  >50492...........<
0x00000000, 0x00000000, 0x00000000, 0x00000000  >................<
0x00000000, 0x45564153, 0x41544144, 0x5441442E  >....SAVEDATA.DAT<
0x00000000, 0x09035180, 0x00001000, 0x00000000  >.....Q..........<
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#20
cb37686 version

load save is fixed.
A small problem
screen flicking in loading save.
https://youtu.be/7oCZqDiuFrM


Attached Files
.7z   log.7z (Size: 361.2 KB / Downloads: 1)
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Powered By MyBB, © 2002-2022 iAndrew & Melroy van den Berg.