EmuNewz Network

Full Version: Can't start up JPCSP due to "JRE not installed"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I think you need java installed for 32 bit too. I am on 64 bit and I have to installed both 32 bit and 64 bit and it works fine. Smile
(08-15-2012, 01:32 PM)bearmon2010 Wrote: [ -> ]I think you need java installed for 32 bit too.
If we are talking about JPCSP that depends of the JPCSP architect you are running.

Also, there's was a little bug on JPCSP due some Windows versions does not support a command implemented on JPCSP batch start file. That issue should be solver since r2682.
Ahh.. Didnt have a problem since a little bit older emulator myself because I have both java plugins anyway but it will be good for n00bs who might have a problem with the newer released just in case. Smile
Solved it here.

It seems the path written in the bat is outdated, so it is looking for the jre6 folder.

just edit the original and change the path from jre6 to jre7.

Original .bat :

@echo off
if "%programfiles(x86)%XXX"=="XXX" goto JAVA32
if not exist "%programfiles%\Java\jre6\bin" goto JAVAMISSING
echo Running Jpcsp 64bit...
"%programfiles%\Java\jre6\bin\java" -Xmx1024m -Djava.library.path=lib/windows-amd64 -jar bin/jpcsp.jar
goto END

echo Unable to run a 64bit build on a 32bit platform. Install a 64bit version of Windows first.
goto END

echo The required version of Java has not been installed.
echo Go to http://java.sun.com to install the 64bit Java JRE.


just swap the "6"'s for "7"'s. Worked here.

the .bat is actually quite simple.
Where do you get that batch file? JPCSP start script have been improved several times on early weeks; even that way it always have been using the windows registry to seek the Java patch. The x86 build uses %JAVA_CMD% in case REG command doesn't work, however there's not a full patch attached.

Remember that official builds can be obtained here:
(08-08-2012, 09:17 AM)icecoffemix Wrote: [ -> ]The only difference is the location of Environment Variables window, which you could easily search on google.

*sigh* I didnt have JSDK so I tried to download it and my PC blocked it. I don't know anything about after you're supposed to add CLASSPATH, so English maybe?Huh
Well, i'm another noob trying to run jcpsp...

I use an Intel I3, 4gB ram and windows7 64bits.

Jpcsp never worked for me, except once, when i used a custom bat file I lost... I installed the 32 and 64 bit java, and now i don't know what else i could do.

I'm programming some tiny programs for the psp, and i would love to test then on an emulator. Using the real PSP to test is a bit slow.

Thanks a lot.
I'm having the same problem I also get this when I try to run compatibility mode "The specified path does not contain a valid program. Please select a valid program (ending with .exe)"

I have a Gateway DX4300-15e. http://reviews.cnet.com/desktops/gateway...64721.html
A few things tho I have the integrated GPU off and now have a Raedon HD 6950 and Windows 7 Ultimate 64 bit instead of the home premium.
After trying everything for an hour i found the easiest way to fix this issue for my windows7 64bit is to download Java6. Now it works like a charm. Hope this helps http://www.oracle.com/technetwork/java/j...02815.html
I decided to revive this thread so I made an account just to let people know how to fix this

-Step one open the "Edit" option for "start-windows-x86.bat" or which ever version
one has. (It's the one you click to open the emulator)

-Step two open a different file explorer and find your way to your version of Java
C:\Program Files (x86)\Java\jre1.8.0_111 (I copied my version of java with the

location of where one can find it.) (remove \jre1.8.0_111 and paste it in file explorer unless your java is found in the "Program Files")

I already went through and changed everything so im gonna paste it below to show what mine looks like after the change and hope some of you can find the difference. But just replace the version of Java that is in the "start-windows-x86.bat" with the version of Java you have now.

I believe the original Java that was on there was Java 6

@echo off
set PATH=%PATH%;lib\;lib\windows-x86\
if "%programfiles(x86)%XXX"=="XXX" goto JAVA32
if not exist "%programfiles(x86)%\Java\jre1.8.0_111\bin" goto JAVAMISSING
echo Running Jpcsp 32bit...
"%programfiles(x86)%\Java\jre1.8.0_111\bin\java" -Xmx1024m -Djava.library.path=lib/windows-x86 -jar bin/jpcsp.jar
goto END

if not exist "%programfiles%\Java\jre1.8.0_111\bin" goto JAVAMISSING
echo Running Jpcsp 32bit...
"%programfiles%\Java\jre1.8.0_111\bin\java" -Xmx1024m -Djava.library.path=lib/windows-x86 -jar bin/jpcsp.jar
goto END

echo The required version of Java has not been installed or isn't recognized.
echo Go to http://java.sun.com to install the 32bit Java JRE.

Pages: 1 2 3