EmuNewz Network

Full Version: Supertux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Not work

Quote:54991 [GUI] INFO emu - Jpcsp v0.6 r1772
55088 [GUI] INFO emu - PBP meta data :
BOOTABLE = 1
CATEGORY = MG
REGION = 32768
TITLE = SuperTux
probably homebrew? true
55114 [GUI] INFO emu - Found ModuleInfo name:'SDL App' version:0101 attr:00001000 gp:08a8e400
55114 [GUI] WARN emu - Kernel mode module detected
55115 [GUI] INFO emu - Found 77 imports from 15 modules
55115 [GUI] INFO emu - 77 NIDS mapped
55120 [GUI] INFO hle.IoFileMgrForUser - pspiofilemgr - filepath ms0/PSP/GAME/FW1.0
55121 [GUI] INFO emu - Loading global compatibility settings
55121 [GUI] INFO ge - Only GE Graphics: false
55121 [GUI] INFO hle.sceMpeg - Using JPCSP connector
55122 [GUI] INFO hle.sceMpeg - Media Engine enabled
55122 [GUI] INFO ge - Using Vertex Cache
55123 [GUI] INFO hle.sceAudio - Audio ChReserve disabled: false
55123 [GUI] INFO hle.sceAudio - Audio Blocking disabled: false
55123 [GUI] INFO hle.ThreadManForUser - Audio threads disabled: false
55123 [GUI] INFO memory - Ignore invalid memory access: true
55130 [GUI] INFO ge - OpenGL version: 3.3.0
55131 [GUI] INFO ge - Using VBO
55131 [GUI] INFO ge - Using shaders with Skinning
55132 [GUI] INFO ge - Using Geometry Shader for SPRITES
55343 [GUI] INFO ge - Using Geometry Shader shader-150.geom
57124 [root] WARN hle.LoadCoreForKernel - sceKernelFindModuleByName not found module name='sceModuleManager'
57127 [root] WARN hle - Unsupported syscall 205a sceKernelRegisterDefaultExceptionHandler 88a4119c 8002012e 00000000
57196 [user_main] INFO hle.IoFileMgrForUser - pspiofilemgr - filepath ms0/PSP/GAME/FW1.0
57233 [user_main] ERROR emu - Attempt to use SceUID for different purpose (purpose='IOFileManager-File',original='SceModule')
57236 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/stdout.txt flags = 602 permissions = 0666
57237 [user_main] WARN hle.IoFileMgrForUser - hleIoOpen - file already exists, deleting UNIMPLEMENT (PSP_O_TRUNC)
57240 [user_main] ERROR emu - Attempt to use SceUID for different purpose (purpose='IOFileManager-File',original='SysMem')
57240 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/stderr.txt flags = 602 permissions = 0666
57241 [user_main] WARN hle.IoFileMgrForUser - hleIoOpen - file already exists, deleting UNIMPLEMENT (PSP_O_TRUNC)
57310 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/.supertux/config flags = 1 permissions = 0666
57375 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/timidity.cfg flags = 1 permissions = 0666
57380 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/usr/local/lib/timidity/timidity.cfg flags = 1 permissions = 0666
57488 [SDL thread] WARN hle.sceHprm - IGNORING:sceHprmPeekCurrentKey(key_addr=0x8aa1aa8) future calls will only appear in TRACE log
57501 [GUI] WARN ge - Unimplemented VSCX: coordX=0
57501 [GUI] WARN ge - Unimplemented VSCY: coordY=0
57502 [GUI] WARN ge - Unimplemented VSCZ: coordZ=0
57502 [GUI] WARN ge - Unimplemented VTCS: coordS=0.0
57502 [GUI] WARN ge - Unimplemented VTCT: coordT=0.0
57502 [GUI] WARN ge - Unimplemented VTCQ: coordQ=0.0
57503 [GUI] WARN ge - Unimplemented VCV: colorR=0, colorG=0, colorB=0
57503 [GUI] WARN ge - Unimplemented VAP: alpha=0, prim_type=0
57503 [GUI] WARN ge - Unimplemented VFC: fog=0
57503 [GUI] WARN ge - Unimplemented VSCV: colorR2=0, colorG2=0, colorB2=0
57655 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/data/images/icon.xpm flags = 1 permissions = 0666
57668 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/stdout.txt flags = 1 permissions = 0666
57682 [user_main] INFO hle.IoFileMgrForUser - hleIoOpen filename = ms0:/PSP/GAME/FW1.0/stderr.txt flags = 1 permissions = 0666
58030 [user_main] INFO hle.LoadExecForUser - Program exit detected (sceKernelExitGame)
59738 [user_main] WARN hle.IoFileMgrForUser - sceIoClose - unknown uid 0

Quote:java.lang.RuntimeException: Cannot find executable
at jpcsp.Allegrex.compiler.RuntimeContext.jumpCall(RuntimeContext.java:114)
at jpcsp.Allegrex.compiler.RuntimeContext.jump(RuntimeContext.java:130)
at _S1_2_8A4AD78.s(_S1_2_8A4AD78.java:4)
at _S1_2_8A24C04.s(_S1_2_8A24C04.java:64)
at _S1_2_8A2490C.s(_S1_2_8A2490C.java:60)
at _S1_2_8A24324.s(_S1_2_8A24324.java:52)
at _S1_2_8A130C0.s(_S1_2_8A130C0.java:52)
at _S1_2_8A24C68.s(_S1_2_8A24C68.java:72)
at _S1_2_8A243F0.s(_S1_2_8A243F0.java:64)
at _S1_2_8A24730.s(_S1_2_8A24730.java:16)
at _S1_2_8A24730.exec(_S1_2_8A24730.java)
at jpcsp.Allegrex.compiler.RuntimeContext.runThread(RuntimeContext.java:618)
at jpcsp.Allegrex.compiler.RuntimeThread.run(RuntimeThread.java:45)

Download binary and source http://jomarj.tihlde.org/projects/supert...040206.zip
Working on 1923

- No recomended Only ge (Flasing screen and not view ingame render only menus work if this option enabled).

- menus work 10fps speed

- Ingame working decent speed 20-35fps (Slowndown in some zones but playable not crash).

- Working sound
Stops working on selecting one of the menu options:
- Start Game
- Bonus Levels
- Options
- Credits

Is there any way to fix this?
(05-18-2011 04:00 AM)taenew Wrote: [ -> ]Stops working on selecting one of the menu options:
- Start Game
- Bonus Levels
- Options
- Credits

Is there any way to fix this?
I have no problem running it using the following configuration settings:
Code:
Configuration / Video
    [ ] Disable VBO (automatically disabled if not supported)
    [ ] Only GE graphics (not recommended for homebrew)
    [ ] Use vertex cache
    [ ] Use shaders (experimental)
    [ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
    [ ] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
    [ ] Enable VAO (only relevant when using shaders and vertex cache)
    [ ] Enable saving GE screen to Textures instead of Memory
    [ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
    [ ] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
Configuration / Audio
    [ ] Disable audio threads
    [ ] Disable audio channels (not recommended)
    [ ] Disable audio blocking
Configuration / Memory
    [ ] Ignore invalid memory access (not recommended for test reports, but improves performance)
    [X] Ignore unmapped imports (not recommended)
Configuration / Media
    [X] Use Media Engine
    [ ] Extract media files to tmp folder
    [X] Decode audio files with SonicStage (must be installed separately and requires Media Engine)
    [X] Use non-native fonts from flash0 folder
Configuration / Compiler
    [X] Use compiler (dynarec)
    [ ] Output profiler info to profiler.txt (only for compiler)
    [3000] Maximum method size
Configuration / Crypto
    [ ] Extract decrypted EBOOT.BIN files to the TMP folder
    [ ] Handle SAVEDATA in crypto mode
    [ ] Extract original PGD files to the TMP folder
Could you check your settings and post a log file?
Actually this homebrew Only problem for me with Ge screen to texture option is enabled.

The render image not view correct Menus
- Start
- Bonus leves
- options Credits

But Disable option is working
Reference URL's