EmuNewz Network

Full Version: Compiling RPCS3 on GhostBSD
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i get this error in ghostbsd. any ideas?
Replace instances of #include <malloc.h> with stdlib.h
(09-14-2014, 01:31 AM)derpf Wrote: [ -> ]Replace instances of #include <malloc.h> with stdlib.h

ok, done. now i have another error, but it's glew related. i need to install it properly first.

well, can't fucking understand this one. it can't find glew.h but glew.h is in /usr/local/include/GL/glew.h

well, i fixed it myself by adding /usr/local/include to cmakelist include directories

there's also another malloc error in stblib stb_truetype.h line 370 that i fixed.

now there's this:

/home/zecoxao/Desktop/rpcs3/rpcs3/Emu/SysCalls/Modules/cellL10n.cpp:322:17: error:
      no matching function for call to 'libiconv'
i've fixed previous error by casting const char ** to second argument of the function.

now i get this:

/home/zecoxao/Desktop/rpcs3/rpcs3/Emu/SysCalls/Modules/cellSpurs.cpp:950:23: error:
      no viable overloaded '='
        attribute->eaContext = NULL;
fixed by replacing NULL with 0 (twice this error appears)

next error:

/home/zecoxao/Desktop/rpcs3/Utilities/rFile.cpp:41:16: error: variable has
      incomplete type 'struct stat64'
        struct stat64 file_info;
last error
/usr/bin/ld: s: invalid DSO for symbol `libiconv_open' definition
/usr/local/lib/libiconv.so.3: could not read symbols: Bad value
CC: error: linker command failed with exit code 1 (use -v to see invocation)
*** Error code 1
fixed by adding this:
-L${LOCALBASE}/lib -liconv
to flags in CMakeLists.txt.

new linking errors Big Grin

you're gonna have to recompile ffmpeg with your toolchain
(09-14-2014, 02:23 PM)Bigpet Wrote: [ -> ]you're gonna have to recompile ffmpeg with your toolchain

solved that also, much thanks Bigpet Tongue

pkg install yasm wget
wget http://ffmpeg.org/releases/ffmpeg-0.10.4.tar.gz
tar xvfz ./ffmpeg-0.10.4.tar.gz
rm ./ffmpeg-0.10.4.tar.gz
cd ./ffmpeg-0.10.4
./configure --cc=clang --enable-shared
gmake install

i also had to configure the configure file to avoid TMPDIR shit.

for my final error in libinotify, i just added -linotify to the flags.

compiles perfectly now Big Grin

i hope these changes go to the main repo Smile

spoke too soon Sad

segfault when loading SCOOGER

here's the backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 815c06400 (LWP 100629/rpcs3)]
0x000000080580478b in memset () from /lib/libc.so.7
(gdb) bt
#0  0x000000080580478b in memset () from /lib/libc.so.7
#1  0x00000000005a7aae in MemBlockInfo::MemBlockInfo ()
#2  0x00000000005a9367 in _ZNSt3__16vectorI12MemBlockInfoNS_9allocatorIS1_EEE24__emplace_back_slow_pathIJRmRjEEEvDpOT_ ()
#3  0x00000000005a8076 in DynamicMemoryBlockBase::AppendMem ()
#4  0x00000000005a81b9 in DynamicMemoryBlockBase::AllocAlign ()
#5  0x0000000000509a3f in PPCThread::InitStack ()
#6  0x00000000004d7a6e in Emulator::Load ()
#7  0x00000000006e3fea in MainFrame::BootElf ()
#8  0x0000000802958dcb in wxEvtHandler::SearchDynamicEventTable ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#9  0x0000000802958a9e in wxEvtHandler::ProcessEvent ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#10 0x0000000802958ba4 in wxEvtHandler::ProcessEventLocally ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#11 0x0000000802958a49 in wxEvtHandler::ProcessEvent ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#12 0x0000000802273ff4 in wxWindowBase::TryAfter ()
   from /usr/local/lib/libwx_gtk2u_core-3.0.so.0
#13 0x0000000802958a7d in wxEvtHandler::ProcessEvent ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#14 0x0000000802958e5f in wxEvtHandler::SafelyProcessEvent ()
   from /usr/local/lib/libwx_baseu-3.0.so.0
#15 0x000000080226c840 in wxWindowBase::HandleWindowEvent ()
   from /usr/local/lib/libwx_gtk2u_core-3.0.so.0
#16 0x0000000802227370 in wxMenuBase::SendEvent ()
   from /usr/local/lib/libwx_gtk2u_core-3.0.so.0
#17 0x0000000802131234 in menuitem_activate ()
   from /usr/local/lib/libwx_gtk2u_core-3.0.so.0
#18 0x00000008088e4a71 in g_closure_invoke ()
   from /usr/local/lib/libgobject-2.0.so.0
#19 0x00000008088f945a in g_signal_emitv ()
   from /usr/local/lib/libgobject-2.0.so.0
#20 0x00000008088fa10b in g_signal_emit_valist ()
   from /usr/local/lib/libgobject-2.0.so.0
#21 0x00000008088fa7e4 in g_signal_emit ()
   from /usr/local/lib/libgobject-2.0.so.0
#22 0x0000000806117788 in gtk_widget_activate ()
---Type <return> to continue, or q <return> to quit---

full with symbols:

edit:found the cause. it's my graphics card. hardware acceleration for it is not supported in freebsd. oh well, worth the shot Smile