This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random semi-hanging
11-17-2012, 07:22 PM
Post: #1
Random semi-hanging
I call it 'semi' because it's a wierd problem. Every so often, usually after playing for 20 minutes or so, the game hangs, but ONLY when it goes to load something, like a new screen or I'm trying to save the game. The wierd part is I can still activate menus and such in the game, I just can't move and the transition the game is trying to create, either to the save menu or to a new screen, never happens.

Is this just one of those emulator things we learn to cope with or is it something I specifically am doing wrong that I can troubleshoot? I have a fairly powerful computer, 4cpu 3.8ghz processor, 32 gigs of ram, 4 gig 6800 HD Radeon card (AMD), etc. I work with 3d art/animation so I needed a strong computer, and it's certainly able to handle that so I should think it can handle a PSP emulator as well. I've tried playing both with and without the jpcsp launcher and that doesn't seem to avoid the issue. Video settings for games obviously differs between them, the only options that are universal are the compiler, the soundstage setup and crypto. Thoughts?
Find all posts by this user
Quote this message in a reply
11-17-2012, 11:16 PM
Post: #2
RE: Random semi-hanging
(11-17-2012 11:07 PM)joxof Wrote:  I honestly think that OpenGL Driver of Nvidia GPU is more compatible/ support with JPCSP

Btw, the project is still a beta release Smile

Is it? The progress is pretty amazing for a beta, I can play the majority of my games fine with minimum lag. Nice to have a big screen with FAQS all right there <3 It's just the saving issue, I've lost quite a lot of progress that way, particularly in games like Fate EXTRA where you can't save inside of a dungeon.

Figured it was worth asking in case there was something on my end I could do to reduce the issue.
Find all posts by this user
Quote this message in a reply
11-17-2012, 11:23 PM
Post: #3
RE: Random semi-hanging
are you using the 32bit build or 64bit?
could you can post a screen shot or a log so we know what the crash error message is, that might narrow down if the crash is a bug or just a setting that needs adjusting/,.

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-18-2012, 09:52 AM
Post: #4
RE: Random semi-hanging
(11-17-2012 11:23 PM)hyakki Wrote:  are you using the 32bit build or 64bit?
could you can post a screen shot or a log so we know what the crash error message is, that might narrow down if the crash is a bug or just a setting that needs adjusting/,.

64bit. I just tried Fate EXTRA and now it won't even let me load a save, it just hangs. Didn't used to, though it's the save just before I enter the arena and once in, I'm in there for long enough to end up with that hanging issue before I get a chance to save. Maybe that happening enough during the same save screwed it up or something, but hopefully the logs will still be helpful. I get this problem with Tactics Ogre and Brave Story as well, so I'll give those a go next and post the logs from those if I get the error.

1st log is with minimal settings, 2nd is the settings I normally use for this particular game but also includes the ignoring memory access option.


Attached File(s)
.zip  Log_r2860(64bit)_1st_INFO.zip (Size: 5.21 KB / Downloads: 2)
.zip  Log_r2860(64bit)_INFO.zip (Size: 5.34 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
11-18-2012, 10:36 AM
Post: #5
RE: Random semi-hanging
(11-18-2012 09:52 AM)OuO Wrote:  
(11-17-2012 11:23 PM)hyakki Wrote:  are you using the 32bit build or 64bit?
could you can post a screen shot or a log so we know what the crash error message is, that might narrow down if the crash is a bug or just a setting that needs adjusting/,.

64bit. I just tried Fate EXTRA and now it won't even let me load a save, it just hangs. Didn't used to, though it's the save just before I enter the arena and once in, I'm in there for long enough to end up with that hanging issue before I get a chance to save. Maybe that happening enough during the same save screwed it up or something, but hopefully the logs will still be helpful. I get this problem with Tactics Ogre and Brave Story as well, so I'll give those a go next and post the logs from those if I get the error.

1st log is with minimal settings, 2nd is the settings I normally use for this particular game but also includes the ignoring memory access option.

Do you see the save window popup? maybe it got moved off screen


Attached File(s) Thumbnail(s)
       

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-18-2012, 06:11 PM
Post: #6
RE: Random semi-hanging
(11-18-2012 10:36 AM)hyakki Wrote:  
(11-18-2012 09:52 AM)OuO Wrote:  
(11-17-2012 11:23 PM)hyakki Wrote:  are you using the 32bit build or 64bit?
could you can post a screen shot or a log so we know what the crash error message is, that might narrow down if the crash is a bug or just a setting that needs adjusting/,.

64bit. I just tried Fate EXTRA and now it won't even let me load a save, it just hangs. Didn't used to, though it's the save just before I enter the arena and once in, I'm in there for long enough to end up with that hanging issue before I get a chance to save. Maybe that happening enough during the same save screwed it up or something, but hopefully the logs will still be helpful. I get this problem with Tactics Ogre and Brave Story as well, so I'll give those a go next and post the logs from those if I get the error.

1st log is with minimal settings, 2nd is the settings I normally use for this particular game but also includes the ignoring memory access option.

Do you see the save window popup? maybe it got moved off screen

Yeah I considered that, but I moved all my windows around and nothing. I also loaded up Tactics Ogre just after closing out of Fate EXTRA, and the window was to the left of the emu where it always is. It has popped up in wierd locations before though, but that didn't seem the be the case this time. On a separate note, Tactics Ogre suddenly decided to play fine, I've been going for 2 hours without that issue. The only setting that's different is I had GE off (forgot to turn it on) so maybe that's what was causing it? Gonna suck for games that need it, if that's the case.
Find all posts by this user
Quote this message in a reply
11-19-2012, 12:26 AM
Post: #7
RE: Random semi-hanging
Just happened again. This time I was a bit disheartened and just walked away from my computer entirely after staring at a black screen for no less than 10 min. Came back, and the save menu had finally appeared just as I sat back down. Just to test, I tried another save right after, popped up instantly. Log attached, hope it helps.


Attached File(s)
.zip  Log_r2860(64bit)_INFO.zip (Size: 19.58 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
11-19-2012, 10:48 PM (This post was last modified: 11-19-2012 10:49 PM by OuO.)
Post: #8
Figured it out (kinda)
So I've been testing with the games I had, and whenever the save/loading screen hang happens I've just been leaving the game on then going to do other things. As it turns out, it just takes a REALLY long time to figure itself out, but the save window does eventually pop up and the loading does eventually finish. The problem is this sometimes takes upwards of 20 minutes. I posted my computer specs, they're beefy enough to handle this and I've tried with and without the loader, so it seems to be the emulator itself; i.e., just something I have to live with while it continues to improve.

It could be because I have an ATI card, however I would think if that was the case it wouldn't let me save at all...as it stands, sometimes it saves/loads instantly, other times I need to find something else to do while it takes its jolly time doing so ;P


EDIT - Also I forgot to mention, sometimes when it's been loading for a while, it doesn't actually register as finished until I start pressing buttons on my controller, then the laod finishes or the save window pops up. It's happened to many times that way for it to be a coincidence.
Find all posts by this user
Quote this message in a reply
11-19-2012, 10:57 PM
Post: #9
RE: Random semi-hanging
(11-19-2012 10:48 PM)OuO Wrote:  So I've been testing with the games I had, and whenever the save/loading screen hang happens I've just been leaving the game on then going to do other things. As it turns out, it just takes a REALLY long time to figure itself out, but the save window does eventually pop up and the loading does eventually finish. The problem is this sometimes takes upwards of 20 minutes. I posted my computer specs, they're beefy enough to handle this and I've tried with and without the loader, so it seems to be the emulator itself; i.e., just something I have to live with while it continues to improve.

It could be because I have an ATI card, however I would think if that was the case it wouldn't let me save at all...as it stands, sometimes it saves/loads instantly, other times I need to find something else to do while it takes its jolly time doing so ;P


EDIT - Also I forgot to mention, sometimes when it's been loading for a while, it doesn't actually register as finished until I start pressing buttons on my controller, then the laod finishes or the save window pops up. It's happened to many times that way for it to be a coincidence.

Yeah strange, never heard of this problem before usually the save / Load window pops up near instant for me unless its one of those rare game that has to check every save game, I tested fate extra and didn't experience any save / load delay.

there is a few things to try..
1. Defrag your computer if you're not on a solid state drive.
2. Unplug your game controller and try the keyboard (I want to see if the controller is triggering some kind of conflict), I noticed this in the log where you had to press buttons.
3. Start jpcsp from a clean install (make a new directory) and quickly test a save / load scenario to see if it works better.

In the past do you think you've enabled Crypto mode? there could be a save that jpcsp is trying to read but since its crypto mode it cause a delay.

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)