This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Major regressions caused by changes in the last few builds
09-24-2011, 08:08 PM
Post: #1
Major regressions caused by changes in the last few builds
Everything worked normal in r2313 but now all my games are broken as of r2323.

Some examples:

Mega Man X = No background rendered in game.

Worms = Cannot even load the umd without causing an error that wants to be debugged in VS

3rd Birthday = cloudy static all over the screen in gameplay - can't see hardly anything.

This is with stencil test on/off.

What happened?

Intel Core i7 6700k @ 4.5 ghz. / GeForce GTX 970 / 16 Gig Ram / Win 10
Find all posts by this user
Quote this message in a reply
09-24-2011, 08:23 PM
Post: #2
RE: Major regressions caused by changes in the last few builds
stencil test was reworked to the last update so if there are bugs, post your log and pictures into the good section.
Find all posts by this user
Quote this message in a reply
09-24-2011, 08:32 PM (This post was last modified: 09-24-2011 08:33 PM by Hykem.)
Post: #3
RE: Major regressions caused by changes in the last few builds
Hmm...
Indeed, looks quite a serious bug. Unfortunately, I wasn't able to reproduce any of those issues, so I suspect they may be related to the shader changes.
Have you tried loading "Worms" with all video settings turned off? If it doesn't crash, then it's definitely the depth checking that needs to be revised (may not be supported).
Find all posts by this user
Quote this message in a reply
09-24-2011, 08:55 PM (This post was last modified: 09-24-2011 09:06 PM by hyakki.)
Post: #4
RE: Major regressions caused by changes in the last few builds
just tested 3rd birthday in r2323, seems to work fine as long as UBO (that was triggering shaders getting disabled) and stencil test is disabled
   
stencil test causes main character and some walls to become see through (screenshot).
   

anyways try to disable UBO since that seems to be the main problem cause (somehow triggers a shader error causing jpcsp to disable all shaders)

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
09-24-2011, 10:34 PM
Post: #5
RE: Major regressions caused by changes in the last few builds
(09-24-2011 08:55 PM)hyakki Wrote:  just tested 3rd birthday in r2323, seems to work fine as long as UBO (that was triggering shaders getting disabled) and stencil test is disabled

stencil test causes main character and some walls to become see through (screenshot).


anyways try to disable UBO since that seems to be the main problem cause (somehow triggers a shader error causing jpcsp to disable all shaders)

I can never get a stupid log because with it set to html, nothing get's logged. If i save it to txt file, it just unchecks itself after closing the menu.

I attached settings file, a pic of MM black background and two error logs and pic of the Worms error message. It doesn't happen 100% of the time. Seemed to be triggered when trying to load it after running Mega Man.

Speaking of, Mega Man definetely lost it's background in r2323 (fine in r2322 with identical settings). Disabling UBO changes nothing.

Also, with Stencil Testing activated running a game after loading the iso does nothing. Tried several times with several games. I'll just keep that off until that stabilizes and doesn't cause gfx issues.


Attached File(s)
.zip  Untitled.zip (Size: 73.73 KB / Downloads: 12)

Intel Core i7 6700k @ 4.5 ghz. / GeForce GTX 970 / 16 Gig Ram / Win 10
Find all posts by this user
Quote this message in a reply
09-24-2011, 10:43 PM (This post was last modified: 09-24-2011 10:45 PM by hyakki.)
Post: #6
RE: Major regressions caused by changes in the last few builds
to log you should go to
Jpcsp -> Debug -> tools -> logger ,
<Logger Window>
Under "Choose log level" select Info

then load your UMD -> Run, a bunch of messages should show in the logger window , after the error / crash close Jpcsp and you should have a file called Log.html in the root Jpcsp directory.

also don't forget you need to completely restart Jpcsp any time you change an option since they don't take effect while a game is running.

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
09-24-2011, 11:12 PM (This post was last modified: 09-24-2011 11:57 PM by legend80.)
Post: #7
RE: Major regressions caused by changes in the last few builds
(09-24-2011 10:43 PM)hyakki Wrote:  to log you should go to
Jpcsp -> Debug -> tools -> logger ,
<Logger Window>
Under "Choose log level" select Info

then load your UMD -> Run, a bunch of messages should show in the logger window , after the error / crash close Jpcsp and you should have a file called Log.html in the root Jpcsp directory.

also don't forget you need to completely restart Jpcsp any time you change an option since they don't take effect while a game is running.

Got out of fullscreen and was able to get a bunch of logs. Looks like Mega Man Maverick Hunter has slowing been getting broken and broken and broken in the last 30 revs. Smile

Here's the timeline and the EXACT revisions that caused the issues:

r2279 = Last good revision - as good as it's ever been. Only three outstanding issues were present: no sfx and you have to press START at boot (at the "Accessing" screen) to get cinamatic rolling. You also need "Only GE" to prevent the terrible stuttering which in turn causes black cinematics.

r2280=Cinamatics broken - all black. The one during boot and starting the game are both just black.

r2288=Now, the game halts when loading cinematics I guess. I have to select "Run" and then press START to bypass. This occurs twice to get the thing to the main menu. Once more after that to get into gameplay. Never seen anything like this before.

r2323=Still have to hit "Run" repeatidly to get ingame, cinematics are black and now the ingame gfx do not show - only the hud. Log attached of this from launch to gameplay.

The rest of the logs are just from launch to main menu. Stop breaking my game constantly!! Tongue


Attached File(s)
.zip  More logs.zip (Size: 1.95 KB / Downloads: 8)

Intel Core i7 6700k @ 4.5 ghz. / GeForce GTX 970 / 16 Gig Ram / Win 10
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)