This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xuggle 5.5 (64bit) - SandyBridge/IvyBridge compatibility test
11-05-2012, 11:17 AM (This post was last modified: 11-10-2012 06:36 AM by hyakki.)
Post: #1
Xuggle 5.5 (64bit) - SandyBridge/IvyBridge compatibility test
This is based off the latest xuggle GIT source (04a94d9cc729) built using mingw-w64-x86_64 (svn), GCC 4.7.1

I disabled the AVX support within ffmpeg with hopes of solving the crash bug present in Xuggle 5.4 64bit that seemed to effect only 'Sandy Bridge / Ivy Bridge' series of Intel Processors.
That said this build is just for testing with Jpcsp, let me know if its working properly on these processors (no crashes with video or audio), of course you can also test it on other processors).

Instructions
1. Get both Jpcsp 32bit, and Jpcsp 64bit builds
2. Extract the 64bit build to a directory of your choice.
3. Open the 32bit Jpcsp archive then just copy out 'bin/jpcsp.jar' to where you extracted the 64bit build (overwrite the jar file)
4. Open the xuggle 7z archive and extract 'libxuggle-5.dll' to the Jpcsp "lib\windows-amd64" dir.
xuggle-xuggler-noarch-5.4.jar goes in the 'lib' dir (overwrite, I added -5.4 to the filename, the current jpcsp xuggle-xuggler-noarch-5.4.jar might also work but for safe results I decided to include the one I built)
5. run Jpcsp and look for the bug.

xuggle-5.5-git(04a94d9cc729)
Bug free (no crashes)
http://www.mediafire.com/?gpnyn1sq9wi0505 (no avx, no cpu detect, confirmed working - replaced build with Cpu detect)
http://www.mediafire.com/download.php?ympk3tfjs5y68hn (no avx, Cpu detect, confirmed working)

Bug confirmed on these builds
http://www.mediafire.com/download.php?nt56c362wa9onsc (avx)

as always I test on my PC first to make sure everything works at a basic level (movies, audio ..etc ) and that I have no crashes.
Instruction video if needed Smile

Code:
Full source code for this build can be obtained here if needed (I would of included it in the archive but it was 200 megs)
Working.
git clone https://github.com/xuggle/xuggle-xuggler
git checkout 04a94d9cc729a7d7e8ce28e4ccbc4d4eda4a1d47

Configuration Flags
ffmpeg version N-36078-g04a94d9-xuggle-5.5 Copyright (c) 2000-2012 the FFmpeg developers
  built on Nov  5 2012 23:22:43 with gcc 4.7.1
  configuration: --prefix=/usr/local/xuggler --disable-shared --enable-pic --enable-gpl --disable-nonfree --enable-libx264 --enable-version3 --enable-cross-compile
--cross-prefix=x86_64-w64-mingw32- --arch=x86_64 --target-os=mingw32 --pkg-config=pkg-config --disable-avx --enable-libmp3lame --enable-libvorbis --enable-libtheora
--enable-libspeex --enable-libvo-aacenc --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --extra-libs=-lwinmm --enable-zlib --enable-libvpx
  libavutil      51. 46.100 / 51. 46.100
  libavcodec     54. 14.101 / 54. 14.101
  libavformat    54.  3.100 / 54.  3.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 67.101 /  2. 67.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0. 10.100 /  0. 10.100
  libpostproc    52.  0.100 / 52.  0.100


Attached File(s) Thumbnail(s)
   

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-05-2012, 11:25 AM (This post was last modified: 11-05-2012 11:25 AM by nash67.)
Post: #2
RE: Xuggle 5.5 (64bit) - unoffical test
has anybody done a bug report over at Xuggle to let them know about the 64 bit problems they have ????
Find all posts by this user
Quote this message in a reply
11-05-2012, 11:37 AM (This post was last modified: 11-05-2012 11:40 AM by hyakki.)
Post: #3
RE: Xuggle 5.5 (64bit) - unoffical test
well it might of been fixed, the builds on the svn are old, they switched over to GIT and since then there has been no official builds, I just noticed it's compiling as 5.5 (last official was 5.4)
Since I can compile it now I can enable and disable features, and optimizations the only downside is I dont have a second gen processor so I have to have others test :\

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-05-2012, 03:23 PM
Post: #4
RE: Xuggle 5.5 (64bit) - unoffical test
Well I tested it and happy to report success !
Crimson gem saga and tactics ogre dont crash anymore ( tested each 10 times ).

What are differences between jpcsp.jar which comes with 32 bit version and the one which comes with 64 bit version ?
Is only difference path to xuggle files ?
Can I keep the .jar from 32 bit version and still have fully functional 64 bit version of jpcsp ?
( I wanna keep it till gid15 release official 64 bit version with new xuggle )
Find all posts by this user
Quote this message in a reply
11-05-2012, 09:03 PM
Post: #5
RE: Xuggle 5.5 (64bit) - unoffical test
(11-05-2012 03:23 PM)digiadventures Wrote:  Well I tested it and happy to report success !
Crimson gem saga and tactics ogre dont crash anymore ( tested each 10 times ).

What are differences between jpcsp.jar which comes with 32 bit version and the one which comes with 64 bit version ?
Is only difference path to xuggle files ?
Can I keep the .jar from 32 bit version and still have fully functional 64 bit version of jpcsp ?
( I wanna keep it till gid15 release official 64 bit version with new xuggle )

Nothing is really different in functionality so you can run the 32bit jar with 64bit, the 32bit one is configured to look for the xuggle-5.dll (the new media engine) and the 64bit jpcsp.jar one looks only for the older xuggle 3.
so using the 32bit jar will just enable access to xuggle-5 and enable the new media engine on 64bit.

anyways great news it worked, just need a few more people to test, then it will be up to gid15 if he wants to try implementing it again for default builds.

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-06-2012, 02:38 AM (This post was last modified: 11-10-2012 06:35 AM by hyakki.)
Post: #6
RE: Xuggle 5.5 (64bit) - unoffical test
new build , I recompiled and removed the external dependency's for 'libgcc_s_sjlj-1.dll', 'libstdc++-6.dll' (no longer need these files, so you can remove them if you have gotten the previous build.)
xuggle-5.5-git(04a94d9cc729)
(see first post for builds)

Just replace libxuggle-5.dll under 'windows-amd64\' and use the 32bit jpcsp.jar with the 64bit.


Instruction video if needed Smile

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
11-06-2012, 03:42 AM
Post: #7
RE: Xuggle 5.5 (64bit) - unoffical test
just test the games that had problem on 64 bit version and so far no problems Smile
Find all posts by this user
Quote this message in a reply
11-08-2012, 01:02 PM
Post: #8
RE: Xuggle 5.5 (64bit) - SandyBridge/IvyBridge compatibility test
I performed the same Atrac3 audio file test as before and I can happily confirm that Xuggle 5.5 is crash free on my AVX-enabled Ultrabook. I played each file 10 times without a single crash. Then I restored the original libxuggle-5.dll and the crashes were back. Replaced it with the new libxuggle-5.dll and the crashes were gone again.

Thanks for taking the trouble to compile it, hyakki! Hopefully gid15 will use this Xuggle 5.5 and we can finally get rid of Xuggle 3.4 for good.
Find all posts by this user
Quote this message in a reply
11-08-2012, 03:36 PM
Post: #9
RE: Xuggle 5.5 (64bit) - SandyBridge/IvyBridge compatibility test
Can we expect more speed or a better compatibility using the latest Xuggle or it won't change much??

Intel Core i5 - Geforce 560ti 1GB RAM - 8GB RAM - Windows 7 64bits
Find all posts by this user
Quote this message in a reply
11-09-2012, 12:03 PM (This post was last modified: 11-09-2012 12:14 PM by hyakki.)
Post: #10
RE: Xuggle 5.5 (64bit) - SandyBridge/IvyBridge compatibility test
(11-08-2012 03:36 PM)guidodi Wrote:  Can we expect more speed or a better compatibility using the latest Xuggle or it won't change much??

Probably better compatibility, the current xuggle (3.2) in jpcsp 64bit has trouble with certain types of audio that only playback on the 32bit builds (xuggle 5.4), this change brings that compatibility to the 64bit builds so you will get more audio, the reason it wasn't added before was it would crash on certain processors so it had to be reverted back to the old 3.2, so back to this thread, I manually compiled it in hopes of solving that crash, and from the looks of it it appears to be fixed I also think it's working much smoother and has less crashes..
I have personally been running this for about 3-4 days without one crash or error with relation to the media engine....

I'm not sure if / when it will be added into the official builds that's up to the devs, I don't think gid wants a repeat of before when people were complaining about the crashes ,so I was hoping more people would test this and report back good results Tongue, Itaru has given some good news since he was one of the ones able to reproduce the crash, and said this has fixed it, so most likely it will provide good results for others as-well.

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)