This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to add a plugin to jpcsp [SOLVED]
hi everyone!

recently i had some trouble with some game, such as the valkyria chronicles series for example.

I was unable to launch a new game because of some corrupted data files.
I browsed the web and found the magicsave plugin.
i took the 3.62a ver.

my problem is that i can't use it.

i never add any plugin of any kind to my jpcsp folder, so in ms0, there was only a "PSP" folder and nothing else.

as the tutorials said, i placed here "MagicSave" and "seplugins"
in "seplugins" i created three txt files namely:

"Game" ; "VSH" and "POPS"

in "Game" i wrote "ms0:/seplugins/MagicSave.prx 1"

and that's it.
i deleted the "src" folder that was in the archive, since the tutorial didn't specified to copy it to ms0.

yet, when i run the game, i press the buttons + and - (actually keep mashing them to try to activate something) nothing happens and i'm stuck.

i have no idea how to add a plugin to jpcsp and there is nothing on the web on that subject. if anyone here ave magicsave installed on their computer, would you please be so kind as to tell me what to do?

thank you!

the plugins are only for psp with cfw installed, they won't work in the emulator.

so that's it, ok thanks for the information.

is there another way than magicsave to solve that kind issue do i have to wait&see?

PCSX2, EPSXE and JPCSP. I think this is some of the best settings that would make your game add a plugin to jpcsp.
EPSXE - PS1 Emulator
-PCSX2 - PS2 Emulator
-JPCSP - PSP Emulator
-Swift Shader - Directx 9 & Pixel Shader 2.1 Rederer
-3D Analyze - Old Graphics Card Rendarer
Thank u.


i am sorry but i don't understand.
is that an answer or a question?

nevermind that, i found the content of your message on a website.
you think i should use swiftshader and 3d analyze with jpcsp is that it?

because i don't have graphic problems, it's just corrupted data that i would like to fix in order to actually start a new game, just like magicsave does for psp.

also, with games like the 3rd birthday, that runs perfectly, when i use data install, the installed data is flagged as corrupt.
is does not cause any problem with running the game, but whatever game i use, that install data option some of them give to reduce loading times never work.
but maybe it is not supposed to work on emulators? that's not a problem anyway as i said it does not prevent me from playing.

it's just that corrupted save thing that block me on games like valkyria chronicles I&II and grand knights history.

i would like to know is there is actually a way to solve this, or not.

thank you!

with the last rev 2806, i can play the game if i refuse to create a save file.
but it's pointless to play it if i can't save and there is no quiksave feature on jpcsp to bypass that issue.

i browsed the thread about the game in the half-playable section but they don't mention that problem so i guess i must be doing something wrong from the very beginning, could someone
help me with that?
is it helps, i have to mention that i can't use the jpcsp launcher, when i try to run a file, it says closed/terminated.

maybe the two are linked since everyone seems to use the launcher without issues.

all right i found the solution all thanks to you #serio and this post on another topic:

RE: Valkyria Chronicles 2 [ULUS10515]
53K8FKGP1GHQ4SBN is a password i entered, it's supposed to unlock a character. unless you mean it adds the 's to the password, which is why it's failing.

it was failing back when i was using java 1.6 too as far as i remember. edit: yep reconfirmed, 1.6 fails too.

edit: i wonder if maybe the problem with the date might be related to the crypto mode savedata setting. the game uses stuff like WRITESECURE, READSECURE and MAKEDATASECURE. problem is, if the game's in crypto savedata mode it can't create the savefiles correctly. it creates corrupted saves which it then has to delete before it can do anything.

and indeed disabling the crypto mode allowed me to create and load a savefile.
now i can play the game with no problems.

thank you very much o/

Forum Jump:

Users browsing this thread:
1 Guest(s)

Powered By MyBB, © 2002-2022 iAndrew & Melroy van den Berg.