This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HOW TO FIX ATI BUG
08-05-2011, 11:52 AM (This post was last modified: 08-05-2011 11:54 AM by solano.)
Post: #1
HOW TO FIX ATI BUG
As many of you have noticed there is a bug with ati where there is no color in the game when using shaders. Also on some ati's, the only way to get color was to turn on only ge graphics.

This was tested on r2255!
I have an Intel Core 2 Duo e6300 (1.86 Ghz, 2mb L2 cash)
Ati Radeon HD 4670 overclocked running with 1.7 GB VRAM(750Mhz GPU clock, 900 Mhz Memory clock)
2GB DDR2 RAM

How to fix:
1. Download the latest ATI driver and Catalyst: 11.7
2. Open the Catalyst Control panel and go to Gaming tab (on the left) and select 3D Application Settings.
These are the settings:
[Image: e32cf4fe5d541c8e6f82e312d2658f8a.png]
Press Apply and you are done! Enjoy

Tested on Queen's Gate Spiral chaos with options
Use shaders
Diable UBO
Enable dynamic shader generation
Enable shader "stencil buffer"

These settings are just the best for the game. You don't need them to get color.


[Image: 589e5b1aaadab7ebcddd19b0df237821.png][Image: 33068875eeadf15d3e6ac110c57ba355.png][Image: 60f7d5fdc5bbc394c74167bee67280a7.png][Image: 9376b7c1ebdb3b00213cb874ac25af6e.png]
Find all posts by this user
Quote this message in a reply
08-05-2011, 03:19 PM
Post: #2
RE: HOW TO FIX ATI BUG
solanom, you don't have to change setting on Catalyst Control panel.
i have try it with default setting Catalyst Control panel (use 11.7).

for ATI only if you use
Use shaders
Enable dynamic shader generation
Enable shader "stencil buffer"

and to work must with
Disable UBO

if you don't disable UBO it doesn't work.

Mobo:Gigabyte (GA-78LMT-USB3) CPU:AMD FX-6300 RAM:G-Skill 8GB Dual-Channel DDR3 PC12800 VGA:Sapphire R7 265 2GB OS:Windows 7 Ultimate 64-bit SP1
Find all posts by this user
Quote this message in a reply
08-07-2011, 08:24 AM
Post: #3
RE: HOW TO FIX ATI BUG
(08-05-2011 03:19 PM)dista_bagus Wrote:  solanom, you don't have to change setting on Catalyst Control panel.
i have try it with default setting Catalyst Control panel (use 11.7).

for ATI only if you use
Use shaders
Enable dynamic shader generation
Enable shader "stencil buffer"

and to work must with
Disable UBO

if you don't disable UBO it doesn't work.

So, it's just the normal workaround for the ATI shader bug? "Disable UBO" as always. Plus, I heard that Catalyst 11.7 is actually worst for JPCSP than 11.6 was (performance-wise of course), I'm sticking with 11.5 for a while Big Grin

CPU: AMD Athlon 64 Dual-Core 7850 2.80 GHz RAM: 4GB VGA: ATI Radeon 4850HD 512MB/256bit
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)