This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Killzone: Liberation - USA - UCUS98646
05-31-2012, 03:12 PM
Post: #11
RE: Killzone: Liberation - USA - UCUS98646
I've provided a fix for the NullPointerException in r2560. Could you try it?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
05-31-2012, 08:27 PM (This post was last modified: 05-31-2012 10:50 PM by montcer9012.)
Post: #12
RE: Killzone: Liberation - USA - UCUS98646
Have tried a lot of times whit r2560 and that rev can trough to the in game but just one time!. Even i tried whit same configuration next times, it crash.

Whit software rending game graphics is almost perfect, intro movie finally if good and sound is very good too! but it crash when loading screen is supposed to appear and FPS is very very slow as so keys commands.

When the game pass trough loading screen and do load, the cinematic whit the game engine WAS FROZEN ON A STATIC IMAGE but sound still there cause game continue running.
After a few seconds the character appears like the picture show. Tried to control the character touching some keys and then the world vanish and character was on a black world.

See pictures attached; that images was the only that change and in the order are paste. Left to right and in the numeric order cause that was the only images that game show; i mean that video was not smooth and lineal, it was just some frozen images; sound was good and lineal.

Is important mention that in this time game never crashed (When in game do load); i just quit the emulator cause game was too slow and world disappear.

After i quit and save the log, i start the game again but next times it crash even i don't change the configuration.

All attached logos have different configurations except log 5.

PD: r2565 Does not load the .iso image of Killzone; sayd something about xuggle on the CMD screen. I do attach the file on a txt.


Attached File(s) Thumbnail(s)
           

.7z  info log 1 - Crash r2560.7z (Size: 7.08 KB / Downloads: 1)
.7z  info log 2 - Crash r2560.7z (Size: 6.99 KB / Downloads: 0)
.7z  info log 3 - Crash r2560 - Software rending, game graphics almost perfect!.7z (Size: 7.56 KB / Downloads: 1)
.7z  info log 4 - Working! r2560 - This conf can make it through the game!.7z (Size: 8.37 KB / Downloads: 3)
.7z  info log 5 - Crash r2560 - Same config that in log 4 but that time cant make it.7z (Size: 6.99 KB / Downloads: 2)
.txt  2565 Xuggle error.txt (Size: 12.67 KB / Downloads: 3)

[Image: montcer.png]
Find all posts by this user
Quote this message in a reply
06-01-2012, 07:26 AM
Post: #13
RE: Killzone: Liberation - USA - UCUS98646
(05-31-2012 08:27 PM)montcer9012 Wrote:  Have tried a lot of times whit r2560 and that rev can trough to the in game but just one time!. Even i tried whit same configuration next times, it crash.
Is it maybe because this game is saving something in savedata (ms0/PSP/SAVEDATA/UCUS98646*): when it is present (i.e. after the 1st time), it is reloading it and then crashing. Could you try to delete this savedata and see if it behaves like the 1st time?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
06-01-2012, 10:05 PM
Post: #14
RE: Killzone: Liberation - USA - UCUS98646
(06-01-2012 07:26 AM)gid15 Wrote:  Could you try to delete this savedata and see if it behaves like the 1st time?

Have do it, and does not work :/

I do erase the content that you told me and crash. Then erase the content on \tmp, and still crashing.

Gid15, there will be a way to help you fix this? I can handle whit batch files, and on google are the commands i will need to program on java; i just need to know how does works JPCSP to understand it.

Ooor, to be more practice, there will be a way to live try the fixes you program?


Attached File(s)
.7z  log 2560 - Temp and Save erased, still crashing.7z (Size: 6.96 KB / Downloads: 1)

[Image: montcer.png]
Find all posts by this user
Quote this message in a reply
07-04-2012, 09:06 PM
Post: #15
RE: Killzone: Liberation - USA - UCUS98646
Why game working stop here?? Sad Huh

[Image: montcer.png]
Find all posts by this user
Quote this message in a reply
07-10-2012, 04:18 AM
Post: #16
RE: Killzone: Liberation - USA - UCUS98646
Ok, i don't really know what happen here cause no body told me theres a new fix on next releases, but game is loading ALWAYS. (An improvement since last post when game always crash saying something about ERROR MEMORY X)

Since last post the software changes on my machine are:
Clean SO W7 SP1x64 Up to Date / AMD Catalyst 12.6 / Java 7u5

Hardware changes:
None


So as i say, game always load to in game, and this time no matter what config i choose, smooth or freeze graphics results, Templar character always end on a black world whit arms opens.

Have tried 3 differents configs over and over to prove that and as far i can see the best is the one named "BEST". Told that because last time game work for me only does 1 time; even i have same configuration if i start it again game crash; now game always run but always whit tragic end for Templar on that black world.

BEST: Image flip on the sides and some textures appear and dissapear a lot. Very glitch, but as i say, is the best playable config.

Good: Very good graphics, not craxy textures but instead, game is just a few frozen screen that change sometimes.

Poor: Menus was good, but image freeze at all on loading screen besides it still running.

Sound was very good on all configurations.


Attached File(s) Thumbnail(s)
   

.7z  Rev r2604 Working Best - Smooth image and acceptable FPS but dont work.7z (Size: 7.13 KB / Downloads: 4)
.7z  Rev r2604 Working Good - In game graphics are just a few freeze images while sound still running.7z (Size: 8.51 KB / Downloads: 1)
.7z  Rev r2604 Working Poor - Image freeze on loading screen but game still running.7z (Size: 84 bytes / Downloads: 1)

[Image: montcer.png]
Find all posts by this user
Quote this message in a reply
07-11-2012, 04:10 PM
Post: #17
RE: Killzone: Liberation - USA - UCUS98646
(07-10-2012 04:18 AM)montcer9012 Wrote:  Image flip on the sides and some textures appear and dissapear a lot. Very glitch, but as i say, is the best playable config.
This could be improved by r2606. Could you check?

Thanks

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
07-12-2012, 04:55 AM
Post: #18
RE: Killzone: Liberation - USA - UCUS98646
I cant try on r2606 cause it haven't a downloadable build; so i try on r2608.

First, an importance notice. The graphics issues on the game looks like aren't the most important problem; since game still running besides the black screen or the slow FPS i have notice that the problem is something whit the emulation it self.

So i don't know if was noticed before but: On every configurations i try, Templar always TRESPASS THE FLOOR AND FALL DOWN on that black world that is posted on many logs here; he just don't appear there, he fall down trespassing the floor. The bug happen in a precise moment and is after the first tutorial pop up.

I don't know if on the logs this information will be displayed, but for now on the problem on the game is the floor that not support Templar character and let him fall down hahahaha.

KZ 2 r2608 - Poor - Old Config: This is the old config that have smooth image on r2606. This time image fas flip on left side by just a bar; the only way to make image appear complete (but glitch) if i resize image x2. (See attached pictures).

KZ 2 r2608 - Best - Smoth confg: On that rev i saw it a little more smoothest.

NOTES: Now the game can run whit smooth image whit differents configurations; problems still being slow FPS to let it play and the most important; Templar fall down traspassing the floor.


Attached File(s) Thumbnail(s)
       

.7z  KZ 2 r2608 - Best - Smoth confg.7z (Size: 8.12 KB / Downloads: 3)
.7z  KZ 2 r2608 - Poor - Old Config.7z (Size: 7.87 KB / Downloads: 1)

[Image: montcer.png]
Find all posts by this user
Quote this message in a reply
07-12-2012, 07:05 AM
Post: #19
RE: Killzone: Liberation - USA - UCUS98646
From what i heard from a friend that worked dev team of killzone game has some internal checks for prevent hacking (and emulating) . Maybe that's the case
Find all posts by this user
Quote this message in a reply
07-12-2012, 07:13 AM
Post: #20
RE: Killzone: Liberation - USA - UCUS98646
(07-12-2012 04:55 AM)montcer9012 Wrote:  So i don't know if was noticed before but: On every configurations i try, Templar always TRESPASS THE FLOOR AND FALL DOWN on that black world that is posted on many logs here; he just don't appear there, he fall down trespassing the floor. The bug happen in a precise moment and is after the first tutorial pop up.
Hmmm, this could come from an incorrect emulation of a VFPU instruction. Could you enable the profiler (in the Compiler tab), run the game and leave it run for about 1 minute when the Templar is falling. After that, close Jpcsp and it will generate a profiler.txt file. Maybe I will find some rare VFPU instruction in it...

Thanks!

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)