This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 10 Vote(s) - 2.9 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hatsune Miku Project Diva 2nd [ULJM05681]
#61
somebody can give me the save game 100% or something like this for jpcsp&
Reply
#62
(11-21-2011, 10:15 PM)valeric92 Wrote: somebody can give me the save game 100% or something like this for jpcsp&

Just get one from here: http://www.gamefaqs.com/psp/991048-hatsu...-2nd/saves

Don't forget to enable handle SAVEDATA in crypto mode.
Reply
#63
Hatsune Miku: Project Diva 2nd JPCSP Full Speed on AMD/ATI card
960x544 resolution

You have to force v-sync to off in Catalyst Control Panel to get rid of the SUDDEN FPS DROP problem

*Stuttering and lag caused by Fraps*

Compatible settings:
Video - Use vertex Cache,Use a Geometry Shader for 2d rendering,Disable UBO,Enable VAO,Enable saving GE screen to Textures instead of memory, Enable dynamic shader generation
Memory - Ignore invalid memory access,Ignore unmapped imports
Media - Use Media Engine, Decode audio files with SonicStage
Compiler - Use Compiler(dynarec), Maximum method size = 3000
Crypto - Handle SAVEDATA in crypto mode (for loading certain save files)

Reply
#64
This game works amazing in the most recent jpcsp (build 2574 I believe) and I'm just posting to share my config, since none of the other ones I've seen posted around gave me the best performance (most still caused me to have jittering and laggyness in game), but the following config has it running as smooth as can be at 30FPS.

Video: Use vertex cache, use shaders, Use a Geometry Shader for 2D rendering, Enable saving GE screen to Textures instead of Memory.
Memory: Ignore invalid memory access, ignore unmapped imports.
Media: NONE
Compiler: Use compiler, 50 Max method size
Display: I have 8x Anti-aliasing on, this is more of a preference/how much your GPU can handle option.

Also, as mentioned in the post above, you need to force Vsync to be off in your respecting graphics control panel.

If anyone is curious, I'm running it on a:
Windows 7 Laptop
Intel i5 processor at 2.3Ghz
Geforce 550M
6 Gigs of RAM
Reply
#65
using geometry shader on ATi card will introduce input lag in my case.
Reply
#66
psp 
HELP! anyone.
i have problems using JPCSP. not the game.
everytime i run a game, even the cube.iso, nothing happens.
the logs have yellow-colored text that i believe is an error.
please help.
this logs are from project diva.


157 [GUI] INFO emu - Java version: 1.7.0_06 (1.7.0_06-b24)
158 [GUI] INFO emu - Jpcsp v0.6
162 [GUI] INFO emu - UMD param.sfo :
APP_VER = 01.00
BOOTABLE = 1
CATEGORY = UG
DISC_ID = ULJM05681
DISC_NUMBER = 1
DISC_TOTAL = 1
DISC_VERSION = 1.00
HRKGMP_VER = 19
PARENTAL_LEVEL = 5
PSP_SYSTEM_VER = 6.20
REGION = 32768
TITLE = 初音ミク -Project DIVA- 2nd
USE_USB = 0
probably homebrew? false
193 [GUI] INFO emu - Loading global compatibility settings:
193 [GUI] INFO emu - Configuration / Region
200 [GUI] INFO emu - Language [English]
201 [GUI] INFO emu - Button preference: ["O" for "Enter"]
202 [GUI] INFO emu - Daylight savings: [Off]
203 [GUI] INFO emu - Time zone offset in minutes (GMT+/-): [0]
203 [GUI] INFO emu - Time format: [24H]
204 [GUI] INFO emu - Date format: [YYYY-MM-DD]
205 [GUI] INFO emu - WLAN power saving mode: [Off]
206 [GUI] INFO emu - Ad hoc channel: [Auto]
206 [GUI] INFO emu - Nickname: []
207 [GUI] INFO emu - Configuration / Video
207 [GUI] INFO emu - [ ] Disable VBO (automatically disabled if not supported)
208 [GUI] INFO emu - [ ] Only GE graphics (not recommended for homebrew)
209 [GUI] INFO emu - [X] Use vertex cache
209 [GUI] INFO emu - [X] Use shaders (experimental)
214 [GUI] INFO emu - [ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
216 [GUI] INFO emu - [X] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
217 [GUI] INFO emu - [ ] Enable VAO (only relevant when using shaders and vertex cache)
217 [GUI] INFO emu - [X] Enable saving GE screen to Textures instead of Memory
218 [GUI] INFO emu - [ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
218 [GUI] INFO emu - [X] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
219 [GUI] INFO emu - Configuration / Audio
219 [GUI] INFO emu - [ ] Disable audio threads
220 [GUI] INFO emu - [ ] Disable audio channels (not recommended)
220 [GUI] INFO emu - [ ] Disable audio blocking
221 [GUI] INFO emu - Configuration / Memory
221 [GUI] INFO emu - [X] Ignore invalid memory access (not recommended for test reports, but improves performance)
222 [GUI] INFO emu - [X] Ignore unmapped imports (not recommended)
222 [GUI] INFO emu - Configuration / Media
223 [GUI] INFO emu - [X] Use Media Engine
223 [GUI] INFO emu - [ ] Extract media files to tmp folder
223 [GUI] INFO emu - [X] Decode audio files with SonicStage (must be installed separately and requires Media Engine)
224 [GUI] INFO emu - [ ] Use non-native fonts from flash0 folder
224 [GUI] INFO emu - Configuration / Compiler
224 [GUI] INFO emu - [X] Use compiler (dynarec)
225 [GUI] INFO emu - [X] Output profiler info to profiler.txt (only for compiler)
225 [GUI] INFO emu - [100] Maximum method size
225 [GUI] INFO emu - Configuration / Crypto
226 [GUI] INFO emu - [X] Extract decrypted EBOOT.BIN files to the TMP folder
226 [GUI] INFO emu - [ ] Handle SAVEDATA in crypto mode
227 [GUI] INFO emu - [ ] Extract original PGD files to the TMP folder
238 [GUI] INFO ge - Only GE Graphics: false
238 [GUI] INFO hle.sceMpeg - Media Engine enabled
333 [GUI] INFO ge - Using Async Vertex Cache
334 [GUI] INFO hle.sceAudio - Audio ChReserve disabled: false
335 [GUI] INFO hle.sceAudio - Audio Blocking disabled: false
335 [GUI] INFO hle.ThreadManForUser - Audio threads disabled: false
336 [GUI] INFO memory - Ignore invalid memory access: true
338 [GUI] INFO hle - Ignore Unmapped Imports enabled
602 [GUI] INFO emu - Unrecognized file format
603 [GUI] INFO emu - File magic 00 00 00 00
790 [GUI] INFO emu - Found ModuleInfo name:'PdvApp' version:0101 attr:00000000 gp:08c5bfd0
794 [GUI] INFO emu - Found 245 unresolved imports

******************************************************
795 [GUI] WARN emu - Failed to map import at 0x08BAE188 [0x7D1FBED3] Module 'sceRtc'(attempt 1)
796 [GUI] WARN emu - Failed to map import at 0x08BAE208 [0xAE6D2027] Module 'sceMp3'(attempt 1)
******************************************************

796 [GUI] INFO emu - 243 NIDS mapped
796 [GUI] INFO emu - 2 remaining unmapped NIDS
809 [GUI] INFO hle.sceDisplay - Saving GE to Textures
863 [GUI] INFO hle - Using the external audio decoder (SonicStage)
1349 [GUI] INFO hle.sceFont - Loading font file 'ltn0.pgf'. Font='Liberation Sans' Type='Regular'
1358 [GUI] INFO hle.sceFont - Loading font file 'ltn1.pgf'. Font='Liberation Serif' Type='Regular'
1367 [GUI] INFO hle.sceFont - Loading font file 'ltn2.pgf'. Font='Liberation Sans' Type='Italic'
1373 [GUI] INFO hle.sceFont - Loading font file 'ltn3.pgf'. Font='Liberation Serif' Type='Italic'
1380 [GUI] INFO hle.sceFont - Loading font file 'ltn4.pgf'. Font='Liberation Sans' Type='Bold'
1386 [GUI] INFO hle.sceFont - Loading font file 'ltn5.pgf'. Font='Liberation Serif' Type='Bold'
1393 [GUI] INFO hle.sceFont - Loading font file 'ltn6.pgf'. Font='Liberation Sans' Type='Bold Italic'
1400 [GUI] INFO hle.sceFont - Loading font file 'ltn7.pgf'. Font='Liberation Serif' Type='Bold Italic'
1406 [GUI] INFO hle.sceFont - Loading font file 'ltn8.pgf'. Font='Liberation Sans' Type='Regular'
1412 [GUI] INFO hle.sceFont - Loading font file 'ltn9.pgf'. Font='Liberation Serif' Type='Regular'
1418 [GUI] INFO hle.sceFont - Loading font file 'ltn10.pgf'. Font='Liberation Sans' Type='Italic'
1424 [GUI] INFO hle.sceFont - Loading font file 'ltn11.pgf'. Font='Liberation Serif' Type='Italic'
1430 [GUI] INFO hle.sceFont - Loading font file 'ltn12.pgf'. Font='Liberation Sans' Type='Bold'
1437 [GUI] INFO hle.sceFont - Loading font file 'ltn13.pgf'. Font='Liberation Serif' Type='Bold'
1444 [GUI] INFO hle.sceFont - Loading font file 'ltn14.pgf'. Font='Liberation Sans' Type='Bold Italic'
1450 [GUI] INFO hle.sceFont - Loading font file 'ltn15.pgf'. Font='Liberation Serif' Type='Bold Italic'
1452 [GUI] INFO hle.IoFileMgrForUser - pspiofilemgr - filepath disc0/

******************************************************
1564 [root] WARN hle - Unsupported syscall 2083 SysMemUserForUser_35669D4C 05000010 09FFFE00 00000000
******************************************************

1637 [user_main] INFO hle.LoadExecForUser - sceKernelRegisterExitCallback SceUID=e
1640 [user_main] INFO hle.scePower - scePowerRegisterCallback slot=-1 SceUID=f
3076 [igPSPPowerManager] INFO hle.LoadExecForUser - sceKernelRegisterExitCallback SceUID=14
3077 [igPSPPowerManager] INFO hle.scePower - scePowerRegisterCallback slot=15 SceUID=15

******************************************************
8323 [user_main] WARN hle.sceDisplay - sceDisplaySetFrameBuf(topaddr=0x0, bufferwidth=512, pixelformat=3, syncType=1) (blocking display output)
******************************************************

13361 [user_main] INFO hle.sceDisplay - sceDisplaySetFrameBuf(topaddr=0x4000000, bufferwidth=512, pixelformat=3, syncType=1) ok
15994 [user_main] INFO hle.sceUtility - IGNORING: sceUtilityLoadModule(module=0x0500) PSP_MODULE_NP_DRM

******************************************************
16001 [user_main] WARN hle.scePspNpDrm_user - PARTIAL: sceNpDrmSetLicenseeKey (npDrmKeyAddr=0x8bbc70c)
******************************************************

16007 [user_main] INFO hle.scePspNpDrm_user - NPDRM Encryption key detected: 0xc381c4ce92af7479e825d1514fde49d
16530 [user_main] INFO hle.scePower - scePowerRegisterCallback slot=-1 SceUID=6e
16608 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Script.cpk flags = 4001 permissions = 020644
16720 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Script.cpk flags = 4001 permissions = 020644
16751 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Script.cpk flags = 4001 permissions = 020644
16818 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Sound.cpk flags = 4001 permissions = 020644
16848 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Sound.cpk flags = 4001 permissions = 020644
16877 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Sound.cpk flags = 4001 permissions = 020644
16961 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Data.cpk flags = 4001 permissions = 020644
16989 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Data.cpk flags = 4001 permissions = 020644
17024 [CriThread] INFO hle.IoFileMgrForUser - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/media/afs/Diva2Data.cpk flags = 4001 permissions = 020644

thats all the logs. sorry for the long comment.
enclosed in ******************* are the yellow text ones.
Reply
#67
I can't seem to get this game to be stable. I have my NVIDIA v-sync turned off, the settings all in order, and whenever I activate vertex cache, the game refuses to boot. I made a thread here http://www.emunewz.net/forum/showthread.php?tid=80031 which ultimately directed me to this thread. I'll post my log but I can't find out why this isn't working. I know I meet the specs.


Attached Files
.7z   log.7z (Size: 16.62 KB / Downloads: 8)
Reply
#68
Try this setting :
[ ] Disable VBO (automatically disabled if not supported)
[ ] Only GE graphics (not recommended for homebrew)
[X] Use vertex cache
[X] Use shaders (experimental)
[ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
[X] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
[ ] Enable VAO (only relevant when using shaders and vertex cache)
[X] Enable saving GE screen to Textures instead of Memory
[ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
[X] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
[ ] Enable the shader implementation for the "Stencil Test" (more accurate but slower)
[ ] Enable the shader implementation for the "Color Mask" (more accurate but slower)
[ ] Disable optimized VertexInfo reading (may improve compatibility)
[ ] Use Software Rendering (very experimental, not yet complete, slow)

[X ] Ignore invalid memory access (not recommended for test reports, but improves performance)
[X] Ignore unmapped imports (not recommended)

[X] Use Media Engine
[ ] Extract media files to tmp folder
[X] Decode audio files with SonicStage (must be installed separately and requires Media Engine)
[ ] Use debug font (disable flash0 fonts)

[X] Extract decrypted EBOOT.BIN files to the TMP folder
[ ] Handle SAVEDATA in crypto mode
[ ] Extract original PGD files to the TMP folder

Don't forget to install sonicstage.

Also, I just tested the game on latest JPCSP. Works fine even if I enable vertex cache.
Reply
#69
I tried all of that with no luck. Same problem.
Reply
#70
Testing with the emulator:
For play this game smoothly you HAVE TO FORCE OFF the Vsync to off on your VGA's control panel (Only ATI and Nvidia).

JPCSP config:
1- Video:
Check: Vertex Cache, Shaders, Disable UBO and VAO and enable dinamic Shader.
*Note: Don't check "use geometry shader for 2D rendering", because this setting will low some FPS, and you'll have some imput problems with it.

2- Memory:
Check all options.

3- Media:
Check Use Media Engine.
*Optional, check use SonicStage, if it is installed.

4- Compiler:
Check use compiler. Set the max method size to 50.
*Note: Thanks to loveassassins for this, but recommend use my setting, because i can't play with his setting xD

Video:
*Note: This video was recorded weeks ago, the only change is the Max size Method, on default here.
*Note 2: The settings for Project DIVA 2nd can be used for Project DIVA Extend.
*Note 3: I tested all this for myself. AMD Phenom II X4 @ 3.0GHz, 3GB RAM, ATI HD4670 and Windows 8 Enterprise.


Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)