This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
05-12-2017, 07:30 AM (This post was last modified: 06-24-2017 08:34 PM by ssshadow.)
Post: #1
The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
Settings:
PPU LLVM
SPU ASMJIT
Any renderer, but OpenGL has been extensively tested already. DX12 and Vulkan probably also work just fine but may be slower...
Use GPU Texture Scaling.

http://tinypic.com/view.php?pic=5bqyph&s=9
Find all posts by this user
Quote this message in a reply
05-12-2017, 08:44 AM
Post: #2
RE: The Legend of Heroes: Trails of Cold Steel 2 BLUS31597
which cpu, gpu, & rpcs3 build did you used?
Find all posts by this user
Quote this message in a reply
05-12-2017, 09:45 AM (This post was last modified: 05-12-2017 09:50 AM by foreveryou79.)
Post: #3
RE: The Legend of Heroes: Trails of Cold Steel 2 BLUS31597
(05-12-2017 08:44 AM)Jhon1234 Wrote:  which cpu, gpu, & rpcs3 build did you used?

i7 4790k, gtx970,
rpcs3 build, it is the one that is not the official release I think, it was mod or beta or something, the one used for cold steel 1 is the one I used, didn't change anything and worked OK for me.

I posted screenshot of the version I used if it helps you.

[Image: n13wqa.png]
Find all posts by this user
Quote this message in a reply
05-12-2017, 02:22 PM
Post: #4
RE: The Legend of Heroes: Trails of Cold Steel 2 BLUS31597
This thread should be renamed to: The Legend of Heroes: Trails of Cold Steel II [BLUS31597].

Desktop: Intel Core i7-6700K, Nvidia GeForce GTX 970 (OpenGL, DirectX12 & Vulkan), Windows 10
Laptop: Intel Core i3-4030U, Nvidia GeForce 820M (OpenGL only), Windows 8.1
Find all posts by this user
Quote this message in a reply
05-12-2017, 03:47 PM (This post was last modified: 05-12-2017 03:47 PM by ssshadow.)
Post: #5
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
Fixed. Also don't embedd huge images. Maybe you didn't notice on a 1440p screen or whatever but it breaks the forum layout even in 1080p. Yes this forum software is old...

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
05-16-2017, 06:47 PM
Post: #6
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
Missing log, see submission guidelines.

Desktop: AMD FX-8350 | AMD R9 280X 3G
Laptop: Intel i7-6700HQ | NVIDIA GTX 960M 2G
Find all posts by this user
Quote this message in a reply
05-30-2017, 10:19 AM
Post: #7
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
On a whim I tried this game on the newest build
rpcs3-v0.0.2-2017-05-26-7739f332_win64

Miraculously it worked. After a short install of game data, I was able to see the opening intro and was able to start a new game before it got stuck on infinite loading.

Attached is the log file.

I could only try it on D3D12 since my OpenGL doesn't work anymore on the newest builds. Now usually my crappy video card shoots down my hopes of playing these games because Trails of Cold Steel 1 doesn't work for me. But maybe I'm just missing a little thing here to get this to work?


Attached File(s)
.rar  RPCS3.rar (Size: 427.08 KB / Downloads: 6)
Find all posts by this user
Quote this message in a reply
05-31-2017, 12:11 AM
Post: #8
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
Looks like an Intel GPU problem... But it "should" support Vulkan too so maybe try that. Also definitely use PPU LLVM with the config hack mentioned here: http://www.emunewz.net/forum/showthread....#pid230652

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
05-31-2017, 04:28 AM (This post was last modified: 05-31-2017 09:40 AM by jazjaz36.)
Post: #9
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
(05-31-2017 12:11 AM)ssshadow Wrote:  Looks like an Intel GPU problem... But it "should" support Vulkan too so maybe try that. Also definitely use PPU LLVM with the config hack mentioned here: http://www.emunewz.net/forum/showthread....#pid230652

I followed the link. I was able to pass the main menu and start a new game. So far its working. The only problems that I could see are three things

1. Speed is still slow but that's not so bad, I think.
2. Only 1 save file. But I think info on that is on the link you just gave.
3. The biggest problem is that the field map is black (mini map, flashback scenes, and even character status is visible). You can see everything else though except that. Attached are pics.

I got a new Trails of Cold Steel 1 game too and its the same result here (black field map and conversations). Maybe my original game version was just corrupted that's why it doesn't work. Anyway I think that if there is a solution, both the problems on both games will be solved.

EDIT: Cross that. I solved the blackness issue by checking "write color buffers" on the graphics menu. The problem now is that it got even slower than before from 2 fps to 5. So if anyone has a good speedhack or something please let me know.


Attached File(s) Thumbnail(s)
               

.rar  RPCS3.rar (Size: 1.01 MB / Downloads: 8)
Find all posts by this user
Quote this message in a reply
05-31-2017, 02:48 PM
Post: #10
RE: The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
GPU texture scaling + OpenGL is the way to run this game really. I think you are "doomed" for now with buggy Intel graphics drivers. But I'll check with graphics developer kd-11.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)