This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Demon's Souls [BLES00932]
01-23-2017, 07:59 PM (This post was last modified: 07-29-2017 07:14 PM by Annie.)
Post: #1
Demon's Souls [BLES00932]
Playable:




Settings:
PPU LLVM Recompiler
SPU ASMJIT Recompiler
SPU loop detection: On
Preferred SPU Threads: 4 (probably but you have to test to see what's better for your CPU)
SPU delay penalty: 0 (config.yml only setting for now)
OpenGL or Vulkan (faster) + Write Color Buffers + Invalidate cache every frame

Known issues:
Very very rarely loading screens may look like they have locked up, but the game will recover after ~30 seconds.

Historical blog post from when the game first stared working: https://rpcs3.net/blog/2017/03/11/des/

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
03-11-2017, 07:42 PM
Post: #2
RE: Demon's Souls [BLES00932]
Moving to ingame

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
03-12-2017, 02:33 AM (This post was last modified: 03-12-2017 05:54 PM by ssshadow.)
Post: #3
RE: Demon's Souls [BLES00932]
(01-23-2017 07:59 PM)ssshadow Wrote:  Works well but a little slow. See this post: https://rpcs3.net/blog/2017/03/11/des/

I'm unable to run the game. It loads (can be booted) but nothing is seem on the screen (black screen with 30 fps. I'm using the most recent build, but I'm getting these errors (no need for the entire log I guess, as this is the only kind of error I get):
[redacted console spam]
Using PPU and SPU as Interpreter (Fast) + OpenGL
Find all posts by this user
Quote this message in a reply
03-12-2017, 09:50 AM (This post was last modified: 03-12-2017 05:55 PM by ssshadow.)
Post: #4
RE: Demon's Souls [BLES00932]
Tried running the game with the version provided at the end of the article.

lib problem at the beginning and some kind of a mem problem after booting the game. The debugger keeps spamming "sys_fs: sys_fs_open" and "cellFsOpen" until stopping the game while running a black screen at 30 fps.

Were the changes / fixes mentioned in the article compiled into the the build or I'm supposed to do that myself?

This is my first try at launching a game with RPCS3, so maybe I'm just missing something pretty basic.

PS: I checked multiple dev_flash packs and PS3 update files and none of them have a lib called "cellLibprof".

[redacted console spam]
Find all posts by this user
Quote this message in a reply
03-12-2017, 05:55 PM
Post: #5
RE: Demon's Souls [BLES00932]
Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
03-12-2017, 06:11 PM
Post: #6
RE: Demon's Souls [BLES00932]
(03-12-2017 05:55 PM)ssshadow Wrote:  Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked


Attached File(s)
.zip  RPCS3.zip (Size: 406.69 KB / Downloads: 55)
Find all posts by this user
Quote this message in a reply
03-12-2017, 06:57 PM
Post: #7
RE: Demon's Souls [BLES00932]
(03-12-2017 06:11 PM)Bathory Wrote:  
(03-12-2017 05:55 PM)ssshadow Wrote:  Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked

Check if the file PS3_DISC.sfb exists next to the folder PS3_GAME and not somewhere else. If it is somewhere else move it to the correct location.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
03-12-2017, 07:07 PM (This post was last modified: 03-13-2017 12:20 AM by ssshadow.)
Post: #8
RE: Demon's Souls [BLES00932]
(03-12-2017 05:55 PM)ssshadow Wrote:  Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Works now. Borrowed the US version instead of the EU.

Interpreter fast on (PPU)
ASMJIT (SPU)
Load auto
Vulkan
1280x720

~20 fps on a 16 core 2.8 GHz Xeon
Find all posts by this user
Quote this message in a reply
03-12-2017, 07:09 PM
Post: #9
RE: Demon's Souls [BLES00932]
(03-12-2017 06:57 PM)ssshadow Wrote:  
(03-12-2017 06:11 PM)Bathory Wrote:  
(03-12-2017 05:55 PM)ssshadow Wrote:  Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked

Check if the file PS3_DISC.sfb exists next to the folder PS3_GAME and not somewhere else. If it is somewhere else move it to the correct location.
I've found the solution, based on your answer. The file was in the correct folder, but the extension was sfb.txt, I just had to remove the .txt and the game loaded. Thx for your help
Find all posts by this user
Quote this message in a reply
03-12-2017, 07:44 PM
Post: #10
RE: Demon's Souls [BLES00932]
Only worked first time.

Menu and everything works, but no ingame graphics are displayed. Looks like this.


[Image: souls6.jpg]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)