This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Atelier Meruru: The Apprentice of Arland [BLES01593]
09-09-2016, 09:05 PM (This post was last modified: 04-09-2017 01:12 PM by ssshadow.)
Post: #1
Atelier Meruru: The Apprentice of Arland [BLES01593]
Works fine and runs fast with both recompilers and Vulkan or DX12, but OpenGL is ok too. Random hanging is fixed, and as of this PR you can save and load. Rarely some text will be missing but this will be fixed shortly.

You need to manually load libfs.sprx in addition to what is automatically loaded. In settings tick "load liblv2.sprx only" and in the long list of modules tick libfs.sprx. Leave every other module unchecked.

Settings I used:
OpenGL 1280x720
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
XAudio

Log:

.zip  meruru.zip (Size: 274.48 KB / Downloads: 48)

Screens:
                   

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
09-15-2016, 12:50 PM
Post: #2
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
Gust games won't boot anymore with the newests versions:

F {rsx::thread} class std::runtime_error thrown: Unknown vertex base type 0
(in file C:\rpcs3\rpcs3\Emu\RSX\gcm_enums.cpp:16)
Find all posts by this user
Quote this message in a reply
09-19-2016, 07:22 PM (This post was last modified: 09-19-2016 08:03 PM by ssshadow.)
Post: #3
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-15-2016 12:50 PM)rauldj Wrote:  Gust games won't boot anymore with the newests versions:

F {rsx::thread} class std::runtime_error thrown: Unknown vertex base type 0
(in file C:\rpcs3\rpcs3\Emu\RSX\gcm_enums.cpp:16)

Fixed with Pull request #2140 - Rsx refactor (or earlier, didn't test). For some reason none of the Gust games have any music now...

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
09-20-2016, 03:14 PM
Post: #4
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-19-2016 07:22 PM)ssshadow Wrote:  Fixed with Pull request #2140 - Rsx refactor (or earlier, didn't test). For some reason none of the Gust games have any music now...


Yeah, thanks, I get them to boot now, Dragon's Crown too, but I still have music on the Gust games I managed to boot before: Ar tonelico III and Atelier Totori (this one even plays the intro video sequence now).
Find all posts by this user
Quote this message in a reply
09-20-2016, 06:43 PM
Post: #5
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-20-2016 03:14 PM)rauldj Wrote:  
(09-19-2016 07:22 PM)ssshadow Wrote:  Fixed with Pull request #2140 - Rsx refactor (or earlier, didn't test). For some reason none of the Gust games have any music now...


Yeah, thanks, I get them to boot now, Dragon's Crown too, but I still have music on the Gust games I managed to boot before: Ar tonelico III and Atelier Totori (this one even plays the intro video sequence now).

I must have used the wrong config, music is indeed working. What LLE modules did you use for the intro video though?

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
09-20-2016, 08:15 PM
Post: #6
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-20-2016 06:43 PM)ssshadow Wrote:  I must have used the wrong config, music is indeed working. What LLE modules did you use for the intro video though?

Well... I have a bunch of them enabled but I think it's related to "libdmux" and "libdmuxpamf".
Find all posts by this user
Quote this message in a reply
09-20-2016, 09:55 PM
Post: #7
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-20-2016 08:15 PM)rauldj Wrote:  
(09-20-2016 06:43 PM)ssshadow Wrote:  I must have used the wrong config, music is indeed working. What LLE modules did you use for the intro video though?

Well... I have a bunch of them enabled but I think it's related to "libdmux" and "libdmuxpamf".

Doesn't work for me, still a black screen. Just paste your entire list of LLE modules and I'll try to figure it out. (you can copy it from near the top of the config.yml file)

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
09-21-2016, 10:33 AM
Post: #8
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-20-2016 09:55 PM)ssshadow Wrote:  Doesn't work for me, still a black screen. Just paste your entire list of LLE modules and I'll try to figure it out. (you can copy it from near the top of the config.yml file)

Here they are:

- libac3dec.prx
- libac3dec2.prx
- libadec.prx
- libat3dec.prx
- libatrac3multi.elf
- libatrac3multi.prx
- libatxdec.prx
- libdmux.prx
- libdmuxpamf.prx
- libfiber.prx
- libfont.prx
- libfontFT.prx
- libfreetype.prx
- libfreetypeTT.prx
- libfs.prx
- libresc.prx
- librtc.prx
- libsail.prx
- libspurs_jq.prx
- libsre.prx
- libsync2.prx
Find all posts by this user
Quote this message in a reply
09-21-2016, 08:25 PM (This post was last modified: 09-21-2016 08:25 PM by ssshadow.)
Post: #9
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-21-2016 10:33 AM)rauldj Wrote:  
(09-20-2016 09:55 PM)ssshadow Wrote:  Doesn't work for me, still a black screen. Just paste your entire list of LLE modules and I'll try to figure it out. (you can copy it from near the top of the config.yml file)

Here they are:
...

Yeah that works. I'll look into it later and see why. So far I have seen the opening video in Totori, Meruru and Ayesha. Slowly FTPing Ar Tonelico 3 from my PS3 to test that as well.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
09-21-2016, 08:37 PM
Post: #10
RE: Atelier Meruru: The Apprentice of Arland [BLES01593]
(09-21-2016 08:25 PM)ssshadow Wrote:  Yeah that works. I'll look into it later and see why. So far I have seen the opening video in Totori, Meruru and Ayesha. Slowly FTPing Ar Tonelico 3 from my PS3 to test that as well.

The intro in the last one runs like crap on my 4.4 GHz 4670K D:.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)