This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Catherine [BLES01459]
06-28-2015, 12:36 AM (This post was last modified: 04-11-2017 03:54 PM by ssshadow.)
Post: #1
Catherine [BLES01459]
Update 2017-03-20 Graphics and performance are flawless with DX12 and Vulkan on a fast CPU. Use ASMJIT + LLVM. If ASMJIT shows a black screen use fast SPU interpreter.







In Only with build DX12
Show the loading screen, 30 fps with the flashing icon.
   
And then shows after 20 sec another Logo "Deep Silver"
   
The 2nd logo disappears after 55 sec.
Log error

Note that this sequence is repeated in a loop.
Quote:E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 4(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 8(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 12(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 16(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 20(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 24(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 28(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 32(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 36(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 40(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 44(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 48(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 52(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 56(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 60(0x2dc8)
E {RSXThread} Unknow min filter 7
E {RSXThread} Unknow mag filter 4

Upload you Log Here :
PC spec:
Windows 10 PRO X64 Insider 16.232
Amd Ryzen 1700X @3.8 ghz
MSI Core Frozr L
16 go Corsair Vengeance LPX PC4-25600 (3200MHz)
MSI GTX 1080 Gaming X 8G
MSI X370 Gaming Pro Carbon
500 Go SSD Samsung 960 EVO M.2
Find all posts by this user
Quote this message in a reply
06-28-2015, 11:51 AM
Post: #2
RE: Catherine [BLES01459]
Any sound like in the other version?

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
06-28-2015, 12:08 PM (This post was last modified: 06-28-2015 11:18 PM by Dante38490.)
Post: #3
RE: Catherine [BLES01459]
(06-28-2015 11:51 AM)ssshadow Wrote:  Any sound like in the other version?
Yes after second logo

I did several test by timing the time for loading the first screen and shows really interesting thing.
From the black screen until the disappearance of the logo.

With CPU : PPU interpreter
Quote:SPU interpreter = 7:05 min
SPU interpreter 2 = 34 sec
SPU asmjit = 12:00 min

With CPU : PPU interpreter 2
Quote:SPU interpreter = 27 sec
SPU interpreter 2 = 18 sec
SPU asmjit = 4:40 min

So we see that the CPU fastest is the "PPU interpreter 2"
I can not test the "PPU JIT (LLVM)" it is not yet compatible with VS 2015.

Then the SPU fastest is very clearly the "SPU Interpreter 2", the "SPU JIT (ASMJIT)" is so slow that even the "SPU Interpreter" is faster and has fewer freeze.

The problem with "SPU JIT (ASMJIT)" are caused by the changes made Nekotekina on that branch, the master branch she has no problem, and no freeze.

This problem should be solved when Neko will be merge to the master, I hope so ^^

Upload you Log Here :
PC spec:
Windows 10 PRO X64 Insider 16.232
Amd Ryzen 1700X @3.8 ghz
MSI Core Frozr L
16 go Corsair Vengeance LPX PC4-25600 (3200MHz)
MSI GTX 1080 Gaming X 8G
MSI X370 Gaming Pro Carbon
500 Go SSD Samsung 960 EVO M.2
Find all posts by this user
Quote this message in a reply
08-15-2015, 03:31 PM
Post: #4
RE: Catherine [BLES01459]
For last My build Game Show nothing, rpcs3 is a pause with error
Quote:E {PPU[0x1] Thread (main_thread)[0x00c2fd9c]} Exception: Access violation writing location 0x762
(in file ..\Utilities\Thread.cpp:1122, in function _se_translator)
E {PPU[0x1aa] Thread (CriSr_ProcessServer)[0x00a90350]} cellSync: cellSyncMutexTryLock() -> CELL_SYNC_ERROR_BUSY (0x8041010a)

Upload you Log Here :
PC spec:
Windows 10 PRO X64 Insider 16.232
Amd Ryzen 1700X @3.8 ghz
MSI Core Frozr L
16 go Corsair Vengeance LPX PC4-25600 (3200MHz)
MSI GTX 1080 Gaming X 8G
MSI X370 Gaming Pro Carbon
500 Go SSD Samsung 960 EVO M.2
Find all posts by this user
Quote this message in a reply
04-10-2017, 11:37 AM
Post: #5
RE: Catherine [BLES01459]
Hey is this game just work in the US version? Cause with this version I stuck at black screen after Atlus Logo. I'm using PPU(LLVM) + SPU(ASMJIT) + OpenGL Render with auto modul. Here's the log


Attached File(s)
.zip  RPCS3.zip (Size: 465.04 KB / Downloads: 13)
Find all posts by this user
Quote this message in a reply
04-10-2017, 10:05 PM
Post: #6
RE: Catherine [BLES01459]
Try LLVM Recompiler and SPU Interpreter (Fast).
Find all posts by this user
Quote this message in a reply
04-11-2017, 06:26 AM
Post: #7
RE: Catherine [BLES01459]
(04-10-2017 10:05 PM)Keksus Wrote:  Try LLVM Recompiler and SPU Interpreter (Fast).

The result is the same stuck at black screen after Atlus Logo. I'm using this version "rpcs3-v0.0.2-2017-04-03-65488078_win64". Maybe the game just works for the US version for now...
Find all posts by this user
Quote this message in a reply
04-11-2017, 02:29 PM
Post: #8
RE: Catherine [BLES01459]
Nope. EU Version works perfectly fine with 30fps like the US version. So most likely playable, but I didn't check saving and loading or anything after taking a look at the tutorial.

DX12 with LLVM recompiler and SPU interpreter (fast)


Attached File(s) Thumbnail(s)
   

.zip  RPCS3.zip (Size: 659.72 KB / Downloads: 13)
Find all posts by this user
Quote this message in a reply
04-11-2017, 03:53 PM
Post: #9
RE: Catherine [BLES01459]
It is probably playable. ASMJIT randomly black screens for some people. Use "fast" SPU interpreter in that case. There is a performance penalty but not too drastic. Someone still got 30 fps either way.

Moving thread.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
05-03-2017, 10:39 AM
Post: #10
RE: Catherine [BLES01459]
Saving / Loading works fine , the game runs smoothly on 30 fps most of the time .

I'd like to report sound sync issues ,
other times sounds is turned off completely (It happened to me several times and I noticed it happens if u skip dialog too fast)

Also the game Rapunzel on the bar doesn't not work (black screen).

Using PPU LLMV,SPU ASMJIT,D3D12,XAudio2

Specs : Intel i7-6700K , GeForce GTX 1060 6GB
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)