This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Video decoding using java decoder (r3659)
11-02-2014, 08:13 PM
Post: #21
RE: Video decoding using java decoder (r3659)
(11-01-2014 06:16 PM)DragonNeos Wrote:  Games such as Bleach: Soul Carnival and Digimon World Re:Digitize use ICON1.PMF for audio when it is being viewed at the UMD Browser on a real PSP.
OK, could someone try to add a SND0.AT3 file to these ISO to check which sound is played on a PSP when both ICON1.PMF contains sound and SND0.AT3 is present?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
11-03-2014, 12:08 AM
Post: #22
RE: Video decoding using java decoder (r3659)
(11-02-2014 08:13 PM)gid15 Wrote:  
(11-01-2014 06:16 PM)DragonNeos Wrote:  Games such as Bleach: Soul Carnival and Digimon World Re:Digitize use ICON1.PMF for audio when it is being viewed at the UMD Browser on a real PSP.
OK, could someone try to add a SND0.AT3 file to these ISO to check which sound is played on a PSP when both ICON1.PMF contains sound and SND0.AT3 is present?
Games such as Hatsune Miku Project DIVA extend have both ICON1.PMF and SND0.AT3. But ICON1.PMF did not have audio
Find all posts by this user
Quote this message in a reply
11-03-2014, 05:03 PM (This post was last modified: 11-03-2014 06:44 PM by gid15.)
Post: #23
RE: Video decoding using java decoder (r3659)
Using r3672, the audio from ICON1.PMF should now be played in the UMD browser.

EDIT: implementation improved in r3674.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
11-04-2014, 12:12 AM
Post: #24
RE: Video decoding using java decoder (r3659)
OK, fixed the audio from ICON1.PMF
another issue
ICON1.PMF
   
Find all posts by this user
Quote this message in a reply
11-05-2014, 04:52 PM
Post: #25
RE: Video decoding using java decoder (r3659)
(11-04-2014 12:12 AM)onelight Wrote:  another issue
ICON1.PMF
This should also be solved in r3675 (incorrect video height and incorrect colors).

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
11-06-2014, 04:28 AM
Post: #26
RE: Video decoding using java decoder (r3659)
(11-05-2014 04:52 PM)gid15 Wrote:  
(11-04-2014 12:12 AM)onelight Wrote:  another issue
ICON1.PMF
This should also be solved in r3675 (incorrect video height and incorrect colors).
ok, fixed it.
Find all posts by this user
Quote this message in a reply
11-22-2014, 02:16 AM (This post was last modified: 11-22-2014 02:18 AM by onelight.)
Post: #27
RE: Video decoding using java decoder (r3659)
   

Code:
Running Jpcsp 64bit...
Exception in thread "Video Decoder Thread"
java.lang.ArrayIndexOutOfBoundsException: -1
    at com.twilight.h264.decoder.H264Context.ff_h264_decode_mb_cabac(H264Context.java:3​476)
    at com.twilight.h264.decoder.H264Context.decode_slice(H264Context.java:4910)
    at com.twilight.h264.decoder.H264Context
.decode_nal_units(H264Context.java:6615)
    at com.twilight.h264.decoder.H264Context.decode_frame(H264Context.java:8587)
    at com.twilight.h264.decoder.H264Decoder.decode(H264Decoder.java:35)
    at com.twilight.h264.decoder.MpegEncContext.avcodec_decode_vide
o2(MpegEncContext.java:2300)
    at jpcsp.media.codec.h264.H264Decoder.decode(H264Decoder.java:59)
    at jpcsp.HLE.modules150.sceMpeg.decodeNextImage(sceMpeg.java:1218)
    at jpcsp.HLE.modules150.sceMpeg.hleVideoDecoderStep(sceMpeg.java:1280)
    at jpcsp.HLE.mo
dules150.sceMpeg.access$500(sceMpeg.java:86)
    at jpcsp.HLE.modules150.sceMpeg$VideoDecoderThread.run(sceMpeg.java:996)
Find all posts by this user
Quote this message in a reply
11-26-2014, 03:28 PM
Post: #28
RE: Video decoding using java decoder (r3659)
(11-22-2014 02:16 AM)onelight Wrote:  
Code:
Running Jpcsp 64bit...
Exception in thread "Video Decoder Thread"
java.lang.ArrayIndexOutOfBoundsException: -1
    at com.twilight.h264.decoder.H264Context.ff_h264_decode_mb_cabac(H264Context.java:3​476)
    at com.twilight.h264.decoder.H264Context.decode_slice(H264Context.java:4910)
    at com.twilight.h264.decoder.H264Context
.decode_nal_units(H264Context.java:6615)
    at com.twilight.h264.decoder.H264Context.decode_frame(H264Context.java:8587)
    at com.twilight.h264.decoder.H264Decoder.decode(H264Decoder.java:35)
    at com.twilight.h264.decoder.MpegEncContext.avcodec_decode_vide
o2(MpegEncContext.java:2300)
    at jpcsp.media.codec.h264.H264Decoder.decode(H264Decoder.java:59)
    at jpcsp.HLE.modules150.sceMpeg.decodeNextImage(sceMpeg.java:1218)
    at jpcsp.HLE.modules150.sceMpeg.hleVideoDecoderStep(sceMpeg.java:1280)
    at jpcsp.HLE.mo
dules150.sceMpeg.access$500(sceMpeg.java:86)
    at jpcsp.HLE.modules150.sceMpeg$VideoDecoderThread.run(sceMpeg.java:996)
Could you post a log file with the following lines in LogSettings.xml
Code:
<logger name='compiler'> <level value='debug' /> </logger>
<logger name='hle.scePsmfPlayer'> <level value='debug' /> </logger>
<logger name='hle.scePsmf'> <level value='debug' /> </logger>
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thank you!

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
11-26-2014, 03:31 PM
Post: #29
RE: Video decoding using java decoder (r3659)
(11-26-2014 03:28 PM)gid15 Wrote:  
(11-22-2014 02:16 AM)onelight Wrote:  
Code:
Running Jpcsp 64bit...
Exception in thread "Video Decoder Thread"
java.lang.ArrayIndexOutOfBoundsException: -1
    at com.twilight.h264.decoder.H264Context.ff_h264_decode_mb_cabac(H264Context.java:3​476)
    at com.twilight.h264.decoder.H264Context.decode_slice(H264Context.java:4910)
    at com.twilight.h264.decoder.H264Context
.decode_nal_units(H264Context.java:6615)
    at com.twilight.h264.decoder.H264Context.decode_frame(H264Context.java:8587)
    at com.twilight.h264.decoder.H264Decoder.decode(H264Decoder.java:35)
    at com.twilight.h264.decoder.MpegEncContext.avcodec_decode_vide
o2(MpegEncContext.java:2300)
    at jpcsp.media.codec.h264.H264Decoder.decode(H264Decoder.java:59)
    at jpcsp.HLE.modules150.sceMpeg.decodeNextImage(sceMpeg.java:1218)
    at jpcsp.HLE.modules150.sceMpeg.hleVideoDecoderStep(sceMpeg.java:1280)
    at jpcsp.HLE.mo
dules150.sceMpeg.access$500(sceMpeg.java:86)
    at jpcsp.HLE.modules150.sceMpeg$VideoDecoderThread.run(sceMpeg.java:996)
Could you post a log file with the following lines in LogSettings.xml
Code:
<logger name='compiler'> <level value='debug' /> </logger>
<logger name='hle.scePsmfPlayer'> <level value='debug' /> </logger>
<logger name='hle.scePsmf'> <level value='debug' /> </logger>
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thank you!
Using this will skip that error.
Find all posts by this user
Quote this message in a reply
11-26-2014, 03:46 PM
Post: #30
RE: Video decoding using java decoder (r3659)
(11-26-2014 03:31 PM)onelight Wrote:  
(11-26-2014 03:28 PM)gid15 Wrote:  
(11-22-2014 02:16 AM)onelight Wrote:  
Code:
Running Jpcsp 64bit...
Exception in thread "Video Decoder Thread"
java.lang.ArrayIndexOutOfBoundsException: -1
    at com.twilight.h264.decoder.H264Context.ff_h264_decode_mb_cabac(H264Context.java:3​476)
    at com.twilight.h264.decoder.H264Context.decode_slice(H264Context.java:4910)
    at com.twilight.h264.decoder.H264Context
.decode_nal_units(H264Context.java:6615)
    at com.twilight.h264.decoder.H264Context.decode_frame(H264Context.java:8587)
    at com.twilight.h264.decoder.H264Decoder.decode(H264Decoder.java:35)
    at com.twilight.h264.decoder.MpegEncContext.avcodec_decode_vide
o2(MpegEncContext.java:2300)
    at jpcsp.media.codec.h264.H264Decoder.decode(H264Decoder.java:59)
    at jpcsp.HLE.modules150.sceMpeg.decodeNextImage(sceMpeg.java:1218)
    at jpcsp.HLE.modules150.sceMpeg.hleVideoDecoderStep(sceMpeg.java:1280)
    at jpcsp.HLE.mo
dules150.sceMpeg.access$500(sceMpeg.java:86)
    at jpcsp.HLE.modules150.sceMpeg$VideoDecoderThread.run(sceMpeg.java:996)
Could you post a log file with the following lines in LogSettings.xml
Code:
<logger name='compiler'> <level value='debug' /> </logger>
<logger name='hle.scePsmfPlayer'> <level value='debug' /> </logger>
<logger name='hle.scePsmf'> <level value='debug' /> </logger>
<logger name='hle.sceMpeg'> <level value='trace' /> </logger>

Thank you!
Using this will skip that error.
Interesting... does it then happen for every video or only some of them?

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)