This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Build Error...
09-06-2014, 10:25 AM,
#1
Build Error...
Hello,

I have been trying to build the project with no success at all...

I have used:

git clone "https://github.com/DHrpcs3/rpcs3" "D:\Github"

cd d:\github\rpcs3

git submodule update --init

I have tried pasting the forked directories myself (wxWidgets and ffmpeg and asmjit) but every time I receive errors while building

I am using Visual Studio 2013 Build 3 on Windows 7. I have two .sln files rpcs3 and rpcs3_buildbot both give the same errors.

I have attached the build log in which I have noticed these errors:
The process cannot access the file because it is being used by another process
D:\Github\rpcs3\wxWidgets\include\wx/any.h(216): error C2061: syntax error : identifier 'place'

The first is weird since it is using the file multiple times with no prob but always has errors on the same line.
The second pops up 4 times .

There is also a cannot open file error but I think it is linked to the previous ones.

These are the errors:

Warning 1 warning C4244: 'return' : conversion from '__int64' to 'XML_Index', possible loss of data D:\Github\rpcs3\wxWidgets\src\expat\lib\xmlparse.c 1854 1 wxexpat
Warning 2 warning C4244: '=' : conversion from 'tmsize_t' to 'int', possible loss of data D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_jpeg.c 1802 1 wxtiff
Warning 3 warning C4244: 'initializing' : conversion from '__int64' to 'int', possible loss of data D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_print.c 398 1 wxtiff
Warning 4 warning C4267: 'function' : conversion from 'size_t' to 'int', possible loss of data D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_print.c 677 1 wxtiff
Warning 5 warning C4244: '=' : conversion from 'tmsize_t' to 'uInt', possible loss of data D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_pixarlog.c 908 1 wxtiff
Warning 6 warning C4018: '<=' : signed/unsigned mismatch D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_write.c 235 1 wxtiff
Warning 7 warning C4018: '<=' : signed/unsigned mismatch D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_write.c 381 1 wxtiff
Warning 8 warning C4244: '=' : conversion from 'tmsize_t' to 'uInt', possible loss of data D:\Github\rpcs3\wxWidgets\src\tiff\libtiff\tif_zip.c 240 1 wxtiff
Warning 9 warning C4267: '+=' : conversion from 'size_t' to 'long', possible loss of data D:\Github\rpcs3\wxWidgets\src\jpeg\jmemmgr.c 306 1 wxjpeg
Warning 10 warning C4267: '+=' : conversion from 'size_t' to 'long', possible loss of data D:\Github\rpcs3\wxWidgets\src\jpeg\jmemmgr.c 366 1 wxjpeg
Warning 11 warning C4267: '-=' : conversion from 'size_t' to 'long', possible loss of data D:\Github\rpcs3\wxWidgets\src\jpeg\jmemmgr.c 976 1 wxjpeg
Warning 12 warning C4267: '-=' : conversion from 'size_t' to 'long', possible loss of data D:\Github\rpcs3\wxWidgets\src\jpeg\jmemmgr.c 990 1 wxjpeg
Warning 13 warning C4324: 'wx_error_mgr' : structure was padded due to __declspec(align()) D:\Github\rpcs3\wxWidgets\src\common\imagjpeg.cpp 153 1 core
Warning 14 warning C4996: 'GetVersionExW': was declared deprecated D:\Github\rpcs3\wxWidgets\src\msw\app.cpp 271 1 core
Warning 15 warning C4996: 'GetVersionExW': was declared deprecated D:\Github\rpcs3\wxWidgets\src\common\strconv.cpp 2836 1 base
Warning 16 warning C4535: calling _set_se_translator() requires /EHa D:\Github\rpcs3\wxWidgets\src\msw\main.cpp 184 1 base
Warning 17 warning C4535: calling _set_se_translator() requires /EHa D:\Github\rpcs3\wxWidgets\src\msw\thread.cpp 589 1 base
Warning 18 warning C4996: 'GetVersionExW': was declared deprecated D:\Github\rpcs3\wxWidgets\src\msw\utils.cpp 1181 1 base
Warning 19 warning C4996: 'GetVersionExW': was declared deprecated D:\Github\rpcs3\wxWidgets\src\msw\utils.cpp 1208 1 base
Warning 20 warning C4996: 'GetVersionExW': was declared deprecated D:\Github\rpcs3\wxWidgets\src\msw\utils.cpp 1392 1 base
Warning 21 warning C4310: cast truncates constant value D:\Github\rpcs3\wxWidgets\src\msw\listctrl.cpp 2787 1 core
Warning 22 warning C4200: nonstandard extension used : zero-sized array in struct/union d:\github\rpcs3\rpcs3\emu\syscalls\modules\cellSync2.h 37 1 emucore
Warning 23 warning C4200: nonstandard extension used : zero-sized array in struct/union d:\github\rpcs3\rpcs3\emu\syscalls\modules\cellSync2.h 44 1 emucore
Warning 24 warning C4200: nonstandard extension used : zero-sized array in struct/union d:\github\rpcs3\rpcs3\emu\syscalls\modules\cellSync2.h 52 1 emucore
Warning 25 warning C4200: nonstandard extension used : zero-sized array in struct/union d:\github\rpcs3\rpcs3\emu\syscalls\modules\cellSync2.h 63 1 emucore
Warning 26 warning C4804: '%' : unsafe use of type 'bool' in operation D:\Github\rpcs3\rpcs3\Emu\SysCalls\Modules\cellSync2.cpp 320 1 emucore
Warning 27 warning C4244: '=' : conversion from 'double' to 'u32', possible loss of data D:\Github\rpcs3\rpcs3\Emu\RSX\GL\GLGSRender.cpp 183 1 emucore
Warning 28 warning C4244: '=' : conversion from 'double' to 'u32', possible loss of data D:\Github\rpcs3\rpcs3\Emu\RSX\GL\GLGSRender.cpp 184 1 emucore
Warning 29 warning C4244: 'argument' : conversion from 'u32' to 'GLfloat', possible loss of data D:\Github\rpcs3\rpcs3\Emu\RSX\GL\GLGSRender.cpp 681 1 emucore
Error 30 error C2061: syntax error : identifier 'place' D:\Github\rpcs3\wxWidgets\include\wx\any.h 216 1 emucore
Error 31 error C2061: syntax error : identifier 'place' D:\Github\rpcs3\wxWidgets\include\wx\any.h 216 1 emucore
Error 32 error C2061: syntax error : identifier 'place' D:\Github\rpcs3\wxWidgets\include\wx\any.h 216 1 emucore
Warning 33 warning C4800: 'int' : forcing value to bool 'true' or 'false' (performance warning) D:\Github\rpcs3\rpcs3\Emu\Io\XInput\XInputPadHandler.cpp 151 1 rpcs3
Error 34 error LNK1104: cannot open file 'D:\Github\rpcs3\x64\Debug - MemLeak\emucore.lib' D:\Github\rpcs3\rpcs3\LINK rpcs3
Reply
09-06-2014, 11:22 AM,
#2
RE: Build Error...
Quote:I have tried pasting the forked directories myself (wxWidgets and ffmpeg and asmjit) but every time I receive errors while building

Why should you do it manually? Maybe it's the problem.
Reply
09-06-2014, 11:48 AM,
#3
RE: Build Error...
Visual Studio 2013 Build 3? What's that? I think there's Update 2...
Reply
09-06-2014, 12:17 PM, (This post was last modified: 09-06-2014, 12:18 PM by Blink123123.)
#4
RE: Build Error...
I meant update 3

I tried both manually and automatically with no luck I'll try again but I doubt it's gonna work.

Automatically it downloaded about 240 mb of wxWidgets and 200 mb of ffmpeg and something small for the ajmsit
Reply
09-06-2014, 07:13 PM, (This post was last modified: 09-06-2014, 07:14 PM by flashmozzg.)
#5
RE: Build Error...
(09-06-2014, 12:17 PM)Blink123123 Wrote: I meant update 3

I tried both manually and automatically with no luck I'll try again but I doubt it's gonna work.

Automatically it downloaded about 240 mb of wxWidgets and 200 mb of ffmpeg and something small for the ajmsit

Don't forget to install wxWidgets.
Reply
09-06-2014, 09:15 PM,
#6
RE: Build Error...
(09-06-2014, 07:13 PM)flashmozzg Wrote:
(09-06-2014, 12:17 PM)Blink123123 Wrote: I meant update 3

I tried both manually and automatically with no luck I'll try again but I doubt it's gonna work.

Automatically it downloaded about 240 mb of wxWidgets and 200 mb of ffmpeg and something small for the ajmsit

Don't forget to install wxWidgets.

it is installed but I haven't touched it, is there something I should do? Reference it from VS?

I re cloned from scratch using git clone and git submodule update --init and ran VS and still same error

I tried rebuiling each element on it's own. asmijt and wxWidgets built successfully but whenever I try building emucore i get the error:
Error 4 error C2061: syntax error : identifier 'place' D:\GitHub\rpcs3\wxWidgets\include\wx\any.h 216 1 emucore
located here
static void SetValue(const T& value,
wxAnyValueBuffer& buf)
{
// Use placement new
void* const place = buf.m_buffer;
::new(place) T(value); // <---- this is the line
}

And randomly I get this error sometimes I don't:
7 IntelliSense: __w64 can only be specified on int, long, and pointer types d:\GitHub\rpcs3\wxWidgets\include\wx\defs.h 1248 13 base

Am I missing something? These are my steps

Clone repostiry with submodules
install wxwidgets
launch rpcs3.sln file
rebuild solution
error
Reply
09-07-2014, 12:04 AM, (This post was last modified: 09-07-2014, 12:08 AM by Bigpet.)
#7
RE: Build Error...
are you sure you are using the wxWidgets version with the commit hash 5a313d2c7cec6914721eac46c623fbb4211d3375 as we do?

edit: but I do have the same line at any.h , so no clue what went wrong

edit2: oh, did you make sure to set the configuration to "Debug" or "Release" instead of "Debug - MemLeak" ? (we should probably remove that if no one uses it , or can be bothered to fix it)
Reply
09-07-2014, 12:18 AM,
#8
RE: Build Error...
(09-07-2014, 12:04 AM)Bigpet Wrote: are you sure you are using the wxWidgets version with the commit hash 5a313d2c7cec6914721eac46c623fbb4211d3375 as we do?

edit: but I do have the same line at any.h , so no clue what went wrong

edit2: oh, did you make sure to set the configuration to "Debug" or "Release" instead of "Debug - MemLeak" ? (we should probably remove that if no one uses it , or can be bothered to fix it)

It was set to Debug - MemLeak chaning it resolved everything ! Thanks so much !
Reply
09-07-2014, 01:47 AM, (This post was last modified: 09-07-2014, 02:36 AM by Darkriot.)
#9
RE: Build Error...
Can someone compile LLVM?
I get many errors(

http://puu.sh/boGUT/5206d45cdc.png - i have all paths correctly.
Maybe bc i have Cyrillic on VS?

Upd. okay, i solved its problem...just need to be download "Cmake".
Reply
09-07-2014, 03:04 AM, (This post was last modified: 09-07-2014, 03:05 AM by Darkriot.)
#10
RE: Build Error...
Upd. 2
Ooh, okay...i tested it. It's very unstable now.In game (avoidance) with interpreter i have 2 fps, with recompiler 0.15.
Need a lot of work ;(
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)