This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Red Dead Redemption [BLUS30418]
10-22-2016, 08:53 PM (This post was last modified: 10-22-2016 08:54 PM by Kilowog01.)
Post: #11
RE: Red Dead Redemption [BLUS30418]
sys_mmapper everywhere, this game will not work anytime soon, but i'm trying to figure out the necessary LLE's to reduce the errors anyway

(10-22-2016 08:00 PM)Loksortfjnasdrt Wrote:  Hi guys. Any news about activating this game with RPCS3 ?
This is not exactly a complete .log

Novo no RPCS3? Não seja BR, tome alguns links úteis:

RPCS3 para recém-chegados
Diretrizes para novos jogos
Vocabulário na emulação

i7-2600k ~4.5Ghz|GTX 1080 STRIX OC|24GB RAM
Find all posts by this user
Quote this message in a reply
10-22-2016, 09:05 PM (This post was last modified: 10-22-2016 09:07 PM by Nezarn.)
Post: #12
RE: Red Dead Redemption [BLUS30418]
(10-22-2016 08:53 PM)Kilowog01 Wrote:  sys_mmapper everywhere

and? that doesn't mean that a game couldn't boot.

For example Project Diva F has those in the log, and runs flawlessly.


This doesn't boot yet because if you look at the partial log, emu crashes because missing libfs stuff

·F {PPU[0x7000000d] Thread (Installer) [0x00533064]} class std::runtime_error thrown: Unimplemented
(in file C:\rpcs3\rpcs3\Emu\Cell\Modules\cellFs.cpp:843)


@Loksortfjnasdrt you should never copy disc games into dev_hdd0, most of them doesn't like it.. copy it somewhere else then run the game with boot -> boot game (and also LLE libfs as Annie said)


edit: also i can try the game too, just need time to backup

PC: i5-4690K | RX 480 | 16GB RAM
Find all posts by this user
Quote this message in a reply
10-22-2016, 09:16 PM (This post was last modified: 10-22-2016 09:17 PM by Loksortfjnasdrt.)
Post: #13
RE: Red Dead Redemption [BLUS30418]
yeah sorry it didn't allow for uploading more than 200kb file, so I reduced it to the last rows only.
I uploaded it now, you can find the full log here:

TTY.log - https://drive.google.com/file/d/0B9DodDN...sp=sharing
RPCS3.log - https://drive.google.com/file/d/0B9DodDN...sp=sharing
SPUJIT.log - https://drive.google.com/file/d/0B9DodDN...sp=sharing

wasn't sure which ones you guys need so I uploaded these three just in case

Thanks for the quick answers,
Find all posts by this user
Quote this message in a reply
10-22-2016, 09:29 PM (This post was last modified: 10-22-2016 09:30 PM by ssshadow.)
Post: #14
RE: Red Dead Redemption [BLUS30418]
Please also LLE libfs, cellspursjq, cellresc, and libfiber.

Only RPCS3.log

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
10-22-2016, 09:51 PM (This post was last modified: 10-22-2016 10:16 PM by Annie.)
Post: #15
RE: Red Dead Redemption [BLUS30418]
@Annie - Yeah I am new to RPCS3. I read the "RPCS3 for Newcomers" and according to it i looks like i don't have the flashATRAC.pic, flashMP3.pic.
Does someone has it for download via link?
I got the PRX files list from someone on youtube (who shared a download link with his video).
Also I don't seem to have sys_mmapper in my LLE list

@Nezarn - I didn't copy the game to dev_hdd0, it probably copied it when I tried to "Boot game". Let me know if you succeed in running the game

@ssshadow - I don't have these LLE: cellspursjq, cellresc

The ones I have at the moment are: libfiber, libfs, libl10n, libsail, libsre
I'll try running the game again now

EDIT: btw, the first time I tried to open the game using "Install PKG" but the program just crashed and didn't open again. Had to delete it and re-extract the original downloaded.
and I think I found the pic files here - REDACTED
Find all posts by this user
Quote this message in a reply
10-22-2016, 10:06 PM
Post: #16
RE: Red Dead Redemption [BLUS30418]
I have assisted you in obtaining firmware files from your very own PS3 via PM. Test with the suggested modules and report back.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
10-22-2016, 10:16 PM
Post: #17
RE: Red Dead Redemption [BLUS30418]
I have redacted the link to the firmware files - you can't post those here.
cellspursjq is libspurs_jq and cellresc is libresc.

sys_mmapper can't be LLE loaded

Desktop: AMD FX-8350 | AMD R9 280X 3G
Laptop: Intel i7-6700HQ | NVIDIA GTX 960M 2G
Find all posts by this user
Quote this message in a reply
10-22-2016, 10:48 PM
Post: #18
RE: Red Dead Redemption [BLUS30418]
Well idk what are you doing, but for me (i have the eu psn version) it throws a PPU exception

https://github.com/RPCS3/rpcs3/issues/1480 (and PSN\disc version shouldn't be that much different...)

PC: i5-4690K | RX 480 | 16GB RAM
Find all posts by this user
Quote this message in a reply
10-22-2016, 11:13 PM (This post was last modified: 10-22-2016 11:24 PM by Loksortfjnasdrt.)
Post: #19
RE: Red Dead Redemption [BLUS30418]
@ssshadow - Thanks again, I'm using them now.
@Annie - Sorry for the REDACTED link.

Just to make sure I'm doing everything right:
1) The best way for opening the game is by going to "Boot -> Boot game" and selecting the USRDIR folder inside the game's main directory? (It does have a PKG file as well...)
2) Should I delete the game folders that were created automatically in dev_hdd0 and dev_hdd1 ?

Here's a photo of my current settings (with app version) - https://drive.google.com/file/d/0B9DodDN...pIMTQ/view

I tried running the game now with these settings and methods, and still didn't work. (New log file - https://drive.google.com/file/d/0B9DodDN...1T2M/view)

EDIT: another log after using OpenGL - added attachment


Attached File(s)
.txt  log3.txt (Size: 37.13 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
10-22-2016, 11:23 PM
Post: #20
RE: Red Dead Redemption [BLUS30418]
(10-22-2016 11:13 PM)Loksortfjnasdrt Wrote:  @ssshadow - Thanks again, I'm using them now.
@Annie - Sorry for the REDACTED link.

Just to make sure I'm doing everything right:
1) The best way for opening the game is by going to "Boot -> Boot game" and selecting the USRDIR folder inside the game's main directory? (It does have a PKG file as well...)
2) Should I delete the game folders that were created automatically in dev_hdd0 and dev_hdd1 ?

Here's a photo of my current settings (with app version) - https://drive.google.com/file/d/0B9DodDN...pIMTQ/view

I tried running the game now with these settings and methods, and still didn't work. (New log file - https://drive.google.com/file/d/0B9DodDN...1T2M/view)

Whatever you did to get that log was correct as the game started to boot, and then something went wrong, but that's outside of the selected LLE modules and other settings. At this point it's clear that the game will not progress any further.

Asus N55SF, i7-2670QM (~2,8 ghz under typical load), GeForce GT 555M (only OpenGL)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)