This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 4 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Final Fantasy I - ULUS10251
05-17-2013, 10:43 AM
Post: #21
RE: Final Fantasy I - ULUS10251
noticed this game won't launch if handle save data in crypto mode is ticked.

something to keep in mind if sharing save games between jpcsp and ppsspp (for games that do use crypto engine.... FF1 does not)
Find all posts by this user
Quote this message in a reply
05-23-2013, 05:48 PM (This post was last modified: 05-23-2013 05:48 PM by Cat Slobber.)
Post: #22
RE: Final Fantasy I - ULUS10251
(05-17-2013 10:43 AM)squall leonhart Wrote:  noticed this game won't launch if handle save data in crypto mode is ticked.

something to keep in mind if sharing save games between jpcsp and ppsspp (for games that do use crypto engine.... FF1 does not)

I have no problem launching this game using that setting. I'm using r3156. Saving also works. Post your config?
Find all posts by this user
Quote this message in a reply
02-11-2015, 09:33 AM (This post was last modified: 02-11-2015 09:40 AM by DragonNeos.)
Post: #23
RE: Final Fantasy I - ULUS10251
This game was tested using r3700 and External Software Render Plugin a308ab8. The Software Renderer works as intended for the most part and has some errors. When the game is starting up, this appears in the log:
Code:
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F0]: 0893CAD0 - X2      (0xF0000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F1]: 0893CAD4 - Y2      (0xF1000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F2]: 0893CAD8 - Z2      (0xF2000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F3]: 0893CADC - S2      (0xF3000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F4]: 0893CAE0 - T2      (0xF4000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F5]: 0893CAE4 - Q2      (0xF5000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F6]: 0893CAE8 - RGB2    (0xF6000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F7]: 0893CAEC - AP2     (0xF7000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F8]: 0893CAF0 - F2      (0xF8000000) unknown command
04:01:06  WARN externalge - ExternalGE - Core Thread - GE[F9]: 0893CAF4 - I2      (0xF9000000) unknown command
The company credits seem to stay in the background while the opening video is playing (only audio is playing, problem possibly occurs only at 2x or higher resolution). The screen only goes away if the user presses the Start button. (1st Screenshot)

Any resolution over 1x will show some sort of lines near characters or in the background. (2nd & 3rd Screenshot)

The type of resolution that the user chooses when the External Software Renderer is used affects the performance (1x - 60-61 FPS, 2x - 29-30 FPS, 3x - 12-13 FPS).


Attached File(s) Thumbnail(s)
           

.zip  Log_r3700(64bit)_INFO.zip (Size: 94.4 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
04-18-2020, 11:30 PM
Post: #24
RE: Final Fantasy I - ULUS10251
This game was tested with revision 503d3e6f. There are several issues:

1) The game doesn't load the title screen if the opening video is fully played. It seems to hang after the video and no button input will make the game move to the title screen.

2) If the opening video is skipped, an error pops up on the log:
Code:
17:00:33 ERROR     h264 - Videocodec Decoder Thread - H264 decode error 0xFFFFFFFF

On rare occasions, skipping the video brings up this error instead:
Code:
Running Jpcsp 64bit...
Exception in thread "Videocodec Decoder Thread" java.lang.NullPointerException
        at jpcsp.HLE.modules.sceVideocodec.videocodecDecodeType0(sceVideocodec.j
ava:238)
        at jpcsp.HLE.modules.sceVideocodec.videocodecDecoderStep(sceVideocodec.j
ava:657)
        at jpcsp.HLE.modules.sceVideocodec.access$000(sceVideocodec.java:54)
        at jpcsp.HLE.modules.sceVideocodec$VideocodecDecoderThread.run(sceVideoc
odec.java:105)

3) The "O Back" doesn't appear on the bottom of the screen when the message "The game data has been saved." appears. The screen needs to be more transparent in comparison to how it appears on the PSP. (1st Screenshot - JPCSP, 2nd Screenshot - PSP)
       

When attempting to overwrite an existing save, the SAVEDATA message appears on the log but doesn't appear on JPCSP as a screen overlay. (3rd Screenshot - JPCSP, 4th Screenshot - PSP)
       


Attached File(s)
.7z  Log_r503d3e6f(64bit)_INFO (Game hangs after opening video).7z (Size: 39.52 KB / Downloads: 1)
.7z  Log_r503d3e6f(64bit)_INFO (Error skipping opening video, SAVEDATA dialog issue).7z (Size: 75.77 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
06-05-2020, 05:59 PM
Post: #25
RE: Final Fantasy I - ULUS10251
Hi gid15. The issues I listed in my previous post still occur on revision e24da20e.

I have attached two Compiler DEBUG logs regarding the first issue on my previous post (the first attached log is when the game will hang after the opening video is fully played and the second attached log is when the opening video is skipped to reach the Title Screen).

Hopefully a comparison between the two logs will help show why there's an issue in the first place.


Attached File(s)
.7z  Log_re24da20e(64bit)_INFO (Game hangs after opening video).7z (Size: 274.14 KB / Downloads: 1)
.7z  Log_re24da20e(64bit)_INFO (Skipping opening video to reach Title Screen).7z (Size: 358.39 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
06-06-2020, 12:17 PM
Post: #26
RE: Final Fantasy I - ULUS10251
(06-05-2020 05:59 PM)DragonNeos Wrote:  Hi gid15. The issues I listed in my previous post still occur on revision e24da20e.

I have attached two Compiler DEBUG logs regarding the first issue on my previous post (the first attached log is when the game will hang after the opening video is fully played and the second attached log is when the opening video is skipped to reach the Title Screen).

Hopefully a comparison between the two logs will help show why there's an issue in the first place.
Sorry, somehow I missed your post from April.
Could you please provide a log at DEBUG level (not just the compiler, but everything)? When playing a video, this is usually possible.

Also, please keep the compiler settings "Maximum Method Size" to the default value 3000. With the value 50, the code is split in very small chunks which makes it quite unreadable in the log file for a human...

Thank you!

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
06-13-2020, 09:00 PM
Post: #27
RE: Final Fantasy I - ULUS10251
On revision 6d28d879, when the opening video starts I switch to DEBUG but the video doesn't continue playing (see screenshot). I left it on DEBUG for at least 30 minutes before I closed the emulator.
   


Attached File(s)
.7z  Log_r6d28d879(64bit)_DEBUG (From start of opening video).7z (Size: 824.93 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
06-22-2020, 03:53 PM
Post: #28
RE: Final Fantasy I - ULUS10251
(06-13-2020 09:00 PM)DragonNeos Wrote:  On revision 6d28d879, when the opening video starts I switch to DEBUG but the video doesn't continue playing (see screenshot). I left it on DEBUG for at least 30 minutes before I closed the emulator.
OK, the audio seems to use all the available CPU in DEBUG mode.
Could you then try to take a log at INFO level with the following lines added to your LogSettings.xml:
Code:
<logger name='compiler'> <level value='debug' /> </logger>
<logger name='hle.sceMpegbase'> <level value='debug' /> </logger>
<logger name='hle.sceVideocodec'> <level value='debug' /> </logger>
<logger name='hle.sceMpeg'> <level value='debug' /> </logger>
This should only enable the debug for the mpeg/video functions.

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
06-30-2020, 09:20 AM (This post was last modified: 06-30-2020 10:00 AM by DragonNeos.)
Post: #29
RE: Final Fantasy I - ULUS10251
I had to upload the log to MediaFire since the file size was too large: https://www.mediafire.com/file/tfnvop404...UG.7z/file

The External Software Renderer doesn't seem to work for any application. I'm using External Software Renderer revision f5f617a (previous revision 97c0bf3 does work). The following appears from the cmd.exe window:
Code:
Running Jpcsp 64bit...
Exception in thread "GUI" java.lang.NoSuchMethodError: onRenderSprite
        at jpcsp.graphics.RE.externalge.NativeUtils.initNative(Native Method)
        at jpcsp.graphics.RE.externalge.NativeUtils.init(NativeUtils.java:94)
        at jpcsp.graphics.RE.externalge.ExternalGE.init(ExternalGE.java:187)
        at jpcsp.graphics.RE.externalge.ExternalGE$ExternalGESettingsListerner.s
ettingsValueChanged(ExternalGE.java:80)
        at jpcsp.settings.AbstractBoolSettingsListener.settingsValueChanged(Abst
ractBoolSettingsListener.java:46)
        at jpcsp.settings.AbstractBoolSettingsListener.settingsValueChanged(Abst
ractBoolSettingsListener.java:35)
        at jpcsp.settings.Settings.registerSettingsListener(Settings.java:890)
        at jpcsp.graphics.RE.externalge.ExternalGE.init(ExternalGE.java:183)
        at jpcsp.HLE.modules.sceDisplay$AWTGLCanvas_sceDisplay.paintGL(sceDispla
y.java:152)
        at org.lwjgl.opengl.AWTGLCanvas.paint(AWTGLCanvas.java:339)
        at org.lwjgl.opengl.AWTGLCanvas.update(AWTGLCanvas.java:368)
        at sun.awt.RepaintArea.updateComponent(Unknown Source)
        at sun.awt.RepaintArea.paint(Unknown Source)
        at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
        at java.awt.Component.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$500(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "GUI" java.lang.NoSuchMethodError: onRenderSprite
        at jpcsp.graphics.RE.externalge.NativeUtils.initNative(Native Method)
        at jpcsp.graphics.RE.externalge.NativeUtils.init(NativeUtils.java:94)
        at jpcsp.graphics.RE.externalge.ExternalGE.init(ExternalGE.java:187)
        at jpcsp.HLE.modules.sceDisplay$AWTGLCanvas_sceDisplay.paintGL(sceDispla
y.java:152)
        at org.lwjgl.opengl.AWTGLCanvas.paint(AWTGLCanvas.java:339)
        at org.lwjgl.opengl.AWTGLCanvas.update(AWTGLCanvas.java:368)
        at sun.awt.RepaintArea.updateComponent(Unknown Source)
        at sun.awt.RepaintArea.paint(Unknown Source)
        at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
        at java.awt.Component.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$500(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "GUI" java.lang.NoSuchMethodError: onRenderSprite
        at jpcsp.graphics.RE.externalge.NativeUtils.initNative(Native Method)
        at jpcsp.graphics.RE.externalge.NativeUtils.init(NativeUtils.java:94)
        at jpcsp.graphics.RE.externalge.ExternalGE.init(ExternalGE.java:187)
        at jpcsp.HLE.modules.sceDisplay$AWTGLCanvas_sceDisplay.paintGL(sceDispla
y.java:152)
        at org.lwjgl.opengl.AWTGLCanvas.paint(AWTGLCanvas.java:339)
        at org.lwjgl.opengl.AWTGLCanvas.update(AWTGLCanvas.java:368)
        at sun.awt.RepaintArea.updateComponent(Unknown Source)
        at sun.awt.RepaintArea.paint(Unknown Source)
        at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
        at java.awt.Component.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$500(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.awt.EventQueue$4.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionP
rivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

From the log:
Code:
05:40:24  INFO      emu - GUI - Content of PSP_GAME/param.sfo:
BOOTABLE = 1
CATEGORY = UG
DISC_ID = ULUS10251
DISC_NUMBER = 1
DISC_TOTAL = 1
DISC_VERSION = 1.00
PARENTAL_LEVEL = 4
PSP_SYSTEM_VER = 3.03
REGION = 32768
TITLE = FINAL FANTASY
05:40:24  INFO      emu - GUI - Content of UMD_DATA.BIN: 'ULUS-10251|E877C742ACE3AA79|0001|G             |'
05:40:24  INFO      emu - GUI - Java version: 1.8.0_251 (1.8.0_251-b08)
05:40:24  INFO      emu - GUI - Java library path: lib/windows-amd64
05:40:24  INFO      emu - GUI - Using the following settings:
05:40:24  INFO      emu - GUI - Configuration / General
05:40:24  INFO      emu - GUI -     PSP Model                                [PSP-3000 (Brite, 4th Generation)]
05:40:24  INFO      emu - GUI - Configuration / Region
05:40:24  INFO      emu - GUI -     Language:                                [English]
05:40:24  INFO      emu - GUI -     Button preference:                       ["X" for "Enter"]
05:40:24  INFO      emu - GUI -     Daylight saving time:                    [On]
05:40:24  INFO      emu - GUI -     Time format:                             [12H]
05:40:24  INFO      emu - GUI -     Date format:                             [M/D/YYYY]
05:40:24  INFO      emu - GUI -     WLAN power saving mode:                  [Off]
05:40:24  INFO      emu - GUI -     Ad hoc channel:                          [Auto]
05:40:24  INFO      emu - GUI -     Time zone offset in minutes (GMT):       [0]
05:40:24  INFO      emu - GUI -     Nickname:                                [Ventus]
05:40:24  INFO      emu - GUI - Configuration / Video
05:40:24  INFO      emu - GUI -     ( ) Use OpenGL Renderer (Default)
05:40:24  INFO      emu - GUI -     ( ) Use Internal Software Rendering
05:40:24  INFO      emu - GUI -     (X) Use External Software Rendering
05:40:24  INFO      emu - GUI -     [ ] Disable VBO (automatically disabled if not supported)
05:40:24  INFO      emu - GUI -     [ ] Only GE graphics (not recommended for homebrew)
05:40:24  INFO      emu - GUI -     [ ] Use vertex cache
05:40:24  INFO      emu - GUI -     [ ] Use shaders
05:40:24  INFO      emu - GUI -     [ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
05:40:24  INFO      emu - GUI -     [ ] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
05:40:24  INFO      emu - GUI -     [ ] Enable VAO (only relevant when using shaders and vertex cache)
05:40:24  INFO      emu - GUI -     [ ] Enable saving GE screen to textures instead of memory
05:40:24  INFO      emu - GUI -     [ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
05:40:24  INFO      emu - GUI -     [ ] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
05:40:24  INFO      emu - GUI -     [ ] Enable the shader implementation for the "Stencil Test" (more accurate but slower)
05:40:24  INFO      emu - GUI -     [ ] Enable the shader implementation for the "Color Mask" (more accurate but slower)
05:40:24  INFO      emu - GUI -     [ ] Disable optimized VertexInfo reading (may improve compatibility)
05:40:24  INFO      emu - GUI -     [ ] Save Stencil to Memory (more accurate but slower)
05:40:24  INFO      emu - GUI - Configuration / Memory
05:40:24  INFO      emu - GUI -     [ ] Ignore invalid memory access (not recommended for test reports, but improves performance)
05:40:24  INFO      emu - GUI -     [ ] Ignore unmapped imports (not recommended)
05:40:24  INFO      emu - GUI -     [ ] Use debugger memory (slower, enables memory breakpoints)
05:40:24  INFO      emu - GUI - Configuration / Compiler
05:40:24  INFO      emu - GUI -     [X] Use compiler (dynarec)
05:40:24  INFO      emu - GUI -     [X] Output profiler info to profiler.txt (only for compiler)
05:40:24  INFO      emu - GUI -     [3000] Maximum Method Size
05:40:24  INFO      emu - GUI -     [ ] Accurately emulate VFPU dot instructions (more accurate but slower)
05:40:24  INFO      emu - GUI - Configuration / Display
05:40:24  INFO      emu - GUI -     Antialiasing:                            [OFF]
05:40:24  INFO      emu - GUI -     Resolution:                              [Native]
05:40:24  INFO      emu - GUI -     [ ] Start JPCSP in fullscreen exclusive mode
05:40:24  INFO      emu - GUI - Configuration / Misc
05:40:24  INFO      emu - GUI -     [ ] Use debug font (disable flash0 fonts)
05:40:24  INFO      emu - GUI - Configuration / Crypto
05:40:24  INFO      emu - GUI -     [ ] Disable SAVEDATA encryption
05:40:24  INFO      emu - GUI -     [ ] Extract SAVEDATA key to TMP folder
05:40:24  INFO      emu - GUI -     [ ] Extract original PGD files to TMP folder
05:40:24  INFO      emu - GUI -     [ ] Extract decrypted EBOOT.BIN files to TMP folder
05:40:24  INFO      emu - GUI -     [ ] Disable DLC Decryption
05:40:24  INFO      emu - GUI - Configuration / Network
05:40:24  INFO      emu - GUI -     ( ) LAN MultiPlayer
05:40:24  INFO      emu - GUI -     ( ) Server Port Shift
05:40:24  INFO      emu - GUI -     ( ) Client Port Shift
05:40:24  INFO      emu - GUI -     ( ) Enable ProOnline
05:40:24  INFO      emu - GUI -     ProOnline MetaServer                     [coldbird.net]
05:40:24  INFO      emu - GUI -     Broadcasting address                     []
05:40:24  INFO      emu - GUI - Contents of 'flash0/' directory:
05:40:24  INFO      emu - GUI -   flash0:
05:40:24  INFO      emu - GUI -       font:
05:40:24  INFO      emu - GUI -           arib.pgf, size=0x2D4A8
05:40:24  INFO      emu - GUI -           debug.jpft, size=0x18520
05:40:24  INFO      emu - GUI -           gb3s1518.bwfon, size=0xF9D8C
05:40:24  INFO      emu - GUI -           imagefont.bin, size=0x35ED
05:40:24  INFO      emu - GUI -           jpn0.pgf, size=0x182284
05:40:24  INFO      emu - GUI -           kr0.pgf, size=0x603D0
05:40:24  INFO      emu - GUI -           ltn0.pgf, size=0x10DF4
05:40:24  INFO      emu - GUI -           ltn1.pgf, size=0xFE64
05:40:24  INFO      emu - GUI -           ltn10.pgf, size=0xA6C4
05:40:24  INFO      emu - GUI -           ltn11.pgf, size=0xA210
05:40:24  INFO      emu - GUI -           ltn12.pgf, size=0xA880
05:40:24  INFO      emu - GUI -           ltn13.pgf, size=0xA32C
05:40:25  INFO      emu - GUI -           ltn14.pgf, size=0xB080
05:40:25  INFO      emu - GUI -           ltn15.pgf, size=0xA824
05:40:25  INFO      emu - GUI -           ltn2.pgf, size=0x11CF4
05:40:25  INFO      emu - GUI -           ltn3.pgf, size=0x10874
05:40:25  INFO      emu - GUI -           ltn4.pgf, size=0x11C7C
05:40:25  INFO      emu - GUI -           ltn5.pgf, size=0x10A7C
05:40:25  INFO      emu - GUI -           ltn6.pgf, size=0x12CE8
05:40:25  INFO      emu - GUI -           ltn7.pgf, size=0x115E8
05:40:25  INFO      emu - GUI -           ltn8.pgf, size=0xA028
05:40:25  INFO      emu - GUI -           ltn9.pgf, size=0x9CE4
05:40:25  INFO      emu - GUI -       vsh:
05:40:25  INFO      emu - GUI -           etc:
05:40:25  INFO      emu - GUI -               index_04g.dat, size=0x1F0
05:40:25  INFO      emu - GUI - Jpcsp v0.7 6d28d879
05:40:25  INFO      emu - GUI - File 'EBOOT.OLD' not found in directory.
05:40:25  INFO compiler - GUI - Compiler MethodMaxInstructions: 3000
05:40:26  INFO   loader - GUI - Found ModuleInfo at 0x0893BD94, name:'ff1psp', version: 0101, attr: 0x00000000, gp: 0x089D2CB0
05:40:26  INFO   loader - GUI - Found 194 unresolved imports
05:40:26  INFO   loader - GUI - 194 NIDS mapped
05:40:26  INFO hle.sceDisplay - GUI - Only GE Graphics: false
05:40:26  INFO hle.sceDisplay - GUI - Save Stencil To Memory: false
05:40:26  INFO hle.sceNetAdhoc - GUI - Using netClientPortShift=0
05:40:26  INFO hle.sceNetAdhoc - GUI - Using netServerPortShift=0
05:40:26  INFO  runtime - Emu - Using Compiler
05:40:26  INFO externalge - GUI - Software-GE-Renderer 64-bit compiled with SSE=30, AVX=0
05:40:26  INFO externalge - GUI - Software-GE-Renderer 64-bit compiled with SSE=30, AVX=0
05:40:26  INFO compiler - user_main - Replacing CodeBlock at 0x08813EAC by Native Code 'strlen'
05:40:26  INFO compiler - user_main - Replacing CodeBlock at 0x08811BC0 by Native Code 'memset'
05:40:27  INFO compiler - user_main - Splitting _S1_2_0x089C32D8 (3014/3000)
05:40:27  INFO externalge - GUI - Software-GE-Renderer 64-bit compiled with SSE=30, AVX=0
05:40:27  INFO hle.scePower - user_main - scePowerRegisterCallback slot=0x0, uid=0x2B
05:40:27  INFO hle.scePower - user_main - scePowerRegisterCallback returning 0x0
05:40:27  INFO hle.IoFileMgrForUser - user_main - hleIoOpen filename = disc0:/PSP_GAME/USRDIR/data/ff1psp.dpk flags = 1 permissions = 0755
05:40:27  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule module=0x0
05:40:27  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule returning 0x0
05:40:27  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule module=0x1
05:40:27  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule returning 0x0
05:40:28  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule module=0x2
05:40:28  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule returning 0x0
05:40:28  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule module=0x3
05:40:28  INFO hle.sceUtility - user_main - sceUtilityLoadAvModule returning 0x0
05:40:28  INFO externalge - GUI - Software-GE-Renderer 64-bit compiled with SSE=30, AVX=0

As for the other issues from my April post (see below), I haven't found the commit that caused the issue yet.

3) The "O Back" doesn't appear on the bottom of the screen when the message "The game data has been saved." appears. The screen needs to be more transparent in comparison to how it appears on the PSP. (1st Screenshot - JPCSP, 2nd Screenshot - PSP)

4) When attempting to overwrite an existing save, the SAVEDATA message appears on the log but doesn't appear on JPCSP as a screen overlay. (3rd Screenshot - JPCSP, 4th Screenshot - PSP)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)