This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Correct Java Bit-Version of JPCSP
01-13-2013, 12:36 AM
Post: #1
The Correct Java Bit-Version of JPCSP
Hello everyone,

Hello everyone,

First, I want to say that this is a great site with a lot of informative (and very patient) members. I've learned a lot. Thanks.

Unfortunately, JPCSP runs incredibly slowly on my computer, so I really can't use it. This maybe my only post, but I wanted to address one major problem I've been reading about in the archives. My apologies if this has already been addressed.

Some people are having a problem with Java when they try to start JPCSP. If you have downloaded the 64-bit version, it will usually say that you don't have the 64-bit Java JRE installed. Well, it's absolutely right; you don't have 64-bit Java installed. You have 32-bit Java installed, and you need to download the 32-bit version of JPCSP.

You're bit version of Java is based on your internet browser's bit version. When you install Java, your browser communicates with the Java website and gives it the bit version of your browser to the Java website; it's not based on your operating system's bit version.

To find what bit version your running, open up the "about" section in your browser and look for anything that says 64-bit. If you don't see 64-bit anywhere, you have a 32-bit browser (I believe most people with 64-bit operating systems have 32-bit browsers).

I think most people are downloading the 64-bit JPCSP because the download page is misleading. When someone reads the download headings, one may think that the heading is asking one which bit version of your operating system one has. Really what it is asking is which bit version of Java one has. I think the headings should be changed to reflect this and clear up a lot of confusion.

I know I was incredibly frustrated when JPCSP kept saying that I didn't have the 64-bit version of Java installed when I was absolutely sure that it was installed. I mean I have a 64-bit operating system, so why wouldn't I have 64-bit Java installed, right? I spent a few hours searching the internet for a way to get JPCSP to run, but I found nothing that worked. I finally found an ehow article explaining that your Java bit version is based on your browser's bit version. I then downloaded the JPCSP 32-bit version, and low and behold, it worked.

I hope this helps someone who may be as confused and frustrated as I was.
Find all posts by this user
Quote this message in a reply
01-13-2013, 12:55 AM (This post was last modified: 01-13-2013 12:57 AM by hyakki.)
Post: #2
RE: The Correct Java Bit-Version of JPCSP
you can just go to oracles java page and select the version of java you want to download
http://www.oracle.com/technetwork/java/j...80261.html

Windows x86 Offline 29.99 MB jre-7u10-windows-i586.exe < 32-bit
Windows x64 31.42 MB jre-7u10-windows-x64.exe < 64-bit

Try Out JPCSP Launcher v1.8.0.4 | How to post a log
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)