Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solutions for display error
#1
I decided to make a little(But important) thread.
It seems many users had a display problem with jpcsp and there are 2 main reasons:
1.You need the x64 drivers if you own a 64 bit pc
2.You have to be in 32 bit color mode

But in windows Xp there was this error that not even the drivers and the color mode won't make it dissapear,but there might be a solution:Strangely if you change the xmx to 768 it might work.
Also windows 8 has some problems with the openGl
Am I the only one with this cool sig?
[Image: ji6WX.png]
[Image: 2404362.png]
Reply

#2
If batch file can dectect windows xp, will auto use xms to 768 .Will be good
Reply

#3
(12-14-2012, 02:48 PM)sum2012 Wrote: If batch file can dectect windows xp, will auto use xms to 768 .Will be good
Good suggestion!
Could someone having Windows XP test if the following change would work.
It is setting -Xmx768m for Windows XP.


Attached Files
.7z   start-windows-x86.7z (Size: 920 bytes / Downloads: 28)
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#4
Yes, it works. But I think the "Display Error" is not present with every graphics card on XP. My AMD works with 1024, but the Intel works only with 768
JPCSP games tested with Athlon X2 4850e, 4 GB RAM, Radeon HD 3300 (onboard), OpenGL: 3.3.11653, Windows XP SP3 32-bit
PPSSPP games tested with Intel i3, 4 GB RAM, Intel HD Graphics 2000 (onboard), OpenGL: 3.1.0 Build 6.14.10.5421, Windows XP SP3 32-bit
Reply

#5
I would like to keep the official start files as conservative as possible so that they work without changes for most users.

For advanced users, I was thinking at the possibility to configure the java options from outside the bat file, so that you don't have to edit it at each new revision. E.g. if the variable JPCSP_JAVA_OPTIONS is set, the bat file would use these options instead of the default ones "-Xmx1024m -Xss2m -XX:MaxPermSize=128m -XX:ReservedCodeCacheSize=64m".

Would it help? Or are you all using Hyakki's launcher?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#6
I do not use Hyakki's launcher
Reply

#7
(12-14-2012, 03:40 PM)sum2012 Wrote: I do not use Hyakki's launcher
Are you editing the bat file to change the Java options or are you keeping the default ones?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply

#8
(12-14-2012, 02:38 PM)virgil94 Wrote: 1.You need the x64 drivers if you own a 64 bit pc
Hmm...i think issue there is, that people using default drivers, which was included with Windows. Long ago i have issue with them - applications, which using OpenGL (based on Quake 3 engine, for example) won't run with default drivers on XP SP2 until i installed drivers by Nvidia. Big Grin
Reply

#9
I am keeping the default ones unless I get StackOverflowError .
(12-14-2012, 03:45 PM)gid15 Wrote:
(12-14-2012, 03:40 PM)sum2012 Wrote: I do not use Hyakki's launcher
Are you editing the bat file to change the Java options or are you keeping the default ones?

Reply

#10
(12-14-2012, 04:01 PM)BlackDaemon Wrote:
(12-14-2012, 02:38 PM)virgil94 Wrote: 1.You need the x64 drivers if you own a 64 bit pc
Hmm...i think issue there is, that people using default drivers, which was included with Windows. Long ago i have issue with them - applications, which using OpenGL (based on Quake 3 engine, for example) won't run with default drivers on XP SP2 until i installed drivers by Nvidia. Big Grin

Well there was somebody on the medievil thread that didn't had the x64 drivers,only the 32 and jpcsp wouldn't work.When I had Xp Sp3 the same happened to me,but it's strange that you have to change the xmx to solve a graphic problem Huh
Am I the only one with this cool sig?
[Image: ji6WX.png]
[Image: 2404362.png]
Reply



Forum Jump:


Users browsing this thread:
1 Guest(s)

Powered By MyBB, © 2002-2022 iAndrew & Melroy van den Berg.