This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't run Jpcsp
#1
I tried to use Jpcsp 0.6 2324 on my desktop computer and netbook. I have Windows XP SP3 and Java 6 update 27 installed on both machines. On desktop computer running start-windows-x86.bat shows console window with "Running Jpcsp 32bit..." message, then shows the GUI for half a second and exits. What could it be? On netbook GUI starts normal but when I choose "Load UMD" from the menu, no dialog appears and there are some messages in console:
Code:
Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 0
        at jpcsp.GUI.UmdBrowser.loadUmdInfo(UmdBrowser.java:389)
        at jpcsp.GUI.UmdBrowser.access$500(UmdBrowser.java:74)
        at jpcsp.GUI.UmdBrowser$MemStickTableModel.<init>(UmdBrowser.java:172)
        at jpcsp.GUI.UmdBrowser.<init>(UmdBrowser.java:263)
        at jpcsp.MainGUI.openUmdActionPerformed(MainGUI.java:1338)
        at jpcsp.MainGUI.access$400(MainGUI.java:114)
        at jpcsp.MainGUI$5.actionPerformed(MainGUI.java:363)
        at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
        at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
        at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
        at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
        at javax.swing.AbstractButton.doClick(Unknown Source)
        at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
        at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
        at java.awt.Component.processMouseEvent(Unknown Source)
        at javax.swing.JComponent.processMouseEvent(Unknown Source)
        at java.awt.Component.processEvent(Unknown Source)
        at java.awt.Container.processEvent(Unknown Source)
        at java.awt.Component.dispatchEventImpl(Unknown Source)
        at java.awt.Container.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
        at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
        at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
        at java.awt.Container.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$000(Unknown Source)
        at java.awt.EventQueue$1.run(Unknown Source)
        at java.awt.EventQueue$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
        at java.awt.EventQueue$2.run(Unknown Source)
        at java.awt.EventQueue$2.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

Help please
Reply

#2
hey do you know how do you launch it with JRE recognized cus i mine didnt get recognized
Reply

#3
You don't launch it with JRE per se. What you do is that you download whatever version you prefer and extract the folder to the location of your choice on your computer. Go to that folder and doubleclick the .bat file which works like an .exe file and JPCSP will start. Alternatively, you can download the launcher which just reroutes to the .bat file (the launcher comes with some editing options that might improve performance, though).

If you attempt to start JPCSP any other way you are doing it wrong.

As for the OP, attempt to reinstall JRE or get Java 7. If that doesn't work, redownload the rev as it might have become corrupted during the downloading process. Also, scan your computer for viruses and other kinds of crap. Further, you might want to download the program called Xuggle and possibly SonicStage.
Reply

#4
Hello,
I found the same Problem. Instaled 6.27 jre, then came here and got java 7. Still nothing, got Xuggle, still nothing. Is SonicStage the Sony music program? Didn't download it yet because of the doubt =/

Any idea of what might be the problem?
Reply

#5
Did you try the other methods I suggested such as redownloading JPCSP or trying a different rev? SonicStage is the music program that JPCSP uses to decode music files for many games. If you got the setting to decode a game without SonicStage it might shut down after you attempt to load the UMD.

Also, delete the old version of Java and make sure you obviously run the right bit version for your JPCSP.
Reply

#6
my problem is the same with your desktop one...before this i can run jpcsp but out of sudden, i cannot run it anymore until now...i already try reinstalling java and jpcsp but to no avail... :/
Reply

#7
i run jpcps 2832 but it can't run and this [Image: 41655963.png]
appear who know this error, please tell me the way to fix this error
Reply

#8
Try locating JPCSP on "C:\JPCSP\start-windows-amd64.bat"; i suspect too long patch or with some wild card are the source of the issue.
[Image: montcer.png]
Reply

#9
I did that but it isn't effective
Reply

#10
Quote:java.lang.illegalargumentException: 0 incompatible with Text-specific LCD contrast key.
Look here:
http://www.rarst.net/software/cleartype-...-java-bug/

[Image: montcer.png]
Reply



Forum Jump:


Users browsing this thread:
2 Guest(s)

Powered By MyBB, © 2002-2022 iAndrew & Melroy van den Berg.