This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Digimon World Re:Digitize - NPJH50588
07-19-2012, 08:39 PM (This post was last modified: 12-05-2017 02:55 PM by DragonNeos.)
Post: #1
Digimon World Re:Digitize - NPJH50588
Config:
   


So the game runs pretty well (full fps most of the time, except in a few areas where it drops to 20FPS) in r2574 32bits.
These are some of the graphical glitches I found:
   
The intro Scene after starting a new game looks like this.

   
The dialog boxes are heavily glitched.

   
The sky and some textures are really pixellated.

   
When the tutorial starts in the game the background looks all garbled, I think the BG should be a blurred still picture of your current battle against this weird gabumon.

Also every menu shows only one Sprite Icon I.E.: When fighting a battle the "makasete" "Items" and "scape" options all have a leaf icon whilst the makasete should have some sort of smiley for example. This happens also inside the digivice menu and in many other places where Icons should be (every option has the same icon). Connected to this issue, I think, is the issue that all damage output sprites display 000 (it's as if every sprite was being replaced by the first one in some sort of table) but the enemy damage bar keeps diminishing.

The game also hangs in some battles.

Here's a clarification of what I meant by all options sharing the same sprite Icons and the 000 damage display in every attack:
   
000 damage input and all icons are leaves in the top left corner.

In the digivice menu (hit triangle)
   
Every option says digivice (デジヴァイス) under them and have the exact same Icon whilst they perform different actions in the game.
This screen shows heavy sprite Icon glitches all over the place.

PC Specs:
Windows x64
Intel Core I5 2500K @3.6Ghz
Geforce GTX560 TI OC'ed
4GB of Ram

Is there anything I should log? How should I log it?
Also should this be moved to fully playable games even though it hangs randomly in battles?

Mod Edit - Added GameID to topic title.
Find all posts by this user
Quote this message in a reply
07-19-2012, 10:17 PM
Post: #2
RE: Digimon World RE: Digitize.
It's out already? I was so waiting for this

Am I the only one with this cool sig?
[Image: ji6WX.png]
[Image: 2404362.png]
Find all posts by this user
Quote this message in a reply
07-19-2012, 10:26 PM
Post: #3
RE: Digimon World RE: Digitize.
Have you tried disabling VAO, CLUT and optimized vertex info?
Find all posts by this user
Quote this message in a reply
07-19-2012, 11:49 PM (This post was last modified: 07-20-2012 01:01 AM by damicore.)
Post: #4
RE: Digimon World RE: Digitize.
With VAO, CLUT and optimized vertex info off:
Same problem with the sprites, the Sky and other pixelated pictures have stopped being pixelated.
But there are some random polygons missing in some of the character models (look near agumon's head):
   
Also, you can see in this screen the icons are all the same when they shouldn't be.
Find all posts by this user
Quote this message in a reply
07-20-2012, 01:25 AM
Post: #5
RE: Digimon World Digitize.
(07-19-2012 08:39 PM)damicore Wrote:  Config:



So the game runs pretty well (full fps most of the time, except in a few areas where it drops to 20FPS) in r2574 32bits.
These are some of the graphical glitches I found:

The intro Scene after starting a new game looks like this.


The dialog boxes are heavily glitched.


The sky and some textures are really pixellated.


When the tutorial starts in the game the background looks all garbled, I think the BG should be a blurred still picture of your current battle against this weird gabumon.

Also every menu shows only one Sprite Icon I.E.: When fighting a battle the "makasete" "Items" and "scape" options all have a leaf icon whilst the makasete should have some sort of smiley for example. This happens also inside the digivice menu and in many other places where Icons should be (every option has the same icon). Connected to this issue, I think, is the issue that all damage output sprites display 000 (it's as if every sprite was being replaced by the first one in some sort of table) but the enemy damage bar keeps diminishing.

The game also hangs in some battles.

Here's a clarification of what I meant by all options sharing the same sprite Icons and the 000 damage display in every attack:

000 damage input and all icons are leaves in the top left corner.

In the digivice menu (hit triangle)

Every option says digivice (デジヴァイス) under them and have the exact same Icon whilst they perform different actions in the game.

PC Specs:
Windows x64
Intel Core I5 2500K @3.6Ghz
Geforce GTX560 TI OC'ed
4GB of Ram

Is there anything I should log? How should I log it?
Also should this be moved to fully playable games even though it hangs randomly in battles?


How did you manage to get it to run? Every time I try i get this error - http://puu.sh/K2eh
and obviously I have no idea what it means/says as I don't know Japanese Tongue
Find all posts by this user
Quote this message in a reply
07-20-2012, 01:33 AM
Post: #6
RE: Digimon World RE: Digitize.
The time doesn't show correctly in game. While you should be seeing something like (09:09), you get (00000) with the colon being replaced with a zero in the middle. Like damicore said earlier, some icons are replaced with something completely different like the Happiness and Discipline icon being replaced with the poop icon. The button to use the finisher is being displayed as X, but you need to press Square instead (or the button you assigned it to). Sometimes, when the player talks to a Digimon, the background is blurred.
Find all posts by this user
Quote this message in a reply
07-20-2012, 01:59 AM
Post: #7
RE: Digimon World RE: Digitize.
So i got past the 532kb error (was pressing X and not O as "enter".
But now I get the main menu, no background, only 4 options,
the first I assume is New Game
The second is Load game
Third is select save location
fourth is install data
the only one that works is the first option, but once I select it, I get white and black "bars" across the screen, can't go back, can't go forward xD
Find all posts by this user
Quote this message in a reply
07-20-2012, 02:20 AM (This post was last modified: 07-20-2012 03:09 AM by damicore.)
Post: #8
RE: Digimon World Digitize.
(07-20-2012 01:59 AM)chris2k7sears Wrote:  So i got past the 532kb error (was pressing X and not O as "enter".
But now I get the main menu, no background, only 4 options,
the first I assume is New Game
The second is Load game
Third is select save location
fourth is install data
the only one that works is the first option, but once I select it, I get white and black "bars" across the screen, can't go back, can't go forward xD

It should be hard to play it not knowing japanese.
When you get tue black screen and the subscequent screens with the bars you should press start, it will ask you if you want to skip the cut-scene and then you have to select yes (はい) with your ccircle button, after that your good to go.
To display the bakcground in the main menu you should use the settings I used minus "disable VAO", the CLUT one, and the Vertex Cache Info thing.

I don't know why would the cutscene display in such a weird way.

(07-20-2012 01:33 AM)DragonNeos Wrote:  The time doesn't show correctly in game. While you should be seeing something like (09:09), you get (00000) with the colon being replaced with a zero in the middle. Like damicore said earlier, some icons are replaced with something completely different like the Happiness and Discipline icon being replaced with the poop icon. The button to use the finisher is being displayed as X, but you need to press Square instead (or the button you assigned it to). Sometimes, when the player talks to a Digimon, the background is blurred.

This is due to the time digits being probably stored as sprites in a similar way by the game. It's always as if it chose the first one from an array to replace every icon in that category.
Find all posts by this user
Quote this message in a reply
07-20-2012, 05:50 AM (This post was last modified: 07-20-2012 06:09 AM by janoia.)
Post: #9
RE: Digimon World RE: Digitize.
So my game was working as well as damicore's seemed to be until I tried to save my game. It saved, but immediately shut down JPCSP (is it supposed to do that?). When I loaded it back up the sound stopped working. I've tried restarting JPCSP as well as Digimon World Re:Digitalize and the sound is still gone. :/


Edit: Fourth time is the charm? Sound came back, and it didn't quit after saving this time.
Find all posts by this user
Quote this message in a reply
07-20-2012, 06:12 AM
Post: #10
RE: Digimon World RE: Digitize.
Do devs check these boards? I'm kind of new to this whole game troubleshooting part of the forum.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: