This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Post Reply 
 
Thread Rating:
  • 1 Votes - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
.hack//LINK - ULJS00266
03-10-2014, 08:06 PM
Post: #11
RE: .hack//LINK - ULJS00266
(03-10-2014 04:32 AM)Watta Wrote:  i try to change the -xmx and -xx:maxpermsize to 1024 value,but the emu showing an error saying " error occured during initialization of VM .could not reseverve enough space for object heap "
Rather try to reduce (not increase) the values for -Xmx or -Xss, e.g. "-Xmx768m" or "-Xss1m"

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-10-2014, 08:50 PM
Post: #12
RE: .hack//LINK - ULJS00266
(03-10-2014 08:06 PM)gid15 Wrote:  
(03-10-2014 04:32 AM)Watta Wrote:  i try to change the -xmx and -xx:maxpermsize to 1024 value,but the emu showing an error saying " error occured during initialization of VM .could not reseverve enough space for object heap "
Rather try to reduce (not increase) the values for -Xmx or -Xss, e.g. "-Xmx768m" or "-Xss1m"

thank you for the hint gid,i'll try it and let you know if the settings work.

* tried with recommended settings for lowering -xmx or -xss
first case, i tried to lower both -xmx and -xss value to 768m and 1m.the game run smooth getting pass the loading screen after prologue end ( yay!),but suffer fps drop from 30 to 12 - 18fps when the loading finish,getting to first tutorial battle stage 1,sluggish movement because of fps drop,no error so far but i got the error when trying to get to the next room ( the game freeze on the loading screen )

* tried with lowering only -xss value to 1m
getting past the prologue smoothly,getting fps drop,no error in first tutorial battle,same error after i tried to proceed to the next room

* tried with lowering only -xmx to 768m
freeze after prologue end at the loading screen ( same error when using default -xmx and -xss value (1024m and 2m)


i attach 3 log if that help


Attached File(s)
.rar  log info r3462(xss1 xmx768).rar (Size: 5.22 KB / Downloads: 1)
.rar  log info r3462(xss1 xmx1024).rar (Size: 5.4 KB / Downloads: 1)
.rar  log info r3462(xss2 xmx768).rar (Size: 4.49 KB / Downloads: 1)
Find all posts by this user
Quote this message in a reply
03-10-2014, 09:16 PM
Post: #13
RE: .hack//LINK - ULJS00266
(03-10-2014 08:50 PM)Watta Wrote:  * tried with lowering only -xss value to 1m
getting past the prologue smoothly,getting fps drop,no error in first tutorial battle,same error after i tried to proceed to the next room
It seems this is the best option. You can try to reduce the "-xss" even more: -Xss256k or less.
Rem.: 1m is actually equivalent to 1024k

Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Find all posts by this user
Quote this message in a reply
03-10-2014, 09:57 PM (This post was last modified: 03-10-2014 10:37 PM by Watta.)
Post: #14
RE: .hack//LINK - ULJS00266
(03-10-2014 09:16 PM)gid15 Wrote:  
(03-10-2014 08:50 PM)Watta Wrote:  * tried with lowering only -xss value to 1m
getting past the prologue smoothly,getting fps drop,no error in first tutorial battle,same error after i tried to proceed to the next room
It seems this is the best option. You can try to reduce the "-xss" even more: -Xss256k or less.
Rem.: 1m is actually equivalent to 1024k

tried with -xss 256k
smoothly pass the next room after first battle tutorial,still having fps drop though,but there's no more error until i reach the save point,no error at the battle sequence too Big Grin thank you gid
but is there a way to get a better fps with 32bit OS?

note : fps drop only happen when entering the battle with 1 or more enemies on screen(in tutorial battle 12-18fps),if there's no enemy,getting a 20-25 fps(tutorial battlefield).getting a solid 30-31 fps at the conversation and not being in the field of battle,if there's a conversation when on the battlefield (5-9 fps).using 32bit OS and emu.no problem with sound and graphic. i think this game is fully playable on 64bit version Big Grin

again,thank you for the guide Wink

here's the log


Attached File(s)
.rar  log info r3462(xss256k).rar (Size: 5.7 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
03-10-2014, 11:31 PM
Post: #15
RE: .hack//LINK - ULJS00266
i just found out when using " use external software renderer " i get a stable fps when fighting the enemy (14-15fps) and get 20-21fps when there's no enemy in the battle field Big Grin
Find all posts by this user
Quote this message in a reply
03-14-2014, 04:30 AM
Post: #16
RE: .hack//LINK - ULJS00266
Even though the option "External Software Renderer" is enabled and displayed, JPCSP is actually using the option "OpenGL Renderer" since the external .dll file has not been bundled with the emulator yet.
Find all posts by this user
Quote this message in a reply
03-14-2014, 09:22 AM
Post: #17
RE: .hack//LINK - ULJS00266
(03-14-2014 04:30 AM)DragonNeos Wrote:  Even though the option "External Software Renderer" is enabled and displayed, JPCSP is actually using the option "OpenGL Renderer" since the external .dll file has not been bundled with the emulator yet.

didn't know about that,but after i select that option for playing this game,the fps is more stable...i try it on the same battlefield spot using openGL renderer and external software renderer.
maybe its just a coincidence Tongue
any tips for getting more stable fps when playing this game using 32bit emu,dragonneos? i'm fine playing this game with 30fps because this game is playable with 30 fps ( a bit slow motion,but still playable when executing battle command and move around )
Find all posts by this user
Quote this message in a reply
03-16-2014, 09:43 PM (This post was last modified: 03-17-2014 12:48 AM by DragonNeos.)
Post: #18
RE: .hack//LINK - ULJS00266
You can try these Settings, but there's no guarantee that JPCSP will consistently run at 30 FPS.
Code:
Configuration / Video
[ ] Disable VBO (automatically disabled if not supported)
[ ] Only GE graphics (not recommended for homebrew)
[X] Use vertex cache
[X] Use shaders
[ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
[ ] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
[ ] Enable VAO (only relevant when using shaders and vertex cache)
[X] Enable saving GE screen to textures instead of memory
[ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
[X] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
[ ] Enable the shader implementation for the "Stencil Test" (more accurate but slower)
[ ] Enable the shader implementation for the "Color Mask" (more accurate but slower)
[ ] Disable optimized VertexInfo reading (may improve compatibility)
[ ] Save Stencil to Memory (more accurate but slower)
[ ] Use Internal Software Rendering
[ ] Use External Software Rendering
Configuration / Audio
[ ] Disable audio threads
[ ] Disable audio channels (not recommended)
[ ] Disable audio blocking
Configuration / Memory
[X] Ignore invalid memory access (not recommended for test reports, but improves performance)
[ ] Ignore unmapped imports (not recommended)
Configuration / Misc
[X] Use Media Engine
[X] Enable Atrac3+ decoding (experimental, requires Media Engine)
[ ] Extract media files to TMP folder
[X] Decode audio files with SonicStage (must be installed separately and requires Media Engine)
[ ] Use debug font (disable flash0 fonts)
Configuration / Compiler
[X] Use compiler (dynarec)
[ ] Output profiler info to profiler.txt (only for compiler)
[50] maximum method size
Configuration / Crypto
[X] Extract decrypted EBOOT.BIN files to TMP folder
[ ] Disable SAVEDATA encryption
[ ] Extract original PGD files to TMP folder
[X] Extract SAVEDATA key to TMP folder
[ ] Disable DLC decryption
Configuration / Display
Antialiasing:                            [OFF]
Resolution:                              [Native]
[ ] Start JPCSP in fullscreen exclusive mode
EDIT: After taking a look at your INFO log, I noticed that there was a website next to the title of the game, which implies piracy. A game's PARAM.SFO should not have anything else in the title other than the name of the game. This forum does not support piracy and we will not give support to those who partake in such activities.
Find all posts by this user
Quote this message in a reply
03-17-2014, 07:56 AM (This post was last modified: 03-17-2014 07:58 AM by Watta.)
Post: #19
RE: .hack//LINK - ULJS00266
(03-16-2014 09:43 PM)DragonNeos Wrote:  You can try these Settings, but there's no guarantee that JPCSP will consistently run at 30 FPS.
Code:
Configuration / Video
[ ] Disable VBO (automatically disabled if not supported)
[ ] Only GE graphics (not recommended for homebrew)
[X] Use vertex cache
[X] Use shaders
[ ] Use a Geometry Shader for 2D rendering (only relevant when using shaders)
[ ] Disable UBO (automatically disabled if not supported, only relevant when using shaders)
[ ] Enable VAO (only relevant when using shaders and vertex cache)
[X] Enable saving GE screen to textures instead of memory
[ ] Enable decoding of indexed textures (using CLUT) in shader (only relevant when using shaders)
[X] Enable dynamic shader generation (only relevant when using shaders, recommended for AMD/ATI)
[ ] Enable the shader implementation for the "Stencil Test" (more accurate but slower)
[ ] Enable the shader implementation for the "Color Mask" (more accurate but slower)
[ ] Disable optimized VertexInfo reading (may improve compatibility)
[ ] Save Stencil to Memory (more accurate but slower)
[ ] Use Internal Software Rendering
[ ] Use External Software Rendering
Configuration / Audio
[ ] Disable audio threads
[ ] Disable audio channels (not recommended)
[ ] Disable audio blocking
Configuration / Memory
[X] Ignore invalid memory access (not recommended for test reports, but improves performance)
[ ] Ignore unmapped imports (not recommended)
Configuration / Misc
[X] Use Media Engine
[X] Enable Atrac3+ decoding (experimental, requires Media Engine)
[ ] Extract media files to TMP folder
[X] Decode audio files with SonicStage (must be installed separately and requires Media Engine)
[ ] Use debug font (disable flash0 fonts)
Configuration / Compiler
[X] Use compiler (dynarec)
[ ] Output profiler info to profiler.txt (only for compiler)
[50] maximum method size
Configuration / Crypto
[X] Extract decrypted EBOOT.BIN files to TMP folder
[ ] Disable SAVEDATA encryption
[ ] Extract original PGD files to TMP folder
[X] Extract SAVEDATA key to TMP folder
[ ] Disable DLC decryption
Configuration / Display
Antialiasing:                            [OFF]
Resolution:                              [Native]
[ ] Start JPCSP in fullscreen exclusive mode
EDIT: After taking a look at your INFO log, I noticed that there was a website next to the title of the game, which implies piracy. A game's PARAM.SFO should not have anything else in the title other than the name of the game. This forum does not support piracy and we will not give support to those who partake in such activities.

thank you for the settings,i will try it later when i have some free time.been busy with work atm.
about the game was a pirated game or not,i didnt know about about it,because i bought it from local store in my country on the form of iso format.
i'm apologize to this forum if the game i bought was actually a pirated format,just trying to get some help playing this game on jpcsp emulator which is my fav emulator so far.
Find all posts by this user
Quote this message in a reply
02-07-2015, 05:53 AM (This post was last modified: 02-07-2015 06:16 AM by lilt00.)
Post: #20
RE: .hack//LINK - ULJS00266
Good news, .hack fans!

I've managed to get .hack//Link working online with coldbird.net server, the game used to get stuck on the Connecting... pop up window and does the same thing on PPSSPP currently, thus blocking the game start window (the one with your nickname) and fading it out so all controls become unresponsible and you get stuck on this screen.

No more! The fix is quite simple really, all you need to do is set JPCSP clock speed to 150% and once you get past the pop up window of hell go back to Normal Clock. Enjoy!

*This fix does not work with PPSSPP.
**You just need to do this ONE TIME.

Settings used:
JPCSP r3698 Windows x64
Code:
Configuration / General
[X] Run immediately after loading
PSP Model: PSP-2000

Configuration / Video
[X] Use Opengl Render (Default)
[X] Enable saving GE screen to textures instead of memory
[X] Disable optimized VertexInfo reading (may improve compatibility)

Configuration / Memory
[X] Ignore invalid memory access (not recommended for test reports, but improves performance)
[X] Ignore unmapped imports (not recommended)

Configuration / Compiler
[X] Use compiler (dynarec)
[50] maximum method size

Configuration / Network
[X] Enable ProOnline
ProOnline MetaServer: coldbird.net

[Image: fix1.png][Image: fix2.png]
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: