EmuNewz Network
Regression causing corrupted gfx to appear on game load - Printable Version

+- EmuNewz Network (http://www.emunewz.net/forum)
+-- Forum: PSP Emulation (/forumdisplay.php?fid=191)
+--- Forum: JPCSP Official Forum (/forumdisplay.php?fid=51)
+---- Forum: JPCSP builds and releases (/forumdisplay.php?fid=53)
+---- Thread: Regression causing corrupted gfx to appear on game load (/showthread.php?tid=7386)



Regression causing corrupted gfx to appear on game load - legend80 - 08-21-2011 07:29 AM

After loading the game (before running it), the black background (fullscreen) displays garbage gfx. See screenshot. Even after a game is running, you'll see this crud during transitions or in the letterboxing areas.

What's weird is one time I saw it display images from the last game I played in Dolphin, as if it were showing the last thing in the vram's buffer or something.

I don't have too much time to narrow it down - I'm hoping you guys can figure it out. This started happening in revs released about 2-3 weeks ago. If I get time, i'll see if I can isolate the change that broke this. I'm surprised no one else has brought this up.

Settings attached as well.


RE: Regression causing corrupted gfx to appear on game load - Hykem - 08-21-2011 02:44 PM

Hmm...
I've seen this happen when "Saving GE to texture" option is enabled. Could you please confirm if this also happens with this option unchecked?


RE: Regression causing corrupted gfx to appear on game load - legend80 - 08-21-2011 05:42 PM

Ok, this issue is directly related to that option - only occurs if it's active. Nonetheless, I'm sure something recently has introduced this behavior. I've had this option on for months, ever since I found out that you need it to get hi-res gfx. But I've only observed this problem for a short while.


RE: Regression causing corrupted gfx to appear on game load - legend80 - 09-18-2011 05:54 AM

Still no change to this regression as of r2313.