EmuNewz Network
Star Wars : Lethal Alliance - ULUS10188 - Printable Version

+- EmuNewz Network (http://www.emunewz.net/forum)
+-- Forum: PSP Emulation (/forumdisplay.php?fid=191)
+--- Forum: JPCSP Official Forum (/forumdisplay.php?fid=51)
+---- Forum: Commercial Game Discussion (/forumdisplay.php?fid=54)
+----- Forum: JPCSP - Half playable Games (/forumdisplay.php?fid=66)
+----- Thread: Star Wars : Lethal Alliance - ULUS10188 (/showthread.php?tid=70567)



Star Wars : Lethal Alliance - ULUS10188 - hyakki - 07-22-2012 10:21 PM

r2633
Gets an invalid memory address, pressing run a few times it will then proceed to shows 3 logos then quits out
[attachment=9038][attachment=9039][attachment=9040]

Looking through all my umd's, this is the only other game I have that uses the unreal engine (it's not even in the list of unreal engine games strangely enough.)
http://en.wikipedia.org/wiki/List_of_Unreal_Engine_games


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - gid15 - 07-24-2012 03:39 PM

Code:
Found ModuleInfo name:'PSPLoader' version:0101 attr:00000000 gp:00000000
Using Compiler
...
Using Compiler
Found ModuleInfo name:'StarWarsPSP' version:0101 attr:00000000 gp:00007ff0
This game seems to use sceKernelLoadExec, could you check if there are any improvements with r2634 and r2638?

Thank you!


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - BlackDaemon - 07-24-2012 05:14 PM

Similar loader was used in Splinter Cell: Essentials, and looks like it's playable now. Smile


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - hyakki - 07-24-2012 08:49 PM

Yeah half-playable in r2643, there is some graphical bugs though (looks over-bright) , I haven't tried without shaders yet so maybe that will help
i see a ton of these in the log
Unimplemented VAP: alpha=114, prim_type=1


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - gid15 - 07-27-2012 03:23 PM

(07-24-2012 08:49 PM)hyakki Wrote:  i see a ton of these in the log
Unimplemented VAP: alpha=114, prim_type=1
I've added additional debug information for the VAP command in r2645: not all the parameters of the commands were listed. Could you update the log file? I will then add support for this command in the 3DStudio and try to find out how it works... No documentation is available.


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - hyakki - 07-27-2012 08:13 PM

r2650

Unimplemented VAP: alpha=114, prim_type=1, unknown=0x0E8C


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - gid15 - 08-11-2012 10:32 AM

(07-27-2012 08:13 PM)hyakki Wrote:  r2650

Unimplemented VAP: alpha=114, prim_type=1, unknown=0x0E8C
Added as Issue 314 to not forget it Wink


RE: Star Wars : Lethal Alliance - ULUS10188 [Encrypted] - hyakki - 11-14-2012 06:47 AM

r2857
Using the new Save Stencil to Memory option, game brightness is normal and game is playable (sometimes takes a speed hit though)


RE: Star Wars : Lethal Alliance - ULUS10188 - nash67 - 10-02-2018 12:43 PM

after the 3rd developers screen nothing but a black screen


RE: Star Wars : Lethal Alliance - ULUS10188 - gid15 - 10-02-2018 03:08 PM

(10-02-2018 12:43 PM)nash67 Wrote:  after the 3rd developers screen nothing but a black screen

Code:
20:42:08 ERROR     h264 - Video Decoder Thread - H264 decode error 0xFFFFFFFF
20:42:08 ERROR hle.sceMpeg - Video Decoder Thread - decodeNextImage codec returned 0xFFFFFFFF
I am working on a complete rewrite of the HLE modules responsible for the video play (sceMpeg and scePsmfPlayer) to better match the PSP behavior. E.g. some of the games in the "Intro" section still have issues with the current video modules. Hopefully my rewrite will fix those issues...