EmuNewz Network

Full Version: fog effects problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Final Fantasy Type-0 and some other games have fog effects problem.

Final Fantasy Type-0
JPCSP
[attachment=16295] [attachment=16296]
PSP
[attachment=16297]

Tales of The World: Radiant Mythology 2
JPCSP
[attachment=16298]
[attachment=16299]
[attachment=16300]
PSP
[attachment=16301]
[attachment=16302]

Tenchu 4
JPCSP
[attachment=16303]
[attachment=16304]
[attachment=16305]
PSP
[attachment=16306]
[attachment=16307]
[attachment=16308]
it seems like jpcsp renders ignores fogging. Is it software or opengl render?
(04-27-2014 03:25 PM)shadow Wrote: [ -> ]it seems like jpcsp renders ignores fogging. Is it software or opengl render?
opengl, but jpcsp ignores fogging even use sofware
(04-27-2014 03:30 PM)onelight Wrote: [ -> ]
(04-27-2014 03:25 PM)shadow Wrote: [ -> ]it seems like jpcsp renders ignores fogging. Is it software or opengl render?
opengl, but jpcsp ignores fogging even use sofware

Hmmm, I remember this issue. It will have to be gid15 answering this, but could you please tell which settings (graphics) are you using? Since you're using the standard OpenGL back-end, I presume you're also using shaders, right?
(04-27-2014 04:20 PM)Hykem Wrote: [ -> ]
(04-27-2014 03:30 PM)onelight Wrote: [ -> ]
(04-27-2014 03:25 PM)shadow Wrote: [ -> ]it seems like jpcsp renders ignores fogging. Is it software or opengl render?
opengl, but jpcsp ignores fogging even use sofware

Hmmm, I remember this issue. It will have to be gid15 answering this, but could you please tell which settings (graphics) are you using? Since you're using the standard OpenGL back-end, I presume you're also using shaders, right?

I use different settings in that 3 games.
Final Fantasy Type-0
Use vertex cache
Use shaders
Enable saving GE screen to textures instead of memory
Enable decoding of indexed textures
Enable dynamic shader

note:faster but no shadow. I can't find a good setting to solve ACE telesport miss card effects

Tales of The World: Radiant Mythology 2
Use vertex cache
Use shaders
Enable saving GE screen to textures instead of memory
Enable dynamic shader
note: map have a black border, I can't find a settings to solve it.

Tenchu 4
Use shaders
Enable saving GE screen to textures instead of memory
Enable dynamic shader
Enable the shader implementaion for the "Stencil Test"
@git15
thinks for fixed fog effects
retest Final Fantasy Type-0
external software renderer
but something didn't need get fog effects
[attachment=17074]
PPSSPP
[attachment=17075]
the graphical issues, the disappear ACG card, using CLUT will help, and that is What's new in ppsspp v0.9.9 https://github.com/hrydgard/ppsspp
jpcsp opengl
no fog effects, but have ACG card if enable decoing of indexed textures (using CLUT)
about CLUT, I think PPSSPP is better than jpcsp
[attachment=17076]

retest Tenchu 4
external software renderer
[attachment=17077]
opengl
[attachment=17078]
Tales of The World: Radiant Mythology 2
Opengl
[attachment=17079]
external software renderer
loading crash
[attachment=17080]
test external software renderer 0d92847
The World: Radiant Mythology 2
fog not get right effects, and map disappear
[attachment=17092]
[attachment=17093]
[attachment=17094]
(07-26-2014 01:33 AM)onelight Wrote: [ -> ]test external software renderer 0d92847
The World: Radiant Mythology 2
fog not get right effects, and map disappear
Again new fog improvements in external software renderer 9b01894 and OpenGL fog implementation in r3570.
(07-28-2014 03:54 PM)gid15 Wrote: [ -> ]
(07-26-2014 01:33 AM)onelight Wrote: [ -> ]test external software renderer 0d92847
The World: Radiant Mythology 2
fog not get right effects, and map disappear
Again new fog improvements in external software renderer 9b01894 and OpenGL fog implementation in r3570.
Think you
test external software renderer 9b01894
[attachment=17114]
[attachment=17115]

opengl
Still no fog effect
[attachment=17116]
[attachment=17117]
(07-29-2014 07:22 AM)onelight Wrote: [ -> ]opengl
Still no fog effect
Which OpenGL settings are you using?
Pages: 1 2
Reference URL's