EmuNewz Network

Full Version: problem using netbeans
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When i run jpcsp this is what shows

Code:
run:
Exception in thread "GUI" java.lang.NullPointerException
        at javax.swing.ImageIcon.<init>(ImageIcon.java:167)
        at jpcsp.MainGUI.initComponents(MainGUI.java:592)
        at jpcsp.MainGUI.<init>(MainGUI.java:124)
        at jpcsp.MainGUI$39.run(MainGUI.java:1515)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269​)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174​)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
BUILD SUCCESSFUL (total time: 5 seconds)

if i use the launcher i get an error: "Could not find the main class: jpcsp.ManGUI. Program will exit" (I check the main project properties and i see that "jpcsp.MainGUI" is set as the main class).

Its strange because like a month ago i could compile working versions of jpcsp with netbeans...
any idea of what im doing wrong?

btw im going to try with eclipse
Code:
MainGUI.java:592
        Polish.setIcon(new javax.swing.ImageIcon(getClass().getResource("/jpcsp/icons/flags/pl_PL.PNG"))); // NOI18N
This is the line with the new polish icon (introduced in r1581). Is it maybe missing in your checkout?
(06-18-2010 08:18 PM)gid15 Wrote: [ -> ]
Code:
MainGUI.java:592
        Polish.setIcon(new javax.swing.ImageIcon(getClass().getResource("/jpcsp/icons/flags/pl_PL.PNG"))); // NOI18N
This is the line with the new polish icon (introduced in r1581). Is it maybe missing in your checkout?

Thats it.
I check the jpcsp.icons.flags package from netbeans but i coudnt find that icon...

Then i checked C:\jpcsp\src\jpcsp\icons\flags and it was there "pl_PL.PNG", i changed is name to "pl_PL.png" open netbeans again compile, run and... another error Dodgy

Code:
run:
Exception in thread "GUI" java.lang.UnsatisfiedLinkError: no jogl in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1734)
        at java.lang.Runtime.loadLibrary0(Runtime.java:823)
        at java.lang.System.loadLibrary(System.java:1028)
        at com.sun.opengl.impl.NativeLibLoader.loadLibraryInternal(NativeLibLoader.java:189​)
        at com.sun.opengl.impl.NativeLibLoader.access$000(NativeLibLoader.java:49)
        at com.sun.opengl.impl.NativeLibLoader$DefaultAction.loadLibrary(NativeLibLoader.ja​va:80)
        at com.sun.opengl.impl.NativeLibLoader.loadLibrary(NativeLibLoader.java:103)
        at com.sun.opengl.impl.NativeLibLoader.access$200(NativeLibLoader.java:49)
        at com.sun.opengl.impl.NativeLibLoader$1.run(NativeLibLoader.java:111)
        at java.security.AccessController.doPrivileged(Native Method)
        at com.sun.opengl.impl.NativeLibLoader.loadCore(NativeLibLoader.java:109)
        at com.sun.opengl.impl.windows.WindowsGLDrawableFactory.<clinit>(WindowsGLDrawableFactory.java:60)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at javax.media.opengl.GLDrawableFactory.getFactory(GLDrawableFactory.java:106)
        at javax.media.opengl.GLCanvas.chooseGraphicsConfiguration(GLCanvas.java:520)
        at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:131)
        at javax.media.opengl.GLCanvas.<init>(GLCanvas.java:90)
        at jpcsp.HLE.pspdisplay.<init>(pspdisplay.java:175)
        at jpcsp.HLE.pspdisplay.getInstance(pspdisplay.java:77)
        at jpcsp.MainGUI.<init>(MainGUI.java:133)
        at jpcsp.MainGUI$39.run(MainGUI.java:1515)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269​)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174​)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

perhaps is something related to tortoise svn because i get the same error with eclipse[/quote]
Code:
run:
Exception in thread "GUI" java.lang.UnsatisfiedLinkError: no jogl in java.library.path
For this problem, you need to add the following JVM option: "-Djava.library.path=lib/windows-x86"
ok thx, now its working ^^
i changed "-Djava.library.path=lib/win32" for "-Djava.library.path=lib/windows-x86"
now, i have a problem running Jpcsp out of netbeans.
Using hyakki launcher i get this error "Could not find the main class: jpcsp.ManGUI. Program will exit"

Using the start-windows-x86.bat

Code:
Running Jpcsp 32bit...
Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/opengl/GL
EventListener
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$000(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
Caused by: java.lang.ClassNotFoundException: javax.media.opengl.GLEventListener
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 12 more
Could not find the main class: jpcsp.MainGUI. Program will exit.

i just put the compiled Jpcsp.jar inside bin folder (i think i used the last automated svn revision)
nvm... i changed the manifest file for an old one and now its working
Reference URL's